Plasmashell crashing after new updates

Hello, I posted this on Reddit but wanted to share here in case I would reach other people because I really want a fix! After installing the most recent updates yesterday on fedora 40, plasmashell now crashes after putting my password in SDDM. My wallpaper will flash for a second before the crash reporting window shows up and the background goes black. I can use KRunner to launch programs still so I have access to a terminal etc to troubleshoot the issue.

Here is the result of asahi-diagnose and
here is the stderr output when running plasmashell manually.

Update: If I create a new user account and log into it, plasmashell works fine! Now I have to find the difference between the accounts.

The problem was with the memory usage widget I had on my taskbar

@dylanchapell thank you for the hint!
In my case I had to remove the following from ~/.config/plasma-org.kde.plasma.desktop-appletsrc:

[Containments][2][Applets][32]
immutability=1
plugin=org.kde.plasma.systemmonitor.cpu

[Containments][2][Applets][32][Configuration]
CurrentPreset=org.kde.plasma.systemmonitor
PreloadWeight=100

[Containments][2][Applets][32][Configuration][Appearance]
chartFace=org.kde.ksysguard.linechart
title=Total CPU Use

[Containments][2][Applets][32][Configuration][ConfigDialog]
DialogHeight=720
DialogWidth=960

[Containments][2][Applets][32][Configuration][SensorColors]
cpu/all/usage=239,76,168

[Containments][2][Applets][32][Configuration][Sensors]
highPrioritySensorIds=["cpu/all/usage"]
lowPrioritySensorIds=["cpu/all/cpuCount","cpu/all/coreCount"]
totalSensors=["cpu/all/usage"]

[Containments][2][Applets][33]
immutability=1
plugin=org.kde.plasma.systemmonitor.memory

[Containments][2][Applets][33][Configuration]
CurrentPreset=org.kde.plasma.systemmonitor
PreloadWeight=100

[Containments][2][Applets][33][Configuration][Appearance]
chartFace=org.kde.ksysguard.linechart
title=Memory Usage

[Containments][2][Applets][33][Configuration][ConfigDialog]
DialogHeight=720
DialogWidth=960

[Containments][2][Applets][33][Configuration][SensorColors]
memory/physical/used=239,76,168

[Containments][2][Applets][33][Configuration][Sensors]
highPrioritySensorIds=["memory/physical/used"]
lowPrioritySensorIds=["memory/physical/total"]
totalSensors=["memory/physical/usedPercent"]

So basically anything with the prefix [Containments][2][Applets][32] and [Containments][2][Applets][33]. But this probably changes depending on the desktop configuration.
So for anyone finding this issue: you can search for plugin=org.kde.plasma.systemmonitor. and delete the entire configuration for that applet.

It looks like it’s a problem with the graph, which I really liked. I hope this gets fixed soon!

This seems to have been fixed in the latest update.

It was supposed to be, but plasmashell is still crashing for me (but persenting a little different). I will dig in more when I have time.

Interesting. For me the applet works when it’s just there in the panel, but when I click it, plasmashell seems to restart (it probably crashes). Though that’s an improvement over the previous behavior of continually crashing plasmashell.

Here is the RAM and CPU graph in my panel:
Screenshot_20240527_143502

Yes, that is the same behavior I am seeing. When I run plasmashell from the console, it says “wayland protocol error” before closing. It seems to be a purposeful restart of plasmashell and not a crash, as there is no GDB backtrace.
I tried to get a log but forgot to redirect stderr. I will get one and file another bug report eventually, but feel free to file one yourself if you want to. Here was my last bug report: 487344 – Memory Usage widget in Task Manager crashes plasmashell on Fedora Asahi Remix 40

Looks like the crash when clicking the applet is now also fixed!

Not fixed for me unfortunately

1 Like

This also happens here under Fedora 40. Looks like plasmashell will crash under high memory consumption or unlocking.

Did you update your system? If you have a fresh install you probably have an old kernel with an issue with kernel panics that has already been fixed (we just haven’t updated the images yet).