Plasma sleeps during dolphin filecopy

Can someone please verify in case this is an issue specific to my environment? TIA


  1. Fresh install of Kinoite 39
  2. use defaults for power settings (sleep in 10)
  3. copy files from an external USB to $HOME/somewhere in dolphin
  4. come back in 11 minutes

Observed behavior:
system has gone to sleep.

Expected behavior:
file copy keeps system awake

Keeping the system awake depends upon keyboard or mouse activity. Anything else is ignored.

This seems related and the discussion has lots of comments.

Can you file a bug report in the KDE bug tracker: ? Thanks

A bug report would be immaterial. The change was deliberate with F38 release and I don’t believe it will be reversed. That linked discussion has several methods to turn off the auto-suspend issue that users are welcome to use.

I believe the decision was based on an attempt to make the OS more eco-friendly by reducing power demands overall.

For GNOME maybe, but this report is about Kinoite (KDE).

Please file a bug report so that options can be considered.

I am not sure about kinoite or silverblue, but as I understood it the change affected all the various spins but the fedora server release – regardless of the desktop involved. If kinoite or silverblue was not involved then that is news to me.

Applications my inhibit suspend using systemd-inhibit. It would be reasonable for Dolphin to inhibit suspend while a file copy is running for example and then lift that inhibit when it’s completed.


Thank you.