Periodic full-system stutters for 2-3 seconds

Hi all - for the past week or so, I’ve seen about once or twice per day what I’d describe as a full-system stutter - mouse cursor movement, audio, and the display all seem to refresh/update once per half-second or so. After about 2-3 seconds, it resolves, and there seem to be no ill after-effects. The last two times this happened were while using Firefox with some music and other apps in the background, and while playing a full-screen game (via Steam, Mass Effect Legendary Edition).

It’s not an enormous deal since it’s happening so infrequently during the day, but I’d rather figure out what’s causing it of course. My first thought was that something must surely stick out in the logs, so when it just happened a few minutes ago, I immediately opened the Logs app and grabbed the prior minute of activity - and nothing really sticks out to me? Are there particular system-level things I should look for here?

Any ideas on what to potentially look for would be much appreciated!


My system:

  Kernel: 6.1.7-200.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Desktop: GNOME v: 43.2 tk: GTK v: 3.24.36 wm: gnome-shell
    dm: GDM Distro: Fedora release 37 (Thirty Seven)
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec2xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 88DD v: 96.33 serial: <superuser required> UEFI: AMI
    v: F.22 date: 08/10/2022
  ID-1: BAT0 charge: 46.9 Wh (99.4%) condition: 47.2/47.2 Wh (100.0%)
    volts: 12.7 min: 11.6 model: HP Primary serial: <filter>
    status: not charging
  Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A
    status: N/A
  Info: 6-core model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 384 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 2736 high: 4005 min/max: 1200/4280 boost: enabled cores:
    1: 3367 2: 3120 3: 4005 4: 2621 5: 2350 6: 3300 7: 1200 8: 1200 9: 3364
    10: 1200 11: 3807 12: 3300 bogomips: 79047
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU117M vendor: Hewlett-Packard driver: nvidia v: 525.78.01
    arch: Turing pcie: speed: 2.5 GT/s lanes: 8 ports: active: none
    empty: HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:1f99
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Hewlett-Packard driver: amdgpu v: kernel arch: GCN-5.1 pcie:
    speed: 8 GT/s lanes: 16 ports: active: eDP-1 empty: none bus-ID: 05:00.0
    chip-ID: 1002:1638 temp: 46.0 C
  Device-3: Luxvisions Innotech HP TrueVision HD Camera type: USB
    driver: uvcvideo bus-ID: 3-3:3 chip-ID: 30c9:0035
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.7
    compositor: gnome-shell driver: X: loaded: amdgpu,nvidia
    unloaded: fbdev,modesetting,nouveau,vesa alternate: nv dri: radeonsi
    gpu: amdgpu display-ID: 0
  Monitor-1: eDP-1 model: BOE Display 0x094d res: 1920x1080 dpi: 142
    diag: 395mm (15.5")
  API: OpenGL v: 4.6 Mesa 22.3.3 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.6 DRM 3.49 6.1.7-200.fc37.x86_64) direct render: Yes
  Device-1: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    pcie: speed: 2.5 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:10fa
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Hewlett-Packard
    driver: N/A pcie: speed: 8 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
  Device-3: AMD Family 17h/19h HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 05:00.6 chip-ID: 1022:15e3
  Sound API: ALSA v: k6.1.7-200.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.64 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek RTL8852AE 802.11ax PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw89_8852ae v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8852
  IF: wlo1 state: up mac: <filter>
  IF-ID-1: enp5s0f3u1c4i2 state: down mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:2 chip-ID: 0bda:2852
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 195.93 GiB (41.1%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ512HALU-000H1
    size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 34.9 C
  ID-1: / size: 475.35 GiB used: 195.6 GiB (41.1%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 319.5 MiB (32.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 475.35 GiB used: 195.6 GiB (41.1%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 8 GiB used: 440.5 MiB (5.4%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 59.4 C mobo: N/A gpu: amdgpu temp: 47.0 C
  Fan Speeds (RPM): fan-1: 0 fan-2: 0
  Processes: 425 Uptime: 8h 13m Memory: 14.97 GiB used: 6.72 GiB (44.8%)
  Init: systemd v: 251 target: graphical (5) default: graphical Compilers:
  gcc: 12.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm pm: flatpak pkgs: 34
  Shell: Bash v: 5.2.15 running-in: gnome-terminal inxi: 3.3.24

Logs grabbed from right after the problem occurred, at 9:49 PM:

9:49:06 PM wpa_supplicant: wlo1: CTRL-EVENT-BEACON-LOSS
 9:49:03 PM gnome-shell: meta_window_set_stack_position_no_sync: assertion 'window->stack_position >= 0' failed
 9:49:02 PM dleyna-renderer: dLeyna: Exit
 9:49:02 PM wpa_supplicant: wlo1: CTRL-EVENT-BEACON-LOSS
 9:49:01 PM systemd: Started dbus-:1.2-org.gnome.Logs@0.service.
 9:49:01 PM dleyna-renderer: Client :1.289 lost
 9:49:01 PM packagekitd: resolve transaction /4799_bccedbec from uid 1000 finished with success after 3ms
 9:49:01 PM wpa_supplicant: wlo1: CTRL-EVENT-BEACON-LOSS
 9:49:01 PM dleyna-renderer: Calling GetRenderers method
 9:49:01 PM systemd: Started\x2drenderer@2.service.
 9:49:01 PM nautilus: Source ID 108 was not found when attempting to remove it
 9:49:01 PM systemd: Started dbus-:1.2-org.gnome.DiskUtility@2.service.
 9:49:01 PM gnome-character: JS LOG: Characters Application started
 9:49:01 PM systemd: Started gnome-terminal-server.service - GNOME Terminal Server.
 9:49:01 PM nautilus: Connecting to org.freedesktop.Tracker3.Miner.Files
 9:49:01 PM systemd: Starting gnome-terminal-server.service - GNOME Terminal Server...
 9:49:01 PM systemd: Starting gnome-terminal-server.service - GNOME Terminal Server...
 9:49:01 PM systemd: Started dbus-:1.2-org.gnome.clocks@2.service.
 9:49:01 PM systemd: Started dbus-:1.2-org.gnome.Settings.SearchProvider@2.service.
 9:49:01 PM systemd: Started dbus-:1.2-org.gnome.Photos@2.service.
 9:49:01 PM systemd: Started dbus-:1.2-org.gnome.Nautilus@2.service.
 9:49:01 PM systemd: Started dbus-:1.2-org.gnome.Contacts.SearchProvider@2.service.
 9:49:01 PM systemd: Started dbus-:1.2-org.gnome.Characters@2.service.
 9:49:01 PM systemd: Started dbus-:1.2-org.gnome.Calculator.SearchProvider@2.service.
 9:49:01 PM systemd: Started dbus-:1.2-org.gnome.Boxes.SearchProvider@2.service.
 9:49:00 PM wpa_supplicant: wlo1: CTRL-EVENT-BEACON-LOSS

I’m curious if it tends to happen when you’re using your discrete graphics card? (Nothing is otherwise obvious to me from the logs, but this is all great info for a new topic.)

1 Like

Interesting - the first time I noticed was definitely during discrete (Nvidia) card use, as it was while playing Steam games and I know they are configured to use the discrete card.

This most recent time, I wasn’t in anything that I’m aware of that explicitly uses it, but I was using several apps at a time - the ones I can think of that might potentially have a connection would be Firefox, Brave and Cider. Some of those probably use hardware acceleration for video, perhaps?

(I think) unrelated to graphics, but IIRC I do also think that I’ve had my iPhone plugged into my PC each time - is there a potential that the nautilus: Source ID 108 was not found when attempting to remove it line might be related to that (like running into something funky accessing the iPhone’s files)? Just wondering as nautilus has probably been the least stable program that I’ve noticed on my PC in the 2-3 months or so that I’ve been running Fedora daily (just in terms of the most visible crashes).

Thanks for the help and ideas!

I’ve been having the same issue for about a week now. I think it has something to do with Nvidia driver 525.78.01; started happening when I upgraded to that version. Could just be a coincidence of course.


I’ve been having this issue as well, and I think it might be caused by the 6.1 kernel. I’m on Silverblue so it’s a bit hard to just downgrade the kernel to test, but I ran Rawhide for a bit while it was still on the 6.1 rc releases and had the issue, downgraded back to 37 and it was gone, until that got 6.1 as well and it started appearing again.
Just for completeness, my system is a Ryzen 3900X with an RX 6700XT, running Silverblue 37.

1 Like

Thanks @fryyx ! It could be connected in some way to what you’re experiencing - the thing that makes me think it’s not that specifically for my case is that I updated to that Nvidia driver version back in mid-December, about a day after it was released via RPMFusion, and didn’t see this stuttering until the past week or so.

Thanks @junglerobba ! The timing of that kernel release might make sense - I’m searching around for any related info now and came across these links:

Which led to looking at it from the AMD-specific angle, and things like this:

But it seems strange that an issue like that would, on its own, only cause issues in 6.1? I’ve been searching around, and can’t find/understand enough of what changed in between 6.0 and 6.1 around TPM - but it doesn’t seem like anything massive that would have worked around the AMD issue in the past but been dropped now?

I may be going too far down a rabbit hole on that one, but one thing I did eliminate is the iPhone being connected - I haven’t connected my iPhone since my last reboot, and just had the stuttering a little bit ago while music was playing and I had stepped away from my PC.

Thank you for sharing those threads; seems unlikely to be the nvidia driver if an all-AMD system is having the same problem.

I’ve updated my BIOS (Fix AMD fTPM issue causes random stuttering.), but as you mention, it’s strange that only 6.1 would be impacted by this.

I’ll report back if the issue persists. Let me know if you need any help with testing/troubleshooting!

I happened across this thread on Reddit today - specifically what is referenced in the linked comment around dleyna - and I suspect this may be the culprit as it was one of the error-looking messages in my logs!

So the concerning thing there…the packages that may be causing this are no longer maintained, according to the page linked to in the ‘info’ available when querying in dnf:

Installed Packages
Name         : dleyna-renderer
Version      : 0.6.0
Release      : 15.fc37
Architecture : x86_64
Size         : 169 k
Source       : dleyna-renderer-0.6.0-15.fc37.src.rpm
Repository   : @System
From repo    : anaconda
Summary      : Service for interacting with Digital Media Renderers
URL          :
License      : LGPLv2
Description  : D-Bus service for clients to discover and manipulate DLNA Digital
             : Media Renderers (DMRs).

So then maybe one question would be…is the work on this page equivalent to what had been done in the now-discontinued package?

Is that an appropriate question for the devel mailing list, or some other channel?

Edit: Looks like there’s a Bugzilla bug submitted for updating this - I added a link to this thread if it’s helpful, but it looks like updating the version packaged with Fedora would now be in the hands of one of the maintainers? (Sorry but I’m such a novice on these topics / don’t have development experience, I looked at the package maintenance documents and could barely make sense of them so I don’t know if I’m up to the task of helping do it myself?)

Hi Adam - just curious if your BIOS update fixed your issue? I just applied a firmware update from HP for my laptop, with completely useless changelog notes (“Enhanced security”) but hoping that perhaps that could include the AMD fTPM fix?

Hi John,

I haven’t seen the issue since I updated my BIOS. I’m assuming that fixed it, as I didn’t change anything else other than dnf updates.

I was seeing it every hour or two prior to the update, but haven’t seen it since (and I’ve spent a lot of time playing Path of Exile lately…).

Hopefully the firmware update helps on your end!

Thanks! I just so happened to experience the same stuttering as I was typing this, so unfortunately the HP update either didn’t integrate the AMD fix, or there’s some other cause - still not seeing anything different showing up in the logs than what was showing originally, so I’m taking a stab at resetting the tracker3 database just in case.


1 Like

I have the same issue.

  Kernel: 6.1.12-200.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Console: pty pts/1 Distro: Fedora release 37 (Thirty Seven)
  Type: Laptop System: LENOVO product: 82NW v: Legion 5 15ACH6A
    serial: <filter>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76462 WIN serial: <filter>
    UEFI: LENOVO v: G9CN29WW date: 06/02/2022
  Info: 8-core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 1700 high: 3200 min/max: 1200/4462 boost: enabled cores:
    1: 1200 2: 1200 3: 1200 4: 3200 5: 1200 6: 1200 7: 1200 8: 1200 9: 1200
    10: 3200 11: 1200 12: 3200 13: 3200 14: 1200 15: 1200 16: 1200
    bogomips: 102206
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: Lenovo
    driver: amdgpu v: kernel arch: RDNA-2 bus-ID: 03:00.0
  Display: server: X.Org v: 22.1.8 with: Xwayland v: 22.1.8 driver:
    dri: radeonsi gpu: amdgpu note: X driver n/a resolution: 1920x1080~165Hz
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: AMD Radeon RX 6600M (navi23 LLVM
    15.0.7 DRM 3.49 6.1.12-200.fc37.x86_64) direct-render: Yes
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    bus-ID: 03:00.1
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    bus-ID: 07:00.5
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 07:00.6
  Sound API: ALSA v: k6.1.12-200.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.66 running: yes

please check:

the fix is merged into 6.1.19 and 6.2.6 or later kernel
this should help you:)

1 Like

I just saw a blog post about that today - thank you for connecting the dots back to this!

Glad this could help you.
Could you please update the kernel to any version (or higher) I mention before and do “journalctl -b --no-pager | grep tpm” to see the output in the terminal?
Because someone in bugzilla said he can’t get the tpm disabled dmesg in 6.2.6-fedora kernel.
thx very much!