Nvidia Driver with Kernel 5.9.11 Generating High CPU usage and Lag

Hello. I have recently updated to the Linux 5.9.11 kernel. I am aware that Nvidia have had some issues updating their drivers for this kernel, but I was under the impression that the problems had been solved. It seems, though, that the Nvidia drivers I’ve installed are severely imbalanced. Running the top command shows excessivly high idle CPU usage when the drivers are installed, primarily through X11 (Xorg) and Nvidia:

1888 root      20   0       0      0      0 S  44.7   0.0  14:43.05 nvidia-+ 
2869 ********  20   0  328828 111748  83856 S  23.8   0.3   8:41.89 Xorg     

and the mouse lags considerably. I would love to get to the bottom of this problem. Would anyone have any suggestions? I am not very familiar with kernels and drivers.

What is your hardware and currently installed drivers.?

The output of “inxi -bG” will give us enough info to start.
I am running 33 with nvidia GeForce GTX 1050 using the nvidia 455.45.01 drivers and have never had any problems with it.

Hello, I am using a GeForce GTX 1650, also with the 455.45.01 driver. If I roll back to the old kernel (5.6), the drivers work fine but my Wifi loses connectivity. When I update to the 5.9 kernel, my wifi is able to connect but the nvidia drovers produce the effect comnmented above, and I have to roll back to nouveau drivers. I need the wifi much more than the drivers

Edit: Okay so it seems that I can no longer boot into previous kernels/fedora versions from the grub menu. This all seems very odd and slightly more worrying.

OK, but still I have no problems and you do.

Where did you download the nvidia drivers from? It seems a lot of people who download and install them directly from nvidia have problems.
I have always used the packages from rpmfusion and have never seen problems. There are other sources, but I have never tried them.

First, I tried the GUI i.e. the fedora software application. When that failed I tried installing the rpm’s straight from the command line with sudo dnf install akmod-nvidia. They are essentially the same thing, but, you never know. Long story, short, they are indeed from rpmfusion. As I mentioned, they worked fine with kernel 5.6, so I would imagine there’s some problem with the new kernel, but I might be wrong. Not sure if this is relevant; I also get a program crashing every time I boot up: dleyna-renderer

Since a renderer depends on the graphics I would suggest removing the one that crashes “every time I boot up” (dleyna-renderer) and see if the problem persists or goes away. If it goes away then you found the problem. If not then it may need more digging. Even if not directly related to the video issue the repeated crashing should be fixed.

I note that removing an entire renderer, especially one that is fundamental to a gnome-built application, is not a reasonable solution. Don’t want to be rude, and I do really appreciate your help, but it is, I think, reasonable to expect that a solution not be to just throw away an application. Anyway I did try uninstalling dleyna-renderer, just to see, and the problem persists. This is clearly not a renderer issue. We are all aware that Nvidia have had problems updating their drivers with the 5.9 kernel, so it isn’t surprising that such an issue has come up.

I also note that I have had a similar problem that was resolved in this solution by disabling the wayland login. Unfortunately, this solution has not worked here.

Just curious @computersavvy savvy, you mentioned that you have fedora 33 running. Which kernel do you have installed there? Perhaps, if you have 5.6 running, that is why your computer is running smoothly and mine is not?

$ uname -a
Linux eagle.home.domain 5.9.11-200.fc33.x86_64 #1 SMP Tue Nov 24 18:18:01 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

# dnf list installed '*nvidia*'
Installed Packages
akmod-nvidia.x86_64                                                           3:455.45.01-3.fc33                                      @rpmfusion-nonfree-updates
kmod-nvidia-5.8.16-300.fc33.x86_64.x86_64                                     3:455.45.01-1.fc33                                      @@commandline             
kmod-nvidia-5.9.10-200.fc33.x86_64.x86_64                                     3:455.45.01-3.fc33                                      @@commandline             
kmod-nvidia-5.9.11-200.fc33.x86_64.x86_64                                     3:455.45.01-3.fc33                                      @@commandline             
nvidia-modprobe.x86_64                                                        3:455.45.01-1.fc33                                      @rpmfusion-nonfree-updates
nvidia-persistenced.x86_64                                                    3:455.45.01-1.fc33                                      @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                        3:455.45.01-1.fc33                                      @rpmfusion-nonfree-updates
nvidia-xconfig.x86_64                                                         3:455.45.01-1.fc33                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                                    3:455.45.01-1.fc33                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                                               3:455.45.01-1.fc33                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                                          3:455.45.01-1.fc33                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-devel.x86_64                                              3:455.45.01-1.fc33                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                            3:455.45.01-1.fc33                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                               3:455.45.01-1.fc33                                      @rpmfusion-nonfree-updates

# dnf list installed '*render*'
Installed Packages
blender-luxcorerender.x86_64                                              2.5-0.1beta1.fc33                                                             @updates
dleyna-renderer.x86_64                                                    0.6.0-8.fc33                                                                  @fedora 
libXrender.x86_64                                                         0.9.10-12.fc33                                                                @fedora 
libXrender-devel.x86_64                                                   0.9.10-12.fc33                                                                @fedora 
luxcorerender.x86_64                                                      2.5-0.1beta1.fc33                                                             @updates
luxcorerender-core.x86_64                                                 2.5-0.1beta1.fc33                                                             @updates
virglrenderer.x86_64                                                      0.8.2-2.20200212git7d204f39.fc33                                              @fedora 
xcb-util-renderutil.x86_64                                                0.3.9-17.fc33                                                                 @fedora 

Running gnome 3.38.2
Everything updated as of last night.

1 Like

Hmm, thank you for that. This leads me to think that the recently updated drivers may be incorrectly communicating between the kernel and the physical GPU. This is starting to sound like something I am going to have to contact Nvidia about. For now, I have rolled back to Fedora 32 with the 5.6 kernel and a 30m ethernet cable. Now, noting my Nvidia dnf installed list:

akmod-nvidia.x86_64                                3:455.45.01-3.fc33 
kmod-nvidia-5.9.11-200.fc33.x86_64.x86_64          3:455.45.01-3.fc33 
nvidia-settings.x86_64                             3:455.45.01-1.fc33 
xorg-x11-drv-nvidia.x86_64                         3:455.45.01-1.fc33 
xorg-x11-drv-nvidia-kmodsrc.x86_64                 3:455.45.01-1.fc33 
xorg-x11-drv-nvidia-libs.x86_64                    3:455.45.01-1.fc33 

I’m not sure if your old drivers are relevent (I could very easily be wrong) but I seem to be missing packages that you have, including cuda, the devel and, importantly, modprobe. Note, the copy/paste for the nvidia process in top, found in the first post, cut out the last part of the command label, which actually reads nvidia-modeset/. Apologies for that. I’ll try install the differentiating rpm’s tomorrow and let you know if that solves the problem.

Old Drivers? I had the same 455.45.01 drivers as you when I posted. The version and repo can be seen by scrolling to the right on my post…
Did you download and install the kmod package or was it built by the akmod package. The way you posted does not show the repo they came from, and I have seen numerous posts with problems when drivers were installed from a different repo but solved when they switched to rpmfusion.

The command I used to install the nvidia packages from rpmfusion was simple after I made sure both kernel-devel and kernel-headers packages were installed.

 sudo dnf install akmod-nvidia nvidia* xorg-x11-drv-nvidia* 

That handled all the packages you see in my post, all from rpmfusion, and I have never seen any problems with drivers.

1 Like

So I have tried installing the aforementioned packages and booting into the updated kernel. Unfortunately, that hasn’t fixed the problem. FYI, indeed the packages are from the akmod bundle, indeed from rpmfusion non-free. There is absolutely no difference between this set of packages except for the old drivers you have from the old kernel. Indeed, I used the same command to install all the packages that you did in the last post. Time to notify Nvidia.

Note: this issue with the dleyna renderer is documented here: 1903139 – Crash in prv_cancel_only