Org.gnome.gedit cannot always read or write files exposed by gsconnect (gvfs/sftp)

I am using these packages installed by rpm-ostree:

  • gnome-shell-extension-gsconnect-38-1.fc32.x86_64
  • nautilus-3.36.2-1.fc32.x86_64

and this one installed by flatpak (remote: oci+

  • app/org.gnome.gedit/x86_64/stable version 3.36.2 (commit: 35660185cbe0620afa24c56b558c7adad9fa69776707a51bf1b329711b677d1b)

Additionally, I defined this override:

$ flatpak override --show org.gnome.gedit

gsconnect enables access to Android storage via gvfs/sftp, and the override above should suffice to enable read and write of such files by gedit but actual behavior varies:

  1. flatpak run org.gnome.gedit
    Error message on startup (banner): none
    Preferences applied: yes
    Write error: (
    Could not save the file “/run/user/1000/gvfs/sftp…/a.txt”.
    Cannot handle “file:” locations in write mode. Please check that you typed the location correctly and try again.
  2. open gsconnect file from nautilus
    Error message on startup (banner): (
    Could not open the file “sftp://…”.
    Unable to handle “sftp:” locations.
    Preferences applied: no (implied by default color scheme)
    NOTE: gedit runs with switch --gapplication-service. Gsconnect files opened from integrated file browser open in new tabs that behave as described in #1.
  3. flatpak run --command=sh org.gnome.gedit
    Can read and write gsconnect files.

I’m stuck on how to troubleshoot. Any ideas?

Have you tried uninstalling and using the flathub version instead? Might be worth it to rule out strangeness with the fedora registry version. I’ve had issues with nearly every fedora flatpak in some way (some innocuous (eg. locale errors), some less so (epiphany didn’t work at all last I tried). Flathub, though, has mostly worked really well. Probably not relevant, but doesn’t hurt to rule it out.