NVIDIA Suspend Problems - unresponsive black screen on suspend

I recently switched to Silverblue recently and after installing the NVIDIA proprietary drivers (I did not test this with the nouveau drivers) the suspend functionality stopped working reliably. When I try to suspend, sometimes it suspends properly but (seemingly randomly) most of the time the screen turns black and becomes unresponsive but the fans keep running, the lights on my mouse stay on and the keyboard still responds to pressing caps/num lock. I have already tried this (screenshot below if link goes missing in the future), however it did not help. I am on driver version 550.90.07 and have an RTX 3060 GPU and a Ryzen 5 5600X CPU (if that’s of any use).

I’ve tried suspending 5-6 times and it has suspended properly every time so I think this worked. I used rpm-ostree kargs --editor to edit the kernel flags and I appended the flag mem_sleep_default=deep. This forces it to enter S3 (deep) sleep and not S0ix, which is what I think was happening before. Also see this, which is where I got the kernel flag from.

1 Like