Nvidia: How to Prevent reseting settings after disconnecting second monitor

my main monitor gives error: input not supported

when i connect old monitor as second monitor and setting in nvidia control panel my main monitor to 60hz instead of 75hz error dissapear but after i disconnect second monitor main monitor giving error: input not supported

nvidia reseting settings for main monitor after disconnecting second monitor
how i prevent that?

Please, with both monitors attached, post the output of inxi -Fzxx so we can see the config and how the system recognizes the monitors.


sorry for long time reply but i don’t have old monitor now

after thousand of reboots and trying to change hz
i changed monitor hz in gnome settings now i can launch wayland but on xorg error persist

on wayland nvidia settings showing gpu correctly

output of lswh -C display:

       description: VGA compatible controller
       product: GP107 [GeForce GTX 1050 Ti]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: iomemory:400-3ff iomemory:400-3ff irq:129 memory:91000000-91ffffff memory:4000000000-400fffffff memory:4010000000-4011ffffff ioport:3000(size=128) memory:c0000-dffff

output of inxi -Fzxx:

  Kernel: 6.1.8-200.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Desktop: GNOME v: 43.2 tk: GTK v: 3.24.36 wm: gnome-shell
    dm: GDM Distro: Fedora release 37 (Thirty Seven)
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: TUF GAMING B460-PLUS v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 1401
    date: 07/27/2020
  Info: quad core model: Intel Core i3-10100F bits: 64 type: MT MCP
    arch: Comet Lake rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 1801 high: 4300 min/max: 800/4300 cores: 1: 1696 2: 800
    3: 800 4: 4300 5: 1112 6: 800 7: 800 8: 4100 bogomips: 57600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte driver: nvidia
    v: 525.78.01 arch: Pascal pcie: speed: 8 GT/s lanes: 16 ports: active: none
    off: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 01:00.0 chip-ID: 10de:1c82
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.7
    compositor: gnome-shell driver: X: loaded: N/A unloaded: nvidia
    gpu: nvidia,nvidia-nvswitch display-ID: 0
  Monitor-1: HDMI-A-1 model: Acer SA230 res: 1920x1080 dpi: 81
    diag: 686mm (27")
  API: OpenGL v: 4.6.0 NVIDIA 525.78.01 renderer: NVIDIA GeForce GTX 1050
    Ti/PCIe/SSE2 direct render: Yes
  Device-1: Intel Comet Lake PCH-V cAVS vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 1-3:2 bus-ID: 00:1f.3 chip-ID: 0d8c:0012
    chip-ID: 8086:a3f0
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fb9
  Device-3: C-Media USB Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.1.8-200.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d55
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 2.15 TiB used: 1.18 TiB (54.8%)
  ID-1: /dev/sda vendor: Seagate model: ST2000DM001-9YN164 size: 1.82 TiB
    speed: 6.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: Gigabyte model: GP-GSTFS31120GNTD size: 111.79 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-3: /dev/sdc vendor: Leven model: JAJS300M240C size: 223.57 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-1: / size: 110.19 GiB used: 79.96 GiB (72.6%) fs: btrfs dev: /dev/sdb4
  ID-2: /boot size: 973.4 MiB used: 302.3 MiB (31.1%) fs: ext4
    dev: /dev/sdb3
  ID-3: /boot/efi size: 596.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/sdb2
  ID-4: /home size: 110.19 GiB used: 79.96 GiB (72.6%) fs: btrfs
    dev: /dev/sdb4
  ID-1: swap-1 type: zram size: 8 GiB used: 2 MiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 43.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 405 Uptime: 1h 47m Memory: 15.53 GiB used: 5.5 GiB (35.4%)
  Init: systemd v: 251 target: graphical (5) default: graphical Compilers:
  gcc: 12.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm pm: flatpak pkgs: 33
  Shell: Zsh v: 5.9 running-in: kitty inxi: 3.3.24

and when i start some electron app it showing gpu: GRAPHICS: GPU0: GP107 [GeForce GTX 1050 Ti] VRAM: 32MB

and when i reboot perfomance changing, like: i try to launch some game it showing 80fps and after reboot its 200fps

and when i login in 1 second it showing input not supported and then gnome desktop loads on wayland

and when i shutdown/reboot/logout error appear, and sometimes when i shutdown/reboot fedora shutted down but fans continue spinning and led working and motherboard doesnt react on reset/shutdown buttons and error showing

and when fedora boot up there is [FAILED] nvidia-powerd.service but i think its because of missing xorg-x11-drv-nvidia-cuda

and note that i dont install xorg-x11-drv-nvidia-cuda because error will appear,
i upgraded fedora from 36 > 37 and kernel from 5 > 6,
nvidia driver from rpmfusion,

Specifically what error appears.?
We need the exact message you see on the screen to determine the cause and assist in repair.

Please do dnf install xorg-x11-drv-nvidia-cuda and show us the command and all the text following.

It would also be helpful to see the output of
dnf list installed '*nvidia*' and lsmod | grep nvidia.

That inxi output shows you are using Wayland and that the nvidia driver may not be in use. Have you tried using xorg to see if there may be a difference?
Sometimes things work in xorg and not wayland, and vice versa.

xorg-x11-drv-nvidia actually installed but nvidia-smi command not found so i upgraded xorg-x11-drv-nvidia and now nvidia-smi working but input not supported error still on Gnome on xorg persist, sorry for misunderstanding

i mentioned that with Gnome on wayland driver works but in Gnome on Xorg, input not suported error persist so i cant enter Gnome on Xorg, i want to use Gnome on xorg because nvidia support for wayland is buggy

output of dnf list installed '*nvidia*'

Installed Packages
akmod-nvidia.x86_64                                                                3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.0.10-300.fc37.x86_64.x86_64                                          3:520.56.06-1.fc37                                          @@commandline                   
kmod-nvidia-6.1.7-200.fc37.x86_64.x86_64                                           3:525.78.01-1.fc37                                          @@commandline                   
kmod-nvidia-6.1.8-200.fc37.x86_64.x86_64                                           3:525.85.05-1.fc37                                          @@commandline                   
nvidia-gpu-firmware.noarch                                                         20230117-146.fc37                                           @updates                        
nvidia-persistenced.x86_64                                                         3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                                                             3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                                                         3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64                                                    3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.i686                                                 3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64                                               3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                                                 3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686                                                      3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                                                    3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                                                   3:525.85.05-1.fc37                                          @rpmfusion-nonfree-nvidia-driver

output of lsmod | grep nvidia:

nvidia_drm             73728  23
nvidia_modeset       1220608  5 nvidia_drm
nvidia_uvm           2904064  0
nvidia              56406016  556 nvidia_uvm,nvidia_modeset
video                  65536  2 asus_wmi,nvidia_modeset

output of nvidia-smi:

| NVIDIA-SMI 525.85.05    Driver Version: 525.85.05    CUDA Version: 12.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
|  0%   32C    P8    N/A /  72W |    377MiB /  4096MiB |      4%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      2109      G   /usr/bin/gnome-shell              149MiB |
|    0   N/A  N/A      2649      G   /usr/bin/Xwayland                  14MiB |
|    0   N/A  N/A      2948      G   kitty                              20MiB |
|    0   N/A  N/A      3165      G   /usr/lib64/firefox/firefox        186MiB |

and what is correct /etc/X11/xorg.conf here is current monitor config

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName	  "Acer SA230"
    HorizSync       55.0 - 60.0
    VertRefresh     50.0 - 60.0

What is correct Horizsync and VertRefresh for 60hz?

input not supported is acer monitor error not fedora or nvidia,

This is not the version of nvidia installed from rpmfusion on my system.
This is what is installed from rpmfusion on all my systems and I never have version mismatches.

| NVIDIA-SMI 525.78.01    Driver Version: 525.78.01    

It would appear you may be installing nvidia from nvidia or at least from different sources so the version mismatches occur.

Please post the output of dnf list installed '*nvidia*' again.

With installing nvidia drivers from rpmfusion the /etc/X11/xorg.conf file is not used at all. (does not even exist on any of my systems)

For me to assist in a way I am comfortable with I would assist in removing the drivers you currently have and then installing the drivers from the rpmfusion repo.

I just ran dnf upgrade *nvidia* --refresh and it picked up the 525.85.05 packages, so it seems I was a bit delayed in seeing the upgrade.

That said, it would seem that you could possibly remove the /etc/x11/xorg.conf file you presently have and the drivers should probably work out the monitor issue for you automatically.

Please post back here and let us know how that works out for you.

i removed /etc/X11/xorg.conf as you said, but nothing has changed still can’t login to Gnome on xorg because of input not supported only Gnome on wayland works

and i run ls in /etc/X11/ and there is some nvidia files, is this ok?

applnk  fontpath.d  xinit  Xmodmap  xorg.conf.backup  xorg.conf.d  xorg.conf.nvidia_uninstalled  Xresources  Xsession.d  Xwrapper.config

and in the past when i owned old monitor and old monitor and current are attached i logged in Gnome on xorg and with old monitor, opened nvidia-settings changed current monitor hz and there is save to xorg.conf and save buttons, so i click on save to xorg and /etc/X11/xorg.conf generated, and as i mentioned when i click save button, current monitor start working but after disconnecting old monitor, current monitor hz resets back to 75hz

in the past with old monitor only connected it works fine, but with my current monitor only connected Gnome on xorg not working so it might be acer problem if so why wayland works but xorg not?,

and in wayland nvidia-settings cant control monitor refresh rate and screen resolution, but in Gnome on xorg monitor refresh rate and screen resolution was controlled by nvidia-settings so does nvidia-settings config file exist if yes, where?

Without knowing the content of that file I cannot answer, but it does not exist on my system.

# ls /etc/X11
applnk  fontpath.d  xinit  Xmodmap  xorg.conf.d  Xresources  Xsession.d  Xsession.options  Xwrapper.config

Seemingly you may have installed nividia from some location other than rpmfusion in the past and invalid config files certainly can impact performance.

I only have a few files related to nvidia.

The one under /etc/X11/xorg.conf is one that was put in on my laptop to make the nvidia dGPU play nice with the laptop screen as well as external monitors and to use the dGPU as primary full time.
The other 2 were installed when I installed or upgraded the nvidia drivers so they were part of the nvidia install from rpmfusion.

I also only have this in /etc/default/grub that was added to that file during the nvidia install
rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init which was added into the GRUB_CMDLINE_LINUX= part of that file.

i dont install nvidia driver from other location, i only reinstalled nvidia-driver from rpmfusion

there is content of /etc/x11/xorg.conf.nvidia_uninstalled:

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"

Section "Files"
	ModulePath   "/usr/lib64/xorg/modules"
	FontPath     "catalogue:/etc/X11/fontpath.d"
	FontPath     "built-ins"

Section "Module"
	Load  "glx"
	Load  "glxserver_nvidia"

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	   "Protocol" "auto"
	Option	   "Device" "/dev/input/mice"
	Option	   "ZAxisMapping" "4 5 6 7"

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "VideoKey"           	# <i>
        #Option     "WrappedFB"          	# [<bool>]
        #Option     "GLXVBlank"          	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "PageFlip"           	# [<bool>]
        #Option     "SwapLimit"          	# <i>
        #Option     "AsyncUTSDFS"        	# [<bool>]
        #Option     "AccelMethod"        	# <str>
        #Option     "DRI"                	# <i>
	Identifier  "Card0"
	Driver      "nouveau"
	BusID       "PCI:1:0:0"

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	SubSection "Display"
		Viewport   0 0
		Depth     4
	SubSection "Display"
		Viewport   0 0
		Depth     8
	SubSection "Display"
		Viewport   0 0
		Depth     15
	SubSection "Display"
		Viewport   0 0
                Depth     16
	SubSection "Display"
		Viewport   0 0
		Depth     24

maybe its backup of /etc/X11/xorg.conf?

and there is a way to login in Gnome on Xorg with safe graphics? or change nvidia-settings refresh rate with wayland or config file?, because on wayland there is no monitors in nvidia-settings

and i installed i3wm and without /etc/X11/xorg.conf there is input not supported error with /etc/X11/xorg.conf it works! so maybe it problem with gnome? there is any gnome xorg configuration if yes where? and i tried to change nvidia-settings refresh rate in i3wm on i3 it changing but, config from i3wm not moving to Gnome on Xorg or not working

i installed kde plasma logged in Plasma (wayland) without nvidia drivers, changed refresh rate in system settings 75 > 60 restarted fedora with nvidia drivers, logged in Plasma (x11) and it works! and looks like refresh rate on i3wm and plasma changing but not changing in Gnome on xorg why? and this trick does not working on Gnome on Xorg

and refresh rate on i3wm and kde plasma is not the same looks like nvidia changing settings for only current desktop enirvoment how do i make nvidia-settings settings global?

hi, again after 2 months, im still cant fix issue, with login/reboot/logout and also i discovered that some native fullscreen games/applications use 75hz, even if there 60hz in kde and nvidia-settings so i AGAIN get input not supported so i need to use wine version of this applications :(, i tried changing refresh rate in every file i found(monitors.xml xorg.conf), did there other files that changing refresh rate, im just want to use fullscreen apps with 60hz, also im discovered that when logging to KDE plasma with 75hz and disconnect hdmi, and then connect refresh rate will be 60hz, also now if i try to use sddm without nvidia driver it will be in start loop(dark screen, and after console, dark screen, bassicaly infinite loop)

i3wm and plasma are discrete DEs as is gnome. Each has its own settings that must be set within the DE and are not intended to affect the others.

Settings within nvidia-settings also discretely affect the running DE so I am not sure it can be made global and applicable to the config of all installed DEs.

My suggestion –
Set the configs within your currently running DE as you desire and recognize that if you switch the running DE the configs may need to be set again there.

Your intent seems to be contrary to what most would expect. I certainly would not expect a config within gnome to dictate how my desktop appeared should I switch to plasma, or some other DE.

im switched to kde plasma, only it can work with x11, also today i updated to fedora 38 and now sddm gives Input Not Supported so im blind when i enter password, but i still can use workaround:

issue after every update more and more bigger, also after fedora 38 upgrade i dont need more to disconnect hdmi when logging in in kde plasma, and infinite start loop with noueveau driver on sddm fixed.

im just dont know how to fix that, please i dont want 75hz, i dont want ultra premium features i just want get rid of Input Not Supported, i only find one person that have same issue, but even this person found solution that for me not working, and what do you mean?:

im mentioned so many times i get INPUT NOT SUPPORTED how do i recongize settings and then apply to other DE if i have Input Not Supported on this other DE, bassically i have input not supported everywhere only KDE Plasma works, also sorry if this reply to aggressive i dont know what to do i cant use my system normarly, also you did not reply to my question: