Installed Nvidia driver on a Laptop, according to the Fedora documentation. Only the external monitors work

Hello everyone. I am experimenting with Fedora Linux. I currently have F36 installed with everything updated and NVIDIA drivers installed according to two guides.

First I followed this guide RPMFusion - Howto/NVIDIA, and after reboot my monitors did not work, and the laptop display did not work.

Next I tried following the additional settings following the additional guide of RPMFusion regarding OPTIMUS configuration. That made my nvidia gpu primary. That also made XORG default, so I had to modify GDM to force wayland again. Issue not fixed, external monitors work but the internal laptop monitor does not turn on - it’s black.

I also reviewed this guide How to Set Nvidia as Primary GPU on Optimus-based Laptops from Fedora docs, but it looked the same as the RPMfusion Optimus guide and did not yield any results.

I am lost and I don’t know what to do next. Please help lol. I can use my laptop with external monitors just fine - everything work good except the built-in display.

Thanks in advance!


You said you followed the instructions from here to set the nvidia dGPU as primary. If you did then the content of the /etc/X11/xorg.conf.c/nvidia.conf file should look like this.

$ cat /etc/X11/xorg.conf.d/nvidia.conf 
#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section "OutputClass"
	Identifier "nvidia"
	MatchDriver "nvidia-drm"
	Driver "nvidia"
	Option "AllowEmptyInitialConfiguration"
	Option "SLI" "Auto"
	Option "BaseMosaic" "on"
    Option "PrimaryGPU" "yes"

Section "ServerLayout"
	Identifier "layout"
	Option "AllowNVIDIAGPUScreens"
    Option "PrimaryGPU" "yes"

The ‘ServerLayout’ section is what allows the nvidia GPU to control both external and internal screens and the above text works for me with everything through F35.
I am updating my laptop to F36 today and will report back with the results.

Note that several have reported similar symptoms with nvidia on laptops when they set the external monitor as the main monitor and have not fully configured the nvidia GPU as primary.

For most resetting the internal monitor as the main display in gnome settings has solved the issue.

1 Like

You can run ‘nvidia-settings’ in terminal and check settings “Set Up Multiple Monitors”. Maybe it isn’t set up there

1 Like

Thanks for replying, I most definitely only had the Primary Gpu option set yo Yes in OutputClass section. I will try doing the sugested changes and see how it goes. Thanks again

Update: I tried implementing @computersavvy suggestions on a clean fedora installation. Still the laptop display in black/notworking while the external displays work just fine. Also from default wayland now I’m using x11 as default. Any ideas on how to solve the internal display issue and still use wayland. Thanks!

@computersavvy are you able to use Nvidia + Wayland + external monitor with this configuration? Here on my laptop if I try to use Wayland it seems to ignore the Nvidia driver and falls back to AMD (the iGPU) Renoir driver.

Oddly enough, I can use the external monitor even if I don’t set PrimaryGPU – but on both cases, only with X11. Wayland is still a no-go for me :cry: I was hoping things would improve with F36 but, judging by these reports, I won’t hold my breath…

This is strange and seems a regression in Wayland + Nvidia with the update to F36.

On F35 I used wayland + nvidia + gnome 41 and had my external monitor working. With F36 the external monitor does not even receive a signal and activate with wayland + nvidia + gnome 42 but it does with xorg.

Since the external hdmi port is connected directly to the nvidia GPU it certainly is related to the wayland + nvidia + gnome interface.

I will add an update to bugzilla on this since it is so far the only thing I have noted that is an issue for me with 36. It seems to me your issue is similar and I do have the nvidia set as primary.

So I looked at the other question regarding similar issue. I followed steeps that @computersavvy wrote there. Now, on Wayland only the internal monitor works, however, on x11 only the external monitors work. I might have to do F35 if that is what currently works just fine.

I know that for my laptop, both the HDMI and the usb-c (dp) are wired directly to GPU.

Note that I have nvidia set as primary (and able to actively control both internal and exteral monitors) by copying /usr/share/X11/xorg.conf.d/nvidia.conf to /etc/X11/xorg.conf.d/nvidia.conf and then editing the file just created under /etc to add Option "Primary" "yes" to both stanzas of that file.

I still have issues with only being able to use the external monitor with xorg though. With wayland the external monitor remains black.

I have seen notes here where failure to copy that file into the directory under /etc does not allow the nvidia GPU to control the internal screen and gives results similar to what you just posted.

I posted an update to 2074167 with my issues with wayland + nvidia + gnome and external monitors.