NVIDIA Drivers on Fedora 40 KDE

I have a laptop with optimus technology. (intel iGPU, NVIDIA eGPU)
I installed.

I messed something up while installing nvidia drivers manually. (runlevel3)
and it said that DKMK certificate not validated or something and that the drivers would be needed to be reinstalled after a new kernel update

and yeah. rebooting into Fedora 40 (KDE), I got the boot message that it failed to load the NVIDIA drivers, reverting to noveau.

I’m trying to clean install NVIDIA drivers from scratch. with deleting any old traces.

will the following commands run well / be enough to get the job done?

rm -f /usr/lib{,64}/libGL.so.* /usr/lib{,64}/libEGL.so.*
rm -f /usr/lib{,64}/xorg/modules/extensions/libglx.so
dnf reinstall xorg-x11-server-Xorg mesa-libGL mesa-libEGL libglvnd*
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.saved

***using Fedora 40 KDE Wayland (latest kernel)

You should mention what instructions you used to install Nvidia drivers – there are several sites that target Fedora specifically and will provide a configuration that works properly for kernel updates. Do you require secure boot? If your Nvidia card doesn’t support Wayland, can you live with Xorg (I have an older system that needs nouveau for Wayland, but I also install the Nvidia driver and it is not hard to switch to the Nvidia driver when I need Xorg).

If you installed the files you want to remove manually outside the packaging system then deleting them should be OK, but don’t mess with files installed from rpm packages. There are dnf options to clean up problems with installed packages.

It is good practice to include the output from running inxi -Fzxx in a terminal so we can see details of your hardware. There can be issues with vendor UEFI support, so it is not enough to see the graphics hardware details. This will make it possible for others with similar hardware to find this topic with a web search.

Finally, it is good practice to ensure that both Fedora packages and vendor firmware are fully updated so you aren’t chasing a solved problem.

I used If not True then False’s method. Guide:

didn’t know that I had the other option of installing via rpmfusion repository.

  • I turned off secure boot. (tried to install from rpmfusion before the manual method)
  • I don’t know where to check if my card supports wayland. but im using a RTX 3060
  • Have to admit I only learnt about X11 after getting Wayland. which I confused for Plasma KDE.
  • how do I include the output from the inxi? just cat?
  • I always dnf update and dnf update --refresh before installing anything

thanks for your time

Welcome to :fedora: :handshake:t5:

People should stop trying to install the INTTF method. It always breaks.

Optimus on Fedora

NVIDIA Optimus is a technology that allows an Intel integrated GPU and discrete NVIDIA GPU to be built into and accessed by a laptop.
With Fedora 25 and later, Optimus devices are supported automatically by default. Please see the dedicated Optimus Howto.

How to install the Nvidia driver from the Repos on Fedora


How to install Nvidia Driver with Secureboot on Fedora 40


Please post the output of inxi -Fzxx for us incase we need to troubleshoot issues you might incur.

1 Like

Lesson learnt. somehow was my first recommended option.

sorry to ask but can you tell me how I can go about doing that? where it can be found? can it be accessed by a command? etc…

1 Like

I learnt my HARD lesson during the Fedora 21-24 days. . . Never again ! :laughing:

Anyway :

So from the terminal paste this command inxi -Fzxx , if it is not installed you will be promted to do so.

Then paste your info here in </> preformatted text:


1 Like
  Kernel: 6.9.7-200.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: KDE Plasma v: 6.1.1 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
    Distro: Fedora Linux 40 (KDE Plasma)
  Type: Laptop System: HP product: Victus by HP Laptop 16-d0xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 88F8 v: 88.58 serial: <superuser required>
    part-nu: 47N76EA#ABV UEFI: AMI v: F.25 date: 10/04/2023
  ID-1: BAT0 charge: 18.4 Wh (37.0%) condition: 49.7/70.1 Wh (70.9%)
    volts: 16.2 min: 15.4 model: HP Primary serial: <filter> status: charging
  Device-1: sony_controller_battery_44:89:cd:f5:ac:9f model: N/A serial: N/A
    charge: N/A status: charging
  Info: 8-core model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 640 KiB L2: 10 MiB L3: 24 MiB
  Speed (MHz): avg: 1351 high: 4118 min/max: 800/4600 cores: 1: 800 2: 4118
    3: 800 4: 1337 5: 800 6: 800 7: 801 8: 800 9: 800 10: 983 11: 800 12: 3243
    13: 793 14: 800 15: 801 16: 3155 bogomips: 73728
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-12.1 ports: active: eDP-1 empty: DP-1
    bus-ID: 0000:00:02.0 chip-ID: 8086:9a60
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q]
    vendor: Hewlett-Packard driver: nvidia v: 555.58.02 arch: Ampere ports:
    active: none empty: DP-2,HDMI-A-1 bus-ID: 0000:01:00.0 chip-ID: 10de:2520
  Device-3: Quanta HP Wide Vision HD Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-6:5 chip-ID: 0408:5425
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: N/A display-ID: 0
  Monitor-1: eDP-1 res: 1920x1080 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 1 drv: iris
    device: 3 drv: swrast surfaceless: drv: nvidia wayland: drv: iris x11:
    drv: iris inactive: gbm,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.2 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel UHD Graphics (TGL GT1)
    device-ID: 8086:9a60 display-ID: :0.0
  API: Vulkan v: 1.3.283 surfaces: xcb,xlib,wayland device: 0
    type: integrated-gpu driver: N/A device-ID: 8086:9a60 device: 1
    type: discrete-gpu driver: N/A device-ID: 10de:2520 device: 2 type: cpu
    driver: N/A device-ID: 10005:0000
  Device-1: Intel Tiger Lake-H HD Audio vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:43c8
  Device-2: NVIDIA GA106 High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228e
  API: ALSA v: k6.9.7-200.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:43f0
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000
    bus-ID: 0000:02:00.0 chip-ID: 10ec:8168
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-14:6 chip-ID: 8087:0026
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b
  Local Storage: total: 953.87 GiB used: 23.33 GiB (2.4%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVL21T0HCLR-00BH1
    size: 953.87 GiB speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 50.9 C
  ID-1: / size: 118.97 GiB used: 22.81 GiB (19.2%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-2: /boot size: 973.4 MiB used: 438.5 MiB (45.0%) fs: ext4
    dev: /dev/nvme0n1p4
  ID-3: /boot/efi size: 256 MiB used: 100.8 MiB (39.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 118.97 GiB used: 22.81 GiB (19.2%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB note: est. available: 15.25 GiB used: 4.27 GiB (28.0%)
  Processes: 591 Power: uptime: 18m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 10 Compilers: gcc: 14.1.1 Shell: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.34

also, my sound-card has something wrong I believe. the right headphone is lower by around 15%
my microphone sounds scuffed, more metalic. cuts off more. (in comparison to using it on Discord on WIndows 11)

Let us know where in the process you are on removing the Nvidia drivers that you got from the site, and if you have done the steps from RPMFusion ?

I’ve seen quirky activity from HP machines, but we’ll deal with that later.

firstly, I ran dnf remove xorg-x11-drv-nvidia\*
then used the following commands after:

sudo rm -f /usr/lib{,64}/libGL.so.* /usr/lib{,64}/libEGL.so.*
sudo rm -f /usr/lib{,64}/xorg/modules/extensions/libglx.so 
sudo dnf reinstall xorg-x11-server-Xorg mesa-libGL mesa-libEGL libglvnd\*
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.saved

executed, no return
executed, no return
failed to execute, return > “mv: cannot stat ‘/etc/X11/xorg.conf’: No such file or directory”

after that, I reinstalled them using:
sudo dnf install akmod-nvidia

If you installed the .run file, that should had been enough.
Typically you go to the directory where you saved the file and do

  • sudo ./NVIDIA-Linux-x86_64-XXX.xx.run --uninstall

So you do have the RPMFusion repo active? :+1:t5:

Can you post the results of:

dnf list installed \*nvidia\*

yes. RPMFusion repo is active

Installed Packages
akmod-nvidia.x86_64                              3:555.58.02-1.fc40         @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.9.7-200.fc40.x86_64.x86_64         3:555.58.02-1.fc40         @@commandline                   
nvidia-modprobe.x86_64                           3:555.58.02-1.fc40         @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                           3:555.58.02-1.fc40         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                       3:555.58.02-1.fc40         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64             3:555.58.02-1.fc40         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64               3:555.58.02-1.fc40         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686                    3:555.58.02-1.fc40         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                  3:555.58.02-1.fc40         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                 3:555.58.02-1.fc40         @rpmfusion-nonfree-nvidia-driver
1 Like

I think you are missing the dnf install nvidia-gpu-firmware,

Also to note,

  • After installing the RPMFusion, you waited the 5mins after install and then rebooted the machine?
  • After installing the firmware, please reboot.
1 Like

RPMFusion has been installed for 3 days now so yes :+1:
it was added to the previous list.
nvidia-gpu-firmware.noarch 20240610-1.fc40 @updates


edit: also, is there supposed to be a NVIDIA application or something that installs with the drivers?

the only NVIDIA application i have is : “NVIDIA X server settings”

Some sites do “search engine optimzation” to attract viewers. They often use content copied from others sites without adequate testing or keeping up with required changes.

Fedora uses very new kernels and associated supporting libraries and tools, so it is not unusual for packages that work for other distributions need some tweaks for Fedora. It is best to stick with Fedora repositories and ask here if you need some thing that has not been packaged. When you encounter problems with a Fedora package there are more users with the same software so a better chance that someone can help with your problem.

1 Like

I don’t have one, and I am on a laptop with a 3050TI mobile. I think it’s dependant on the card. If you are on Xorg there is an application though.

Can you try sudo akmods --force ? and wait till it’s done before you reboot the computer. ~5mins

1 Like

returns Checking kmods exist for 6.9.7-200.fc40.x86_64 [ OK ]

sorry to extend the thread for so long,

my system has startups
-System settings

curious about how to manage startup options for these applications.

they don’t show up in the “autostart” menu in settings

It’s no problem at all ! If you don’t have a solution, please feel free to ask.

I’m not on KDE, so I cannot help here with this. There surely will be someone to jump in and help with that.


I guess it’s a good time to ask what does nvidia-smi return in the Terminal ? Can you paste it here? Maybe it’s working properly?

1 Like

it used to return stuff. before the drivers stopped working after updating the kernel. now it returns this.

bash: nvidia-smi: command not found...
Packages providing this file are: