Nvidia drivers not working anymore after kernel 6.0.x update

after a kernel update today my Nvidia drivers are out of service - I was reverted back to nouveau. Am using Fedora 36 Workstation. Can someone eventually give me a tipp, how I might get them working again. I have to admit, that I am not super experienced in dealing with the Nvidia drivers - I was happy, that I made them work a while ago…
Thanks in advance!

Please boot with the last working kernel.
You can do with pressing Esc or Shift while starting your computer.

1 Like

Thanks for responding! Does this solve the issue, or is this just a temporary workaround, that I will have to repeat for a while?

Temporary workaround, yes.

And the final solution will come with an update?

Generally you have to reinstall the Nvidia drivers while getting a new Kernel.
I do not now if they are available without issues yet.

I protect my self against this problem using a Nvidia free system :wink:

Yes - a nvidia free system is unfortunately not an option I have at the moment :slight_smile: Lets see, how I can go on…

With grubby you can change back to the 5.x.x driver as default boot entry and after change back when ready.

Sorry - I did not get this. I should change to the 5.x.x. driver as default boot entry and when the issue with the new kernel is solved, I can change back to something else?

I would be very happy, if someone could hint me a way, on how to solve this issue in a way that is sustainable. Till today the nvidia driver worked like charm - so my setup must still be OK.

Reboot your PC and press Shift on boot start. After grub menu will show up, you must select the Fedora 36 Workstation (5.19). After that, your drivers should work.

Thanks! But that also means, that I can not install upgrades (of the kernel) anymore. Is there no more sustainable solution?

I think just need to wait for nvidia driver updated in repo. Because right now i can’t intsall it for 6 kernel

Not true. That simply means that you booted that one time with the 5.19.XX kernel.

When I have had a problem with a kernel update I boot to the older working kernel then in 2 steps remove the newest kernel, and follow that with a new upgrade to reinstall it.
sudo dnf remove kernel*6.0.5* to remove that kernel (or whatever kernel number you are working with)
Follow that with sudo dnf upgrade --refresh which should then install the newest kernel and build the nvidia drivers new for that kernel.

These steps have worked for me for several years.

When I have

You may have to be more careful when you are updating your system. Weekends is a bad moment when you expect help and support for you “closed source Hardware”.

I do understand if you not want to skim all topics and requests about nvidia problems. But at least you could observe carefully “Common Issues” and “Announcements” while filter for nvidia tag for the next few days.

Please past inxi -G as pre-formated </> text to see what GPU Hardware you are using.

After some research i found that default provided repo with nvidia driver are outdated, you need to add an full Rpm Fusion nonfree here link with instruction

After adding that you can refresh updates list in gnome apps and get a new Nvidia 520 driver that works perfect for me

I’m using the nvidia-470 kernel module (because my card is a few years old) built from rpmfusion-nonfree and it fails to build on the 6.0 kernel.
It might be related to this … 470xx drivers and linux 6.0 kernel - Linux - NVIDIA Developer Forums


Thanks - you are definitely more experienced than me in this topic and I will try to follow your advice. Unfortunatelly pressing shift during the boot time is not bringing up any menue, respectively not changing the boot process.

Thanks for your kind advice - I will definitely try to follow it!

Yes - I also use the nvidia-470 kernel module. Will have a look!