Fedora 30 KDE Nvidia Geforce GT 130M, Kernel 5.1.5 akmod 340.107 boot stops after Plymouth

After updating my system to the latest kernel 5.1.5, the boot process stops after plymouth splash screen. I am using akmod 340.107 for Nvidia Geforce GT 130M under plasma 5.15.5 and the appropriate xorg-driver. What can I do and where a bug must be reported? Thank you. I can’t post the journals because I can not login into my desktop.

I may have a related problem. I upgraded from F29 to F30 successfully, using kernel 5.0.17 and nvidia driver 418.56.

Then yesterday I got kernel 5.1.5 and couldn’t start, so I thought I might need to update nvidia and wanted to install driver 430.14.

However, I can’t even boot into multi-user.target to install that driver.

@heliosstyx, @skeydan, hi there!

Please check is you can switch to text console using [Ctrl-Alt-F3…6] – there are 6 consoles by default, 1st is usually taken by gdm, 2nd by your graphical session – which you don’t have right now, so I suggest using F3, F4, F5 or F6.

If you do, you’ll see text login prompt and should be able to login using you usual login and password (you have to enter login manually).

From my own experience thing you’re describing usually happens when nvidia driver can’t build modules for new kernel. Using text console you can troubleshoot the issue, install/remove updates and packages and such.

If that’s the case then you’ll most likely have to wait for nvidia’s driver update which fixes build with newer kernel. There are couple more options to try. Please tell me where did you install your driver from (rpmfusion, negativo17, some other place).

Also you should be able to boot into previous kernel where you had your driver working. If you have other OS installed beside Fedora, you should see boot menu by default. If you don’t – try holding [Shift] while booting, and if this don’t show you the boot menu - try hitting [Esc] while booting, and as another option try hitting [F8] while booting. Not three keys at the time, try the key one after another, only one for each reboot.

Hi, nightromantic. I have installed the akmod-driver/xorg-driver package 340.xx from RPM-Fusion repository. I am sure that the issue results from failed building modules for the new kernel 5.1… I am using my system now with the previous kernel 5.0.17. I have checked the Nvidia website for a new Linux driver 340.xx, but there is no new one. I can’t follow your above mentioned tips, because without my desktop I have no internet connection and so I can’t change my system. I am afraid that I will have to wait for a driver update for the new kernel. Please keep in mind, that I am using the KDE desktop and not Gnome. Do you have another solution? Thank you for your answer. So long.

That’s good, you did the right thing (in my opinion).

You can also try

akmods --force 

if I’m remembering correctly to try to rebuild drivers even if they failed earlier, it helped me a couple of times. But in this exact case chance for it to work is quiet small. Also it’s better to try it with new kernel, not old. you can do rebuild from under older kernel, but you’ll need to pass --kernel option with correct kernel number.

You don’t need new driver, you need updated driver package from rpmfusion which will build successfully for new kernel. Chances are it will be available in a couple of days. You can also check if there’s already a bug filed against rpmfusion’s package and ping the package’s maintainer if there isn’t. Keep in mind that rpmfusion is a bit separate from Fedora, they maybe not using official fedora’s bugzilla, you’ll have to check how to file bugs on prmfusion’s site.

You should if you use wired connection, and if you have wireless you can try to activate it with

nmcli connection up <name of your connection>

Also nmcli connection show should list all the available connections – wireless included – you have configured on your desktop.

And it all should be totally the same for KDE and Gnome, as far as I understand.

@nightromantic: Thank you for your answer. I will try your tips soon and I will report the results to you. I need help for akmods --force comand and the kernel number: what should I enter exactly. I am not very familiar with the command line, I am using it very rarely.

@heliosstyx, if you follow my advice for switching to text console

when you boot into 5.1 kernel, then you can login, as I said, and enter exactly this:

sudo akmods --force

This should force akmods to try to rebuild kernel modules for the current kernel even if if failed earlier.
Output will tell you if it was successful or not.

If you can’t switch to text console with 5.1 kernel, then you can try something like this from your terminal application:

sudo akmods --force --kernels 5.1.5-300.fc30.x86_64

though I’m not 100% sure this is exactly how you specify kernel for it, and I have no machine with akmods available for me to test it. This variant is the same except that you ask akmods to rebuild modules for kernel version you specify, not for current kernel.

Keep in mind that in this case I think that probability of successful rebuild is quite low, I think (don’t know for sure) you need to wait for driver package update from rpmfusion.

@nightromantic thanks so much for your help!

Unfortunately, Ctrl - Alt - F3 (or F4, or…) does not work at all for me - nothing happens… Would you have an idea what I could do?

Now I’ve also tried a different thing, namely, booting into the 5.0.17 kernel and installing the 430.14 driver there (hoping that if that worked, dkms would rebuild the driver for 5.1.5). Unfortunately, the installer is frozen (it starts but with a blank window) so I can’t install 430.14 for that kernel either…

(Aside: according to https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/ 430.14 should work with F29 as well as F30)…


Edit: Forgot to answer where I got the driver: it was downloaded from Nvidia.

This command gives an “OK” return-status for the akmods.

Another bad news for all nvidia graphic card owner with driver 340.xx, the support will end at the end of 2019. Game over! Look here: https://bugzilla.rpmfusion.org/show_bug.cgi?id=5280. Fedora 31 probably will kill it too (RPM-Fusion…)

By the end of 2019 you will probably upgrade a few more times your graphical driver. We’ll all probably be on a higher version.
My recommendation is to install the drivers directly from NVIDIA website. Here is a nice guide to install:

good luck!

I’ve just noticed that you are actually running an old video card considered legacy by NVIDIA. So in this case your statement might be true.
From NVIDIA website:


@nightromantic adding to my answer


I tried again booting into the 5.1.5 kernel - the boot process hangs after “Starting deferred execution scheduler”, so I don’t even get to try switching consoles in that case (although switching consoles generally does not work for me).

Together with the fact that the 430.14 installer hangs (with kernel 5.0.17) - and that driver version is reported to work for some people here: https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/comment-page-89/#comments - I am starting to wonder if something’s not okay after my upgrade to F30 (done while on 5.0.17).


I had the same problem as you after my kernel has been upgraded from 5.0.17 to 5.1.5. However after installing the newest driver from nvidia website (430.14) everything works fine:

[xxx@wasteland ~]$ uname -a
Linux wasteland 5.1.5-300.fc30.x86_64 #1 SMP Sat May 25 18:00:11 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
[xxx@wasteland ~]$ dkms status
nvidia, 430.14, 5.1.5-300.fc30.x86_64, x86_64: installed

You don’t need to install the driver from the old 5.0.17 kernel. Boot into 5.0.17 and then:

sudo systemctl set-default multi-user.target
sudo reboot

Boot into 5.1.5, you’ll be prompted to login into the terminal. Install the driver normally, than:

sudo systemctl set-default graphical.target
sudo reboot

And next time you boot it should all be fine.

Thanks @biosharkdev!
Unfortunately this is what I tried … I can’t make the 5.1.5 driver boot into multi-user.target even, it hangs at "Starting deferred execution scheduler”…
Neither can I install the driver from 5.0.17, as the installer hangs…

Did you try CTRL+F3, CTRL+F4 while it hangs?

You need to run the command sudo systemctl set-default multi-user.target from the 5.0.17 kernel. Since you try to install the driver from there, I assume you can log in without issues into that kernel. So run the above command from 5.01.7 and your next boot should be into 5.1.5 in order to install the driver. After it’s installed don’t forget to run sudo systemctl set-default graphical.target

430.14 is not compatible with the old kernel 5.0.17. You need an older version of the driver, something like 418.XX.

thanks, so I don’t need to try that anymore! However,

is what doesn’t work. I tried several times, but it always hangs a few lines after “Terminate Plymouth Boot Screen”. Crazily, the number of successful lines after that one varies. Once I got till “Network Manager script dispatcher service”, once even 1 line after that… But then it doesn’t continue anymore…
This is why I thought this isn’t even related to NVidia, - but I have no idea what else it could be…

Yes, I also guess your graphical driver isn’t to blame here, maybe some network issue. I would try to unplug your network cable if you are physically connected.

However, if booting into 5.0.17 works, you should make sure you have all the updates sudo dnf upgrade --refresh installed and than try again 5.1.5. If it still doesn’t work but you can work in 5.0.17, you could wait for some update. Not sure what could hang on your side.

Yes, I have all the updates … thanks anyway! I guess I’ll really have to hope for some update or in the worst case, reinstall F30. Probably something went wrong with the upgrade (although there were no errors or warnings)…

If it does build successfully, but you still can’t boot into 5.1 kernel, then the issue can be a bit different. Still I would suggest waiting for some time for the rpmfusion’s driver update.

As far as I saw, 340.xx driver wasn’t much updated by NVidia in any case.

There’s one more thing you have to keep in mind about rpmfusion. It’s actually ordinary Fedora users like you and me who package nvidia drivers there, provide updates and such. So if there’s just one person there keeping this driver going and he decides to stop or looses interest or switches to AMD – then there may be no updates for this package anymore.

One more thing you can do – if you want to and have some time – is getting in touch with package maintainer on rpmfusion and offering him some help.

And another thing ) Do you use your computer for gaming? If not then you can try using open source nouveau driver instead of proprietary nvidia one. It’s better in some areas, but in the same time it doesn’t provide 3D performance anywhere close to nvidia’s driver, and it works better on some cards than on others. It’s no-go for gaming, but if you don’t do it then you can test and see if it works ok on your machine.

I’ve had some troubles with nouveau recently on my home computer, but they were resolved/patched quite fast, and in general for me it works well.

@skeydan, if I were in your shoes and if I wanted to experiment, then I would actually uninstall nvidia’s driver and see if that resolves your problem with boot to 5.1 kernel.

If it actually does – then you can decide where to go from there.

If I were to lazy to experiment (or have ho time, have work to do etc), then I would use my computer with 5.0 kernel for some time while waiting for situation to resolve. Further updates to kernel can help here, updates to nvidia’s driver, maybe some other updates.

You’re able to use your computer ok with 5.0 kernel, that usually strongly suggests that all updates went ok, and it’s actually problem with new kernel and probably nvidia’s driver. And if this is the case you can end up in the same exact spot after reinstalling Fedora.

I don’t agree with @biosharkdev on the topic of driver installation. I think we all better off using packaged driver, not one directly from nvidia. Packaged one can be upgraded/removed safely without leaving junk all over you Fedora installation.

But the good thing is we all are free to decide ourselves what do we want to do. @biosharkdev likes driver directly from nvidia – ok, good for him! ) I don’t like it and like packaged ones instead – it’s ok while I can get them. I can’t be 100% sure I can always get one, as we’ve discussed above.

The question I asked @heliosstyx goes to you to: do you use your Fedora installation for gaming? Cause if not you can be better off with free nouveau driver. It’s not 100% guaranteed to work better, but you can test it and decide yourself.

One other source of packaged nvidia driver is negativo17. On the page linked he explains how’s his packages are different from rpmfusion’s ones (though I’ve heard some time ago that some of his work were actually included into rpmfusion’s repo). I’ve used his drivers for a couple of years (though it was about couple years ago). And he has driver 430.14 – though the package is dated May 19, maybe it should be updated too.

One thing to note about his repo is he supports only the latest stable nvidia drivers, he doesn’t do any legacy ones.

@nightromantic thanks so much for taking the time to reply!

Yes I don’t really have the time for experimenting so I’ll probably wait for a few kernel (and/or driver) updates, and if not, reinstall.

Actually I’ve now remembered there was something strange with the upgrade, - the final reboot resulted in power-off, which I never encountered before… but then after booting manually all looked ok and I finally forgot about it… but now that I’ve remembered I’m not completely confident anymore that all is ok.

Yes absolutely :slight_smile: The first time I switched to NVidia drivers, I followed the if-not-true-then-false instructions, and for quite a while upgrades overall went fine for me (mostly even with dkms).

No, but for deep learning - and even if my GPU is not the greatest (Quadro M2200), it’s pretty cool to be able to do that on your laptop :slight_smile:

To tell the truth one thing I hope is not the cause - would be hardware incompatibilities, because in that case of course a reinstall wouldn’t work… I have a Lenovo P51.