What is happening with nvidia drivers from rpm fusion?


This is going to sound a little harsh but like my other posts, I’m a bit angry because I’m struggling it for months now(maybe 6) with those problems without any help on telegram from this community or the community managers.
I’ve been asking for help also on boinc forum, folding@home forum and nvidia developpers for this and apparently nobody has any answer to this.
This problem is somewhat major since even blogs are popping up all over the place to actually state this problem and to advice to come back to the original drivers from nvidia.
The URL from this blog might make you think that it’s an old one but actually it isn’t because if you see the edit date it’s really up to date.
And you can see in the different post
and I could put more but because of my grade on discourse I can’t put more than 2 links.

So by installing the nvidia drivers from rpm fusions or even from fedora-nvidia which is the repo from negativo17 it’s not working. Yeah sure, some part of the acceleration process are working basically like if you test it with glxgears or glmark2.

I had a wide range of problems.

No graphic acceleration available for software like Steam with i686 libs installed.
no multi-monitor support
graphic artifact like a black line of pixel following the mouse pointer

Any of these problems didn’t occur with the nvidia propietary installer. Ever.
If I need to follow the guidance of the telegram and matrix chat, I should only install nvidia drivers through repo.because of apparently, so much ethical and technical reasons that Tobias have again made his propaganda to someone else on the Telegram chat, again in a very rude way and again in at a moment where nobody asked for his opinion but that’s another matter which will lead to another topic that I will create. (this incident that I’ve witnessed is actually the reason that I finally took the time to finish this thread)…
But again I had countless problems with the different repositories. I’ve tried 2 of them I think and they all had their counterparts.
So unless all the blogs and tutorials I’ve followed are wrong, or there is a massive problem with those repositories and how they package the nvidia drivers.

So could someone clarify the situation since apparently the ones who doesn’t use the repositories are just morrons?

Which leads me to my ultimate problem with those nvidia repositories or even the nvidia installer.
How do we activate CUDA ? Because I’ve never succeeded to make BOINC or folding@home detect my GPU. Every tutorial or wiki page are saying that i’s easy, you just need to install that and that, but it just doesn’t work.
And so again, what’s happening with those repositories?
And if there was only me, I would say that maybe my installation of fedora is faulty in some way, but apparently not since there are blog post popping up about it like I previously sourced. And based on the comments on those blog post it is not just me. So can we try to sort that and maybe end up with a more current wiki page even ?

Thanks in advance for all the input and help you can bring.

There are a few points that you must consider:

  • first, Nvidia hardware is proprietary—it is not open source. Neither are the drivers. There is nothing either Fedora or any other Linux distribution can do about this.
  • second, the suggested way of installing the proprietary drivers that Nvidia does provide, is via RPMFusion, which is a repository maintained by Fedora volunteers.
  • All RPMFusion does is take the binary, and put it in an rpm package so that files can be installed and uninstalled conveniently. It is still the driver that Nvidia provide—it is not something that RPMFusion have created.
  • if drivers from RPMFusion do not support a version of the hardware, or do not work (which also happens in cases), the remaining option is to download the driver directly from Nvidia and use that following whatever instructions Nvidia provide.

All of this also applies to CUDA. It requires the proprietary Nvidia drivers.

There is no way of the community verifying the information that people put up on their blogs. We cannot verify negativo or if-true-then-false or whatever it is out there.

I understand your frustration, but the only place where it has a chance of actually making a change or improvement in the drivers that are needed for your hardware is at Nvidia, your vendor. If nothing is working for you, Nvidia are the ones who need to be spoken to.


(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

So, your post has been flagged here, because now you are not following the Code of Conduct. Even when being upset, you are expected to remain excellent to everyone in the community. You are not doing that here.

This is merely a difference of opinion. If the RPMFusion packages do not work for you, feel free to use whatever you wish—other providers, Nvidia’s official installer. It is your system, and it is your choice. No one on any of these channels represents any official Fedora stance on this. That is not how support in a volunteer community works. We are all individuals, and we make suggestions and hold discussions. People agree, and people disagree.

If you want to figure out what is wrong with the RPMFusion packages, you need to file bugs there so that the maintainers can help you. Posting in various support channels instead is not going to do that.


I strongly suggest you take some time out and calm down so that you are able to remain excellent to everyone.

I am going to close this topic also now.



I was asked to rewrite my post to better accommodate the community guidelines.
So here it is.

At my second try with fedora a year ago more or less, I have tried to install correctly the surplus rig that I have with major nvidia card that I had left.
Back in the days around the distribution number 20, I already had problems with installing nvidia drivers from the repository. Issues like graphical glitching, steam missing libraries, etc. As such, I now wanted to try again. Besides the graphical glitches and steam lib 32 compatibility I have also encountered screen stuttering, graphical artifacts, etc. None of these ever happened to me with the official nvidia installer.

I was made aware that the nvidia installer was not trustable. I do not know why it is different from the package, but I am totally inclined to learn a new way should there be one. Given that so many people do not have any problems with the repositories, it would be great to have a step-by-step installation for all the packages I would need.
Indeed, there are several repository for nvidia and I do not know which one is the most trustable or more stable.
I would like to know which packages should I install and which ones should I uninstall maybe. Also, as I am using the nvidia installer, which libraries do I have to manually remove, etc.?
Don’t point me to a search through google please, I have done all that and it’s precisely because I’ve done all that, that I’m asking you because maybe you will have more informations about which files should not be present at the time of installation or things like that. Or if it must be done on a fresh installation maybe, those kind of details.

Even if the nvidia installer would do a proper job each time, there is still one thing I could not manage function correctly. This is the the cuda compatibilities with boinc applications.
I would be grateful if someone has any clue on how to include it since it is only for fedora 29.

I would be using the graphic card essentially for gaming with steam, Boinc application. I don’t know if this is relevant but is the graphic card 1080 Ti known to have any issues?

thanks in advance for all your answers.

1 Like

Still no one got any good feedback about one specific repos who would work correctly and install everything for 3D acceleration but also cuda ?

Did you install CUDA?

You can follow the documentation from rpmfusion for installing the drivers and CUDA from nvidia.

Or you can use the negativo17 repo to source both the driver and CUDA, although this repo is outside the official Fedora sphere.

In any case you may have to play with making sure the right GCC version is used for CUDA, by installing the version required by CUDA in addition to what the system provides, and/or modifying source files so that CUDA compiles with the correct GCC version.

@fasulia Okey and how make I sure there are no interferences from other repos? Because as I said, I got countless problems about those repos whether it’s graphical.options that did show up like fps on every window that I didn’t ask, updates problems, instabilities with some steam games which I didn’t have with the official installer, artifacts with those games too etc.
So maybe I didn’t got all the packages right, maybe I got too much packages, maybe there were interferences from other repos, etc…
Is there a correct way to clean everything and then install it right?

"Cuda" problem 1
dnf install cuda-gcc cuda-gcc-c++ -y
Dropbox Repository 72 kB/s | 25 kB 00:00
Errors during downloading metadata for repository ‘Dropbox’:

  • Status code: 404 for http://linux.dropbox.com/fedora/32/repodata/repomd.xml (IP:
    Error: Failed to download metadata for repo ‘Dropbox’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
    Tárolók mellőzése: Dropbox
    Az utolsó metaadat lejárati ellenőrzés ennyi ideje volt: 0:17:39, ekkor: 2020. júl. 16., csütörtök, 14:57:50 CEST.
    Probléma 1: conflicting requests
  • nothing provides gcc = 9.3.1-3.fc32 needed by cuda-gcc-c+±9.3.1-3.fc32.x86_64
    Probléma 2: problem with installed package gcc-10.1.1-1.fc32.x86_64
  • package gcc-10.1.1-1.fc32.x86_64 requires cpp = 10.1.1-1.fc32, but none of the providers can be installed
  • package gcc-10.0.1-0.11.fc32.x86_64 requires cpp = 10.0.1-0.11.fc32, but none of the providers can be installed
  • cannot install both cpp-9.3.1-3.fc32.x86_64 and cpp-10.1.1-1.fc32.x86_64
  • cannot install both cpp-10.1.1-1.fc32.x86_64 and cpp-9.3.1-3.fc32.x86_64
  • cannot install both cpp-10.0.1-0.11.fc32.x86_64 and cpp-9.3.1-3.fc32.x86_64
  • package cuda-gcc-9.3.1-3.fc32.x86_64 requires cpp = 9.3.1-3.fc32, but none of the providers can be installed
  • conflicting requests
    (adja hozzá a(z) „–allowerasing” kapcsolót az ütköző csomagok lecseréléséhez vagy „–skip-broken” a nem telepíthető csomagok kihagyásához)

"Cuda" problem 2
dnf install devtoolset-8-toolchain
CentOS-7 - SCLo rh 19 MB/s | 14 MB 00:00
Dropbox Repository 480 kB/s | 25 kB 00:00
Errors during downloading metadata for repository ‘Dropbox’:

  • Status code: 404 for http://linux.dropbox.com/fedora/32/repodata/repomd.xml (IP:
    Error: Failed to download metadata for repo ‘Dropbox’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
    Tárolók mellőzése: Dropbox
    Az utolsó metaadat lejárati ellenőrzés ennyi ideje volt: 0:00:03, ekkor: 2020. júl. 16., csütörtök, 15:20:11 CEST.
    Probléma: conflicting requests
  • package devtoolset-8-toolchain-8.0-2.bs1.el7.x86_64 requires devtoolset-8-gdb, but none of the providers can be installed
  • package devtoolset-8-toolchain-8.0-2.el7.x86_64 requires devtoolset-8-gdb, but none of the providers can be installed
  • package devtoolset-8-toolchain-8.1-1.el7.x86_64 requires devtoolset-8-gdb, but none of the providers can be installed
  • nothing provides libmpfr.so.4()(64bit) needed by devtoolset-8-gdb-8.2-2.bs1.el7.x86_64
  • nothing provides libmpfr.so.4()(64bit) needed by devtoolset-8-gdb-8.2-2.el7.x86_64
  • nothing provides libmpfr.so.4()(64bit) needed by devtoolset-8-gdb-8.2-3.el7.x86_64
    (adja hozzá a(z) „–skip-broken” kapcsolót a nem telepíthető csomagok kihagyásához)

What is the good answer?
Is there a good answer?

By being observant when installing updates and seeing which repo they are coming from. Also, by keeping the number of third party repos to a minimum, avoiding entirely if possible.

Since I use the negativo17 repo, I have ecludepkgs=*nvidia* in /etc/yum.repos.d/rpmfusion-nonfree-updates.repo to prevent nvidia updates from the rpmfusion repo. I don’t know if that covers all cases, but it’s been working well enough for me, and again, I always look over updates before installing. If you use rmpfusion, perhaps this won’t be an issue.

There is no universal “correct way” that just works in all cases with nvidia drivers. It has always been a pain and requires some thinking and problem solving.

You might be interested in trying out this new (i.e. not official/stable) tool that tries to make things easier: https://discussion.fedoraproject.org/t/tool-nvidia-easy-automatic-driver-installer-for-fedora-32-workstation-or-above/70299

If you want something that “just works”, (i)GPUs from AMD or Intel tend to be a smoother experience on linux. But if you’re interested in compute, well, you’re going to have another headache with ROCm.

You might want to post a new thread for your issue. In any case this is a known issue as described in the documentation: https://rpmfusion.org/Howto/CUDA#Known_issues

The solution involves adding a COPR to get an older gcc for CUDA.

CUDA and GCC version issues are a pain. It is one reason I went with the negativo17 repo.

1 Like

Okey good advices. So now to clean my system should I do something in particular? I’ve tried to uninstalled everything but since I’m not sure…
Should I do something specific?
I m going to clean the repo lost first. I need to update to fedora 32 still and so right now I m under complete console mode only.
But do I need to look for the presence of some specific library, symbolic link, etc?
Or have I to in fact clean the install by erase everything and reinstall fedora?

Others can’t possibly know the state of your system. You will have to use your judgment and try something. It will be easier to get an answer if you have a specific question.

Hi @fasulia, let us just say that the tool is not official but come on, :laughing: the tool has been tested to work on Workstation and multiple spins - so unstable it isn’t.

1 Like

I’m not suggesting it is unstable, just pointing out that it is an alpha or beta release (version 0.x) vs a stable (version 1.0) release. Better to set lower expectations and have positive surprises than the other way around.

On that note, @t0xic0der has it been tested for CUDA and gcc version issues? And… will the tool be given a distinctive name? Right now it’s hard to refer to it or find it. :wink: Btw, good job on the initiative; there is clearly a need for such a utility.

The version scheming can be pretty confusing I know, with different people following different schemes. In the popular belief, any versioning that has gone beyond its “1.0” release point is considered to be stable while points below it are considered to be in testing phases. It is correct for most of the parts though but the reason why I kept it under a 1.0 release is very different.

I follow a versioning scheme which has the pattern [MAJOR].[MINOR].[PATCH] and the changes made so far have all been minor. A collection of all those changes is what I plan to package in a COPR and then you would get a 1.0 release. All the features are right there but running them can be difficult for some as it has not been natively packaged for Fedora.

I would rather run a

sudo dnf install nvidia-auto-installer-for-fedora

than download it as a package from the GitHub repository, make it executable and then run it.

It has not yet become as convenient (as I promised) for users which it would once it gets its own package. All the functionalities are right there but once it gets its own package - I think I would then immediately step up the version to a 1.0 mark. :sweat_smile:

The version 0.3.0 (which you can find here) has a lot of changes where I have added the functionality for installing CUDA and all of its dependencies. The tool not just installs the drivers but if you add some more command line arguments - it can literally fetch you everything from NVIDIA (Well, everything that has been packaged by RPM Fusion).

I need to come up with a catchy name, yes. Any suggestions @fasulia?


Thanks to you both, the script seems to have done he trick even if I had some errors during the installation process apparently because of old symlinks not having been deleted but I need to check the log first for that.

Is that normal that I have now the number of FPS, if the window is Sync or not etc as information on the left side of windows like brave etc?

Boinc is now recognizing the gpu correctly at each boot which means the cuda has been correctly installed and activated which is a relief.
I just need to find out why folding@home doesn’t recognize the gpu yet.
But that a’s a big improvements for before so really thanks to you both, apparently I was clearly forgetting something and tutorials too then when I was trying the repos. I wonder what that is.

Also @t0xic0der I have a small problem but I didn’t get the time to investigate yet. Could you try to use a shadow connection from shadow.tech . I don’t seem to make it work with the download and installation of your vdpau/API . But again I still need to investigate so maybe it’s their launcher which is screw up but it was working before so…

Thanks for all the help. Much appreciate, I still wonder what did I miss and what the script is doing that I haven’t done before, need to check that too.

1 Like

It would certainly be some time before I would be able to specifically check per application. Glad to know that the auto installer worked for you. :slightly_smiling_face: