NVIDIA Driver version 525 in RPMFusion - any good experiences so far?

Hi - has anyone here installed the newly released NVIDIA Driver version 525 from RPMFusion, and is it working normally for anyone? I hadn’t seen anything pop up here yet, but over on Reddit it seems like at least a handful of folks updated and had some (potentially expected if you are reading up on the topic?) pretty significant regressions in performance.

So, I was mostly curious if it was a case of just very few folks having made the upgrade yet (but it being problematic when it does install), or the loud minority of folks with issues and many who were running normally - trying to figure out if it’s a safe install for my general home use + gaming laptop.



On my daily driver I had the 525.60.06 driver as soon as it was released on rpmfusion. Admittedly I do not do heavy graphics, but I do run a lot of apps with cuda and have had no problems.

I then installed the 525.60.11 driver from the rpmfusion testing repo as soon as it was available and the results were the same. No issues on my end at all.

Please note, however, that I am using an older 1050 card and many are using the newer cards. The ones I have seen that reported problems have mostly been using the 3060 or newer GPUs. Thus the ones that have GPUs that were unsupported with the 520 drivers.

1 Like

Thanks Jeff! I went ahead and gave it a try too (installed 525.60.11 through GNOME Software updates), as I have a GTX 1650 mobile, which i don’t understand to be a super-recent or advanced card.

Zero issues to report on this front also, including gaming (tested using Hades and then Mass Effect: Legendary Edition). If anything Mass Effect might even look a bit smoother, but that’s probably placebo on my part.

Thanks, and hopefully this info + your context are helpful to others in deciding whether to try the latest drivers.

In my laptop I have the GTX 1660 Ti mobile, though I still have F36 on that machine I also have the 525.60.11 driver.

I installed - finally - Nvidia drivers for a Dell 9520 laptop (i12700) with an Nvidia 3050Ti yesterday. I installed the rpmfusion drivers, but they are the 520.56 versions (Fedora 36?) which still allegedly came out of the rpmfusion Fedora 37 repo. The Nvidia drivers proper from Nvidia failed to correctly install during the DKMS phase so I re-installed from scratch and went with rpmfusion. I tried following instructions at linuxcapable.com and phoenixnap.com trying to get working Nvidia drivers.

This seemed to be working yesterday although I didn’t manage to run anything - blender, kdenlive e.g. - that would run on the GPU. At least the drivers were loaded (Secure Boot disabled, drivers not signed) and nvidia-settings and nvidia-smi showed me I had a working 3050Ti but any attempt to measure GPU usage was stuck at 0% utilization.

Today Discover updated about 15 files, mostly grub executables, and rebooted, and since then the Nvidia driver won’t load. I don’t know why - there doesn’t appear to be sufficient info from dmesg or journalctl other than the Nvidia driver failed to load and that it was trying to roll back to nouveau which is blacklisted. I got the impression when going through the rpmfusion installation that there may be an issue when upgrading - the rpmfusion drivers wouldn’t continue to load because they don’t get automatically updated in initrd. I think this may have happened but I don’t know what I need to do, other than yet another clean install; I’ve done 4 already trying to get Nvidia drivers to work.

So I’m an unhappy camper right now with Fedora 37 and Nvidia. Fedora 37 is working well, just not with Nvidia drivers. I’m a bit peeved that getting working Nvidia drivers on any flavor of Linux is still such a hassle and I end up following instructions from web sites which apparently work in some situations but apparently not all.

I decided to try Fedora after being a Debian convert for years but finally wanting something a bit more current, particularly on a fairly state-of-the-art laptop (that’s probably where I went wrong!)

It’d be great if Red Hat could actually publish guides and sanctified drivers that are known to work together but I guess that would require too much co-operation with Nvidia.

This is one of the reasons it is always recommended that you only install from the rpmfusion repo. The drivers installed from there are tweaked and tested to function with fedora while installing directly from nvidia does not have those tweaks.

One should also always ensure all remenants of the drivers from nvidia are removed before installing from rpmfusion to avoid potential conflicts.

One also may need to install the cuda package from rpmfusion to fully use the functions of the GPU. The cuda package is installed with the dnf install xorg-x11-drv-nvidia-cuda.

As of yesterday I have the nvidia 525.60.11 driver on my laptop with F36 and installed from rpmfusion

# dnf list installed akmod-nvidia
Installed Packages
akmod-nvidia.x86_64                                  3:525.60.11-1.fc36                                  @rpmfusion-nonfree-nvidia-driver

And from my desktop with fedora 37 where I upgraded the driver while it was still in testing

# dnf list installed akmod-nvidia
Installed Packages
akmod-nvidia.x86_64                                 3:525.60.11-1.fc37                                 @rpmfusion-nonfree-updates-testing

Can you show us the output of the command like mine above that makes you believe the driver was installed from an F37 repo or that the older version was F36?

You may want to upgrade with dnf upgrade --refresh to make sure your system is using the latest metadata from all the repos and you get the latest packages.

While nothing works in all situations, there is much greater chance of success if one is selective in choosing which instructions to follow, and generally if advice is followed that is focused on the distro of choice then better results are achieved.

On the Ask Fedora forum the advice overwhelmingly seems to install nvidia drivers and cuda from rpmfusion and not use drivers directly from nvidia or those from negativo or the cuda repo.

Unfortunately, things like this are a big part of the problem IMO - these seemingly mass-generated sites full of “how-to” guides with advice that is in fact questionable, but looks well-presented:

This veers into a different topic, but I’ll just say that if folks aren’t really explicitly told to see Ask Fedora as the “source of truth”, but do know that you can Google your way out of most problems, it’s easy to at best waste time, or at worst end up doing something destructive by following the top links on many searches.

1 Like

[quote=“Jeff V, post:6, topic:76289, username:computersavvy”]
Can you show us the output of the command like mine above that makes you believe the driver was installed from an F37 repo or that the older version was F36?
[/quote]Soitinly can:

$ dnf list installed *nvidia* && dnf repolist
Installed Packages
akmod-nvidia.x86_64                                                           3:520.56.06-1.fc37                                      rpmfusion-nonfree        
kmod-nvidia-6.0.12-300.fc37.x86_64.x86_64                                     3:520.56.06-1.fc37                                      commandline             
nvidia-gpu-firmware.noarch                                                    20221109-144.fc37                                       updates                  
nvidia-persistenced.x86_64                                                    3:520.56.06-1.fc37                                      rpmfusion-nonfree        
nvidia-settings.x86_64                                                        3:520.56.06-1.fc37                                      rpmfusion-nonfree        
nvidia-vaapi-driver.x86_64                                                    0.0.7-2.fc37                                            rpmfusion-nonfree        
xorg-x11-drv-nvidia.x86_64                                                    3:520.56.06-1.fc37                                      rpmfusion-nonfree        
xorg-x11-drv-nvidia-cuda.x86_64                                               3:520.56.06-1.fc37                                      rpmfusion-nonfree        
xorg-x11-drv-nvidia-cuda-libs.x86_64                                          3:520.56.06-1.fc37                                      rpmfusion-nonfree        
xorg-x11-drv-nvidia-kmodsrc.x86_64                                            3:525.60.11-1.fc37                                      rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                               3:520.56.06-1.fc37                                      rpmfusion-nonfree        
xorg-x11-drv-nvidia-power.x86_64                                              3:520.56.06-1.fc37                                      rpmfusion-nonfree        
repo id                                                                repo name
cuda-fedora36-x86_64                                                   cuda-fedora36-x86_64
fedora                                                                 Fedora 37 - x86_64
fedora-cisco-openh264                                                  Fedora 37 openh264 (From Cisco) - x86_64
fedora-modular                                                         Fedora Modular 37 - x86_64
google-chrome                                                          google-chrome
rpmfusion-free                                                         RPM Fusion for Fedora 37 - Free
rpmfusion-free-updates                                                 RPM Fusion for Fedora 37 - Free - Updates
rpmfusion-nonfree                                                      RPM Fusion for Fedora 37 - Nonfree
rpmfusion-nonfree-updates                                              RPM Fusion for Fedora 37 - Nonfree - Updates
updates                                                                Fedora 37 - x86_64 - Updates
updates-modular                                                        Fedora Modular 37 - x86_64 - Updates

(Had to remove the at signs from the repo names because “as a new user you’re only allowed to mention two email addresses per response” :grin:)

Grr: I’m barred as a new user from making new responses. I just edited this one to address the --refresh issue - 3 problems with driver versions - but Discourse decided to remove them.

One made at least three attempts with fresh installs to get Nvidia drivers working with Fedora 37 on this laptop, including what i would presume is the authoritative source, in the absence of anything similar from Red Hat: Nvidia. The problem is that there’s no ownership of this issue. My machine arrived with Windows 11 Home installed - which I didn’t really want - but everything was installed correctly and proved to be working before it was shipped. I accept that I’m going to have to do more work to get an operational Linux-based system, but so far with Nvidia drivers on two machines and two different distros (at least) I have failed to get working Nvidia drivers with Nvidia 3050-level GPUs. In the absence of a definitive guide I, and everyone else, am stuck with googling random Linux how-to websites for the solution.

I made another attempt at getting working Nvidia drivers on the Fedora installation on my Alder Lake 12900 desktop last night (it’s currently using nouveau, as was this laptop after I’d initially installed Fedora 37, except that installation doesn’t produce abrt bug reports when I log in, whereas the laptop is/was). Following the Nvidia guidelines I fell at the first or second hurdle because the kernel-headers that match the kernel that I got when I upgraded to Fedora 36 - 6.0.12-200 - don’t exist in the Red Hat repo via dnf (yet, I suppose).

It seems that there’s just never a repo that’s properly matched with Nvidia drivers and if you do get a working system it’s more down to luck than design, and it may not continue to work across version updates of the kernel or OS - this is what happened to me yesterday even with the rpmfusion bits.

I may attempt another Debian install just because it’s more stable and staid (LTS, now 16 months old, with minor version updates) although I’ve not managed to get working Nvidia drivers in the past with that system either. The reason I went to Fedora was that I wanted a more up-to-date toolchain, but it’s at the cost of getting a stable system with working Nvidia drivers.

Overall I’m enjoying Fedora 37 on this laptop (using it now) but - as ever! - the Nvidia driver experience leaves a huge amount to be desired. I realize this is not Red Hat’s problem. I would however appreciate a thoroughly tested and foolproof guide to getting working Nvidia drivers with Fedora repos. I imagine there are many thousands who would, and who don’t relish the idea of constantly running the gauntlet with Nvidia every time there’s a new kernel or OS version release.


ETA: As a new user I’m barred from reponding any more time to this thread(!) I did try dnf upgrade --refresh with these current bits and got the following:

cuda-fedora36-x86_64 18 kB/s | 3.5 kB 00:00
Fedora 37 - x86_64 24 kB/s | 22 kB 00:00
Fedora 37 openh264 (From Cisco) - x86_64 1.9 kB/s | 989 B 00:00
Fedora Modular 37 - x86_64 40 kB/s | 22 kB 00:00
Fedora 37 - x86_64 - Updates 59 kB/s | 24 kB 00:00
Fedora Modular 37 - x86_64 - Updates 59 kB/s | 23 kB 00:00
google-chrome 6.0 kB/s | 1.3 kB 00:00
RPM Fusion for Fedora 37 - Free 4.8 kB/s | 3.4 kB 00:00
RPM Fusion for Fedora 37 - Free - Updates 11 kB/s | 3.2 kB 00:00
RPM Fusion for Fedora 37 - Nonfree 14 kB/s | 4.0 kB 00:00
RPM Fusion for Fedora 37 - Nonfree - Updates 13 kB/s | 3.7 kB 00:00
Dependencies resolved.

Problem 1: package xorg-x11-drv-nvidia-power-3:525.60.11-1.fc37.x86_64 requires xorg-x11-drv-nvidia(x86-64) = 3:525.60.11, but none of the providers can be installed

  • cannot install the best update candidate for package xorg-x11-drv-nvidia-power-3:520.56.06-1.fc37.x86_64
  • package xorg-x11-drv-nvidia-3:525.60.11-1.fc37.x86_64 is filtered out by modular filtering

Problem 2: cannot install both nvidia-persistenced-3:525.60.13-1.fc36.x86_64 and nvidia-persistenced-3:520.56.06-1.fc37.x86_64

  • package xorg-x11-drv-nvidia-cuda-3:520.56.06-1.fc37.x86_64 requires nvidia-persistenced(x86-64) = 3:520.56.06, but none of the providers can be installed
  • cannot install the best update candidate for package nvidia-persistenced-3:520.56.06-1.fc37.x86_64
  • problem with installed package xorg-x11-drv-nvidia-cuda-3:520.56.06-1.fc37.x86_64
  • package nvidia-persistenced-3:520.56.06-1.fc37.x86_64 is filtered out by modular filtering

Problem 3: problem with installed package xorg-x11-drv-nvidia-power-3:520.56.06-1.fc37.x86_64

  • package xorg-x11-drv-nvidia-power-3:520.56.06-1.fc37.x86_64 requires xorg-x11-drv-nvidia(x86-64) = 3:520.56.06, but none of the providers can be installed
  • package nvidia-driver-3:525.60.13-1.fc36.x86_64 conflicts with xorg-x11-drv-nvidia provided by xorg-x11-drv-nvidia-3:520.56.06-1.fc37.x86_64
  • package nvidia-driver-3:525.60.13-1.fc36.x86_64 obsoletes xorg-x11-drv-nvidia provided by xorg-x11-drv-nvidia-3:520.56.06-1.fc37.x86_64
  • package xorg-x11-drv-nvidia-power-3:525.60.11-1.fc37.x86_64 requires xorg-x11-drv-nvidia(x86-64) = 3:525.60.11, but none of the providers can be installed
  • cannot install the best update candidate for package xorg-x11-drv-nvidia-3:520.56.06-1.fc37.x86_64
  • package xorg-x11-drv-nvidia-3:520.56.06-1.fc37.x86_64 is filtered out by modular filtering
  • package xorg-x11-drv-nvidia-3:525.60.11-1.fc37.x86_64 is filtered out by modular filtering

So already, after a clean install, with the supposedly preferred bits, I’ve got myself in “driver hell”. Is it any wonder the driver stopped working/was not loaded after a system update via Discover yesterday?

I was following the if-not-true-then-false guidelines at one point until I realized the guy was rolling his own repo. It may well be 100% fine but in the absence of iron-clad proof I’m not going to trust it. I had a hard enough time trusting rpmfusion! I had more trust in Nvidia, but their recipe failed the hardest so far (5 “fatal” errors during the DKMS phase which weren’t actually fatal, but once I’d got through it all nvidia-settings would just segfault. Not good.)

Errors of this sort are because you have that one package installed that is the 525 version and the remainder are the 520 version.
I suspect this may have happened since you had followed the INTTF instructions, which you already know are not fully accurate.

A quick fix would be to
sudo dnf remove *nvidia* --exclude=nvidia-gpu-firmware (the firmware package is required and must not be removed).
then reinstall with sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda. Wait at least 5 minutes for the modules to be compiled and available then reboot.

I also would consider disabling that cuda repo with sudo dnf config-manager --disable cuda-fedora36-x86_64 since the packages from rpmfusion fully manage cuda for you and are tested and confirmed to function properly. That mentioned cuda repo is 3rd party as well.


Nvidia is great and their product works well but is not always fully compatible with a rapidly advancing distro such as fedora without tweaks.

Actually redhat has nothing directly to do with fedora. Fedora software is managed by the fedora project.

Fedora project does not tell you directly how to enable nvidia drivers since they are proprietary and policies prevent fedora project from distributing or directly enabling proprietary software. This function is managed by rpmfusion which is 3rd party that works with FP and provides how-to as well as distributing the drivers that are already tweaked and tested to be compatible with fedora.

This forum since it is directly focused on fedora is the best source for information and assistance with problems that are fedora related.

1 Like

(Let’s see if I can squeeze in another response…)

Yep, I realized that. I did end up following another suggestion on another forum (Level1Techs) and seemingly created a frankeninstall, or a Linuxstein!

Thanks! This was going to be my next question: what is the recommended method to roll back my installation such that I have a clean base that doesn’t necessitate clean installing for the 5th (or is it 6th, I’ve lost count already) time. (I mean, I can, but I’d rather not - the last 3 clean installs to get the Nvidia driver working have not been encouraging - even the “working” rpmfusion install resulted in no activity from the 3050Ti, in blender for example (which in turn necessitated CUDA tools installation from Nvidia but those in turn necessitated the 525 drivers which I don’t have from rpmfusion. It’s a crazy mess I tells ya!)).

I actually didn’t: I started following the instructions while doing my due diligence but didn’t follow through because I don’t want to trust an unknown repo. I ended up following instructions at linuxcapable.com and phoenixnap.com: those were detailing the rpmfusion install and the Nvidia install. I also read through all of the Nvidia documentation on installing drivers, but that didn’t ultimately help either.

I didn’t realize that; thanks for the clarification.

I did realize that however.

Got it, thanks. What I probably should have done is wait until the 525 drivers are available at rpmfusion, just because those are compatible with the CUDA tools at Nvidia for example, and I would need those to get Blender operational.

That’s good to know! I intend to stick with Fedora, at least on this laptop, and quite probably on the 7950X desktop I’m about to assemble, but I’d sure like to get a working installation with Nvidia drivers that I don’t have to fret over. (The 7950X system will be using a Radeon GPU so I won’t have these problems with that build! :smile:)

Hmm, this is a misleading statement.

From the horses mouth so to speak:

Fedora Project

Red Hat is the primary sponsor of Fedora Project and provides hosting, engineering and other resources. It has several hundred active developers participating and leading the project in different ways in coordination with the volunteer community members. It is a highly successful model pioneered by Red Hat within the Fedora Project that has inspired several other distributions and other free and open source projects.

Source: Red Hat contributions - Fedora Project Wiki

You better not take thoughts apart. @computersavvy is talking clearly about Nvidia. Fedora Project is leading in new technologies and Red-hat as a main sponsor will take for its enterprise versions what is useful for it. In this sense we are a independent opensource project. As we do have a lot of users who are developer, technicians and other employees of RH they support the project as project members and contribute this way to Fedora.

It is better not to let horses speak, let them run :racehorse:

Not quite true. Cuda installed from rpmfusion as I noted above supports blender very well. Installing cuda from nvidia with the drivers from rpmfusion is again mixing sources. Rpmfusion uses the cuda drivers (from nvidia) as well as the nvidia drivers (from nvidia) and tweaks them to function as a seamless whole in the way they install and work.

When I said that I was referring to direct management. Of course RedHat is the main sponsor of the Fedora Project. They do not, however, directly manage it as was noted just above. The fedora project does have their own organization, policies, and management that is independent of direct control.

These policies and restrictions directly impact the ability to use hardware (nvidia GPUs) that are only supported by proprietary software. They also impact the ability for FP to directly provide instructions for use of the same software.

Just as I was about to attempt rolling back drivers, Discover had an update of 44 files, including bringing all the Nvidia drivers up to 525 levels (I checked rpmfusion first but didn’t see any recent timestamps in the release or update repos, like within the last day or two).

So the machine rebooted, installed files, took its time recreating initrd (based on journalctl) and rebooted again.

But I’m still in an unstable situation:

NVRM: API mismatch: the client has the version 525.60.11, but
NVRM: this kernel module has the version 520.56.06. Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

nvidia-settings and nvidia-smi get an internal driver error or driver/library version mismatch and the nvidia driver has been disabled by the kernel again.

I expected Discover to do the right thing, including rebuilding initrd with the correct drivers since they’re all now at the same level.

Loaded nvidia drivers:

Installed Packages
akmod-nvidia.x86_64 3:525.60.11-1.fc37 [at]rpmfusion-nonfree-updates
kmod-nvidia-6.0.12-300.fc37.x86_64.x86_64 3:525.60.11-1.fc37 [at][at]commandline
nvidia-gpu-firmware.noarch 20221109-144.fc37 [at]updates
nvidia-persistenced.x86_64 3:525.60.11-1.fc37 [at]rpmfusion-nonfree-updates
nvidia-settings.x86_64 3:525.60.11-1.fc37 [at]rpmfusion-nonfree-updates
nvidia-vaapi-driver.x86_64 0.0.7-2.fc37 [at]rpmfusion-nonfree
xorg-x11-drv-nvidia.x86_64 3:525.60.11-1.fc37 [at]rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64 3:525.60.11-1.fc37 [at]rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64 3:525.60.11-1.fc37 [at]rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64 3:525.60.11-1.fc37 [at]rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64 3:525.60.11-1.fc37 [at]rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64 3:525.60.11-1.fc37 [at]rpmfusion-nonfree-updates

dnf tells me it has no updates nor upgrades to do.

On Debian I’d do an update-initramfs and hope that fixed it (it should have been fixed during the update however).

So, given that it looks like I have the correct set of matched drivers, where to go from here? Is dracut --regenerate-all the magic bullet?


(rant: Discourse should be smart enough to understand @rpmfusion! and not tell me I can only email 2 people!)