Can't update NVIDIA driver from rpmfusion to version 525 (Fedora 37 KDE)

I tried running a game, but I got the error that my driver is too old. I need at least roughly 525, but I only have 520. Other people seem to already have the driver, although I’m not sure if they’re from rpmfusion or even on Fedora. There are no updates available on my side. Are the latest drivers already pushed to rpmfusion?

There’s a newer (525.60.11) version in a testing repository, you can test it by running:

sudo dnf update akmod-nvidia --enablerepo=rpmfusion-nonfree-updates-testing
1 Like

Please post the output of dnf list installed *nvidia* and dnf repolist so we can see exactly what is installed and what repos you may be using.

The 525.60 drivers have been on rpmfusion for some time.

Here’s the output of both commands:

Installierte Pakete
akmod-nvidia.x86_64                                      3:520.56.06-1.fc37                 @rpmfusion-nonfree
kmod-nvidia-6.0.12-300.fc37.x86_64.x86_64                3:520.56.06-1.fc37                 @@commandline     
nvidia-gpu-firmware.noarch                               20221109-144.fc37                  @updates          
nvidia-persistenced.x86_64                               3:520.56.06-1.fc37                 @rpmfusion-nonfree
nvidia-settings.x86_64                                   3:520.56.06-1.fc37                 @rpmfusion-nonfree
nvidia-texture-tools.x86_64                              2.1.2-3.fc36                       @fedora           
xorg-x11-drv-nvidia.x86_64                               3:520.56.06-1.fc37                 @rpmfusion-nonfree
xorg-x11-drv-nvidia-cuda.x86_64                          3:520.56.06-1.fc37                 @rpmfusion-nonfree
xorg-x11-drv-nvidia-cuda-libs.i686                       3:520.56.06-1.fc37                 @rpmfusion-nonfree
xorg-x11-drv-nvidia-cuda-libs.x86_64                     3:520.56.06-1.fc37                 @rpmfusion-nonfree
xorg-x11-drv-nvidia-kmodsrc.x86_64                       3:520.56.06-1.fc37                 @rpmfusion-nonfree
xorg-x11-drv-nvidia-libs.i686                            3:520.56.06-1.fc37                 @rpmfusion-nonfree
xorg-x11-drv-nvidia-libs.x86_64                          3:520.56.06-1.fc37                 @rpmfusion-nonfree
xorg-x11-drv-nvidia-power.x86_64                         3:520.56.06-1.fc37                 @rpmfusion-nonfree
Paketquellenkennung                                  Paketquellenname
brave-browser-rpm-release.s3.brave.com_x86_64_       created by dnf config-manager from Copr repo for prismlauncher owned by g3tchoo          Copr repo for KDocker owned by name     Copr repo for adw-gtk3 owned by nickavem
fedora                                               Fedora 37 - x86_64
fedora-cisco-openh264                                Fedora 37 openh264 (From Cisco) - x86_64
fedora-modular                                       Fedora Modular 37 - x86_64
google-chrome                                        google-chrome
phracek-PyCharm                                      Copr repo for PyCharm owned by phracek
rpmfusion-free                                       RPM Fusion for Fedora 37 - Free
rpmfusion-free-updates                               RPM Fusion for Fedora 37 - Free - Updates
rpmfusion-nonfree                                    RPM Fusion for Fedora 37 - Nonfree
rpmfusion-nonfree-nvidia-driver                      RPM Fusion for Fedora 37 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                              RPM Fusion for Fedora 37 - Nonfree - Steam
rpmfusion-nonfree-updates                            RPM Fusion for Fedora 37 - Nonfree - Updates
unityhub                                             Unity Hub
updates                                              Fedora 37 - x86_64 - Updates
updates-modular                                      Fedora Modular 37 - x86_64 - Updates

I’m in a similar situation: currently have the 520 drivers, even tho it does seem the 525 are available, yet I am not being offered an upgrade.

$ sudo dnf repolist | grep rpmfusion
rpmfusion-free                                 RPM Fusion for Fedora 36 - Free
rpmfusion-free-updates                         RPM Fusion for Fedora 36 - Free - Updates
rpmfusion-nonfree                              RPM Fusion for Fedora 36 - Nonfree
rpmfusion-nonfree-nvidia-driver                RPM Fusion for Fedora 36 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam                        RPM Fusion for Fedora 36 - Nonfree - Steam
rpmfusion-nonfree-updates                      RPM Fusion for Fedora 36 - Nonfree - Updates
$ dnf list installed *nvidia*
Installed Packages
akmod-nvidia.x86_64                                                          3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates
kmod-nvidia-6.0.10-200.fc36.x86_64.x86_64                                    3:520.56.06-1.fc36                                    @@commandline             
kmod-nvidia-6.0.11-200.fc36.x86_64.x86_64                                    3:520.56.06-1.fc36                                    @@commandline             
kmod-nvidia-6.0.12-200.fc36.x86_64.x86_64                                    3:520.56.06-1.fc36                                    @@commandline             
nvidia-gpu-firmware.noarch                                                   20221109-144.fc36                                     @updates                  
nvidia-persistenced.x86_64                                                   3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                       3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                                   3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                                              3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.i686                                           3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                                         3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                           3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686                                                3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                              3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                                             3:520.56.06-1.fc36                                    @rpmfusion-nonfree-updates

Even tho, the 525 are clearly available on ‘updates’

Now the update is pushed to me.

My mirror updated too. Something must have been stuck, earlier today I run dnf with --refresh parameter, yet dnf info showed 525 still in testing.

and, I have it too now.

I guess someone gave it a kick, or someone kicked them, lol

I see you have both the rpmfusion-nonfree and the rpmfusion-nonfree-nvidia-driver repos enabled. I also see that the 520 driver you currently have came from rpmfusion-nonfree and not even from the rpmfusion-nonfree-updates repo. In my experience dnf tends to stick with one repo when a package has been installed from that repo even if there are newer packages on the other repo.

Please run sudo dnf upgrade akmod-nvidia --refresh --disablerepo=rpmfusion-nonfree. This should force dnf to select the newer packages from rpmfusion-nonfree-nvidia-driver and the version update should work.

You also could get the very latest from the rpmfusion-nonfree-updates-testing repo with sudo dnf upgrade akmod-nvidia --enablerepo=rpmfusion-nonfree-updates-testing since the 525.60.11 packages are still in testing while the 525.60.06 packages are in the updates repo. This was mentioned by @ozeszty above.

1 Like

Thanks very much for the reply. However, shortly after my last post, ‘dnfdagora-updater’ offered me the 525 drivers, without me having done anything.

Good to know how to point to ‘testing’ in the future if I need to. Cheers