NVIDIA driver not working after Fedora 33 install

I have done a clean install of Fedora 33 and cannot get the NVIDIA drivers to work. I get a “NVIDIA kernel module missing. Falling back to nouveau” message on startup.

I have a GPU installed.

$ lspci -v | grep NVIDIA
01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1) (prog-if 00 [VGA controller])
01:00.1 Audio device: NVIDIA Corporation GM206 High Definition Audio Controller (rev a1)

Specifically, this (3D capable) GPU, if it matters:

The GPU & drivers worked fine with my previous Ubuntu installation.

Below are the exact setup steps I followed, after updating all packages and installing the kernel headers, etc.

sudo dnf install fedora-workstation-repositories
sudo dnf config-manager --set-enabled rpmfusion-nonfree-nvidia-driver
# reboot
# verify:
sudo dnf repository-packages rpmfusion-nonfree-nvidia-driver info
sudo dnf install akmod-nvidia nvidia* xorg-x11-drv-nvidia*
# wait 5 minutes, this should show the version number
modinfo -F version nvidia
# reboot, should have nvidia tools installed now

This is a desktop computer.

I have another desktop computer with a 1080Ti and installed Fedora two weeks ago and those setup steps worked fine. A week ago I tried installing Fedora 32 on this computer and had the same NVIDIA driver problem. Using Fedora 33 instead didn’t change anything. I suspect this graphics card is deficient in some way and I don’t know what to do to proceed.


Any error message during installation?

Previously I had different issues. Later I followed cuda installation tutorial for Fedora, that kernel module works for me well.

You seem to have gone about it in a different way than me.

I went to RPM fusion with Firefox, klicked on the relevant repo links (at that time for Fedora 32) and installed them using Software.

Then I just ran
sudo dnf install akmod-nvidia

…and rebooted. I have no need for the Cuda drivers, so that was it for me. I have an old NVIDIA 1050 workhorse, works splendidly in all distros I have tried it with.


I think you are having issues with the newer kernels. The problem is that Nvidia is not supporting new kernels until the middle of November as far as I know. What a experienced Fedora user here in Brazil oriented me to do with my 1060 Nvidia card was to do download in Koji the following packages from kernel 5.8.15-301:

  • Kernel
  • Kernel-core
  • Kernel-devel
  • Kernel-modules
  • Kernel-modules-extra

Then you install all of them with dnf install. Here a link where you can find these packages:

After you do that, you boot into the new installed kernel and install the kmod-nvidia package from Rpmfusion and then reboot again into that kernel and uses it until Nvidia fix things. If you have the akmod already installed, you should probably take it off to install the kmod… but I’m not so sure, I’m a simple user.

That’s it… remember that I’m not a experienced user, and I’m just trying to give an option so you can deal with this problem. Maybe you should backup your files to recover than easily in case you end up stuck in the CLI and you feel like you will have difficulties in a situation like this.

Observe as well that I’m considering that you Nvidia GPU is normal one (no optimus-prime mess) from 2012 or later.

Also remember that Koji is not exactly Fedora repositories, and you will be downloading a build done by a kernel mantainer in Fedora. As a simple user, i can’t tell you how much safe it is compared to the official repositories, but talking with more experienced users, i decided it was secure enought for me.

Good luck.

Possible useful documentation:

1 Like

Probably these older kernels installed manually won’t receive security updates. In an ideal world Nvidia would not stop supporting newer kernels, and if they did so, Fedora could have an linux-lts package like Arch or Solus for example. Despite I heard that Solus (that focus more on beginners) didn’t even allowed the linux-current kernel to upgrade to non-nvidia supported kernels.

This is the case with kernel 5.9, not with 5.8

Also, there is no need to download any 5.8.x kernel from koji, the latest (8.5.16) is in the repos.

With 5.8.16-300, as far as I remember, with my Nvidia 1060, I had the same problem of the author of the post.

If we all have Fedora 33 installed and are uptodate, wouldn’t we all have the same kernel? Why would some Nvidia cards work and not others? Why does everything work fine on my other Fedora computer with a 1080 GPU?

This is the kernel version I am on:

$ uname -a
Linux main 5.8.16-300.fc33.x86_64 #1 SMP Mon Oct 19 13:18:33 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

I’m on 5.8, so the kernel should be supported then. What else could be the problem?

There were no errors during the installation.

One sad possibility is that the card is physically shot, but then you probably wouldn’t get a picture at all.

You are putting ideas in my head about getting one of Nvidia’s new graphics cards…

This computer happens to be double-boot so I switched over to Windows and confirmed that Windows can use the GPU just fine. So it can’t be the hardware.

Wanna give this a try?

by the way, AMD and Intel release open-source drivers for their GPUs, no need to hassle around with propr. drivers that stop working from time to time…

sudo dnf install gcc kernel-headers kernel-devel akmod-nvidia xorg-x11-drv-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia-libs.i686

to get the driver and all necessary dependencies.

Then wait at least 5 minutes for the modules to load, then

sudo akmods --force
sudo dracut --force

This would force the configuration to be read from the updated kernel modules which now have the NVIDIA drivers in them.

Then wait again, for at least 3 minutes, then reboot.

1 Like

Thanks for listing it here, @florian. :heart:

Indeed. If you are getting yourself a new GPU, just follow the brilliant advice given by Linus Torvalds (find it here) and stay away from Nvidia.


The kernel module forcing part is now included in the post-installation hook already, and is no more required to be run explicitly and the wait is also optional as the modules would be load completely before poweroff and before boot.

(Find the reference here. Even the tool I wrote used to make users wait for this long until v0.2.5 and it was so inconvenient :laughing:)

1 Like

OK, good to know.

@hx2a, so no need to wait, as I suggested, you can run one command straight after another

Thanks, and I appreciate that AMD and Intel release open-source drivers. I would go with that but I need the Nvidia card and drivers so I can use CUDA for ML research. I wish Nvidia would release open-source drivers also.

I’m happy to be a team player and help with the testing. To be clear on the steps here, I need to install the Python package in this repo and run the NVAutoInstFedora32 tool, even though I have Fedora33 installed. I should try each of the different “installation modes” and see if any of them work. Right? If there are errors or something doesn’t work, should I report back here or open an issue in that repo?


I tried all these steps and it didn’t work. :cry: Thank you for the suggestion though. :grinning:

1 Like

I just took a moment to validate my assumption that pytorch can only run on Nvidia graphics cards and it seems I might not have been correct. I actually don’t care at all about Nvidia cards, I just want pytorch to work.

1 Like

Exactly :100:

That is what you would need to do.

No dice. I tried every installation mode, most of which said “nothing to do” because the packages were already installed. The -plcuda and --vidacc ones installed a bunch of stuff.

Are there other ideas I can try?

[ ! ] Compatibility infomation was obtained
[ ✔ ] One or more active NVIDIA GPUs were detected
      01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)
[ ✔ ] An single dedicated GPU setup was detected
[ ! ] Host information was gathered
      System: Linux v5.8.16-300.fc33.x86_64
      Hostname: main
      Version: #1 SMP Mon Oct 19 13:18:33 UTC 2020
      Distribution: Fedora x86_64
[ ✔ ] Supported OS detected
      This tool is expected to work correctly here
[ ✘ ] Leaving installer