Unable to install nvidia drivers

I installed Fedora KDE 32 on my laptop HP Elitebook 8560W with embedded NVIDIA Quadro 1000M card. I am following this guide: Howto/NVIDIA - RPM Fusion. I added rpmfusion repo and run these commands to install the drivers:

sudo dnf install akmod-nvidia
sudo dnf install xorg-x11-drv-nvidia-cuda 

But when i reboot i get the message: “nvidia kernel module missing. falling back to nouveau”.
I also checked my bios but i don’t see option for secure boot.

I meant “If your hardware is the optimus/prime configuration linked to by the optimus link in your guide you will need to follow those directions as well.”

You can tell if (as is likely on a laptop) you have dual video cards by running “lspci | grep VGA”
If that returns 2 lines such as

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
01:00.0 VGA compatible controller: NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] (rev a1)

then you have the prime (formerly optimus) configuration.

I guessed because I am not familiar with any laptops that have nvidia video as the primary controller.

1 Like

Why do you think my device is optimus? If i run /sbin/lspci | grep -e 3D it doesn’t show any output.

Also, if i run modinfo -F version nvidia it gives this ouput 450.66. I guess that mean the drivers are installed.

post the results of dnf list installed '*nvidia*' and compare it to mine

This is the output of list installed '*nvidia*':

Installed Packages
akmod-nvidia.x86_64                                                            3:450.66-1.fc32                                      @rpmfusion-nonfree-updates
kmod-nvidia-5.8.12-200.fc32.x86_64.x86_64                                      3:450.66-1.fc32                                      @@commandline             
nvidia-persistenced.x86_64                                                     3:450.66-1.fc32                                      @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                         3:450.66-1.fc32                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                                     3:450.66-2.fc32                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                                                3:450.66-2.fc32                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                                           3:450.66-2.fc32                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                             3:450.66-2.fc32                                      @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                                3:450.66-2.fc32                                      @rpmfusion-nonfree-updates

And this is the output of lspci | grep VGA:

01:00.0 VGA compatible controller: NVIDIA Corporation GF108GLM [Quadro 1000M] (rev a1)

Strange, it seems a couple of my posts here have disappeared??
In any case, your package list is similar to mine, and other than my laptop having the dual GPU design and yours having only the nvidia GPU there seems no real difference…I really don’t see any reason why yours can’t work with the nvidia driver.

One other command to see if the drivers are actually loading would be kmod list | grep nvidia and see if there are about 6 lines displayed. If so then the nvidia drivers are active.
If the nouveau drivers are active the same command with grep for nouveau will return results.

This (kmod-nvidia-5.8.12-200.fc32.x86_64.x86_64) package tells me that akmod has built the nvidia drivers for the existing kernel so there should be no problems unless some of the needed headers or compiler packages are missing.
Just by chance, are you dual booting with windows? If so is your bios set for secure boot or fast boot? Since the nvidia driver “taints” the kernel there have been some issues with secure boot interfering with fedora and IIRC loading a module that taints the kernel may be one of those issues. YMMV

Maybe someone else has another idea.

If i run kmod list | grep nvidia i don’t see any output. If i run kmod list | grep nouveau i see this output:

nouveau              2342912  22
i2c_algo_bit           16384  1 nouveau
ttm                   122880  1 nouveau
drm_kms_helper        262144  1 nouveau
drm                   626688  12 drm_kms_helper,ttm,nouveau
mxm_wmi                16384  1 nouveau
wmi                    36864  4 hp_wmi,wmi_bmof,mxm_wmi,nouveau
video                  53248  1 nouveau

I guess nvidia drivers are not loading.

Yes, i dual boot with Windows 10, but my laptop does not have secure boot option in the bios. It has fast boot option though, but it make no difference if it is enabled or disabled.

Yep, the driver for nvidia seems available but definitely is not loading.

You might try editing the boot command in grub during your next boot and see if it contains (or if you can add) something similar to rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 . I seem to remember when I first started using the nvidia drivers that I had to do that the first time although on my current laptop that apparently was put in place during the driver install.
If it works with no problems and the nvidia drivers are loaded then you can edit /etc/default/grub and add that to the GRUB_CMDLINE_LINUX entry then run grub2-mkconfig -o /etc/grub2-efi.cfg to make it permanent.

Are you running wayland or x11?
Is the video suitable as is? or do you need something more?

The nouveau driver has improved a lot over time and some are quite satisfied with it. Just because I prefer the nvidia drivers for my use does not mean everyone needs them.

I entered edit mode on boot and these three entries are already there.

This shouldn’t be so complicated. I think i will try Manjaro KDE.

Anyway, thanks for the help.