Fedora 40 Beta1 - KDE Plasma 6 Spin - Unable To Get Proprietary nVidia Display Driver Working?

Hi,

I thought I would take a look at Fedora 40 Beta1 KDE Plasma 6 spin.
Only issue is with the nVidia propriety display driver installation.

I tried various directions on the Internet.
Where I am at now is that I receive below error when booting Fedora:
“nVidia kernel module not found - falling back to nouveau”?

Any help would be appreciated, I don’t know much about Linux…

Been using Linux for over 10 years, but only *ubuntu distros, currently on Linux Mint.

Jesse

Did you try using the installation method shown here?

and here
https://rpmfusion.org/Howto/NVIDIA?highlight=(\bCategoryHowto\b)

If you have secure boot enabled it prevents the nvidia modules from loading by default.
It thus is required to either

  1. Disable secure boot
    or
  2. Sign the nvidia modules as shown here
    Howto/Secure Boot - RPM Fusion

Hi,

Thanks for the reply.
Those are the instructions I used.
I already have: “Secure Boot” disabled in the BIOS.
Completely new to Fedora, so hope someone can help me!

Jesse

Hi,

Below is the Terminal output when installing the nVidia display driver:

Thanks in advance…

Jesse

All of those install logs look perfectly normal. I would not expect problems with that.
Please try the following to verify the modules were built and load correctly.

  1. sudo dnf remove kmod-nvidia-*
  2. sudo akmods --force
  3. reboot
  4. Check the loading of the modules with lsmod | grep -E "nvidia|nouveau"
    to see if the nvidia modules loaded this time.
  5. Also check that the firmware package is properly loaded with dnf list installed \*nvidia\*. Which should show all related packages including the nvidia-gpu-firmware package. Without that the gpu may not operate properly and the modules may not load.

Which GPU do you have?

Hi,

Thanks for the assistance.

I get an error message:

jlp@DESKTOP-VGC263Q:~$ sudo dnf remove kmod-nvidia-*
[sudo] password for jlp: 
Dependencies resolved.
==============================================================================================================
 Package                                   Architecture   Version                 Repository             Size
==============================================================================================================
Removing:
 kmod-nvidia-6.8.4-300.fc40.x86_64         x86_64         3:550.67-1.fc40         @@commandline          40 M

Transaction Summary
==============================================================================================================
Remove  1 Package

Freed space: 40 M
Is this ok [y/N]: Y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                      1/1 
  Erasing          : kmod-nvidia-6.8.4-300.fc40.x86_64-3:550.67-1.fc40.x86_64                             1/1 
  Running scriptlet: kmod-nvidia-6.8.4-300.fc40.x86_64-3:550.67-1.fc40.x86_64                             1/1 

Removed:
  kmod-nvidia-6.8.4-300.fc40.x86_64-3:550.67-1.fc40.x86_64                                                    

Complete!
jlp@DESKTOP-VGC263Q:~$ sudo akmods --force
Checking kmods exist for 6.8.5-301.fc40.x86_64 [  OK  ]
Files needed for building modules against kernel
6.8.5-301.fc40.x86_64 could not be found as the following
directories are missing:
/usr/src/kernels/6.8.5-301.fc40.x86_64/
/lib/modules/6.8.5-301.fc40.x86_64/build/Is the correct kernel-devel package installed? [FAILED]
Checking kmods exist for 6.8.4-300.fc40.x86_64 [  OK  ]
Building and installing nvidia-kmod [  OK  ]
jlp@DESKTOP-VGC263Q:~

Jesse

It would appear you have updated F40 from the updates-testing repo since kernel 6.8.5 was not in the currently frozen release repo.

You may need to explicitly install the kernel-devel package to match. I would suggest that you use the following to check as I did.

 dnf list installed kernel-devel*
Installed Packages
kernel-devel.x86_64                                             6.8.2-300.fc40                                      @updates-testing
kernel-devel.x86_64                                             6.8.4-300.fc40                                      @updates-testing
kernel-devel.x86_64                                             6.8.5-301.fc40                                      @updates-testing
kernel-devel-matched.x86_64                                     6.8.5-301.fc40                                      @updates-testing

If those 2 kernel devel packages for kernel 6.8.5 are not installed then install them with
sudo dnf install kernel-devel-6.8.5* kernel-devel-matched-6.8.5* --enablerepo updates-testing to get the proper kernel files needed to build the nvidia modules properly, then repeat the commands above to build and install the modules.

1 Like

Hi,

I appreciate your help, I really do.
But this is a fail.
I’ll stay with Linux Mint at this time.
Thank you again.

Jesse

Without details it becomes difficult to make more suggestions. A generalized reply like this does not aid us in providing assistance.
Would you please show the commands I asked for and the actual results you received on the screen for each command.
Example as shown by my dnf list installed kernel-devel* command above, and the results of the followingdnf install ... command as well. that is a good starting point to get the details of what may be going wrong.

jlp@DESKTOP-VGC263Q:~$ dnf list installed kernel-devel*
Installed Packages
kernel-devel.x86_64                                  6.8.5-301.fc40                           @updates-testing
kernel-devel-matched.x86_64                          6.8.5-301.fc40                           @updates-testing
jlp@DESKTOP-VGC263Q:~$ sudo dnf install kernel-devel-6.8.5* kernel-devel-matched-6.8.5* --enablerepo updates-testing
[sudo] password for jlp: 
Last metadata expiration check: 0:08:36 ago on Sat 13 Apr 2024 04:50:30 PM EDT.
Package kernel-devel-6.8.5-301.fc40.x86_64 is already installed.
Package kernel-devel-matched-6.8.5-301.fc40.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
jlp@DESKTOP-VGC263Q:~$

So that installation appears correct.
Exactly what seems to be failing as you said just above?
Details please.

The kernel devel package seems to contradict the error with akmods. On my system those 2 directories do exist after installing the kernel-devel packages.

$ sudo dnf provides /lib/modules/6.8.5-301.fc40.x86_64/build/ --enablerepo updates-testing
kernel-modules-core-6.8.5-301.fc40.x86_64 : Core kernel modules to match the core kernel
Repo        : updates-testing
Matched from:
Other       : /lib/modules/6.8.5-301.fc40.x86_64/build/


$ sudo dnf provides /usr/src/kernels/6.8.5-301.fc40.x86_64 --enablerepo updates-testing
Last metadata expiration check: 0:01:44 ago on Sat 13 Apr 2024 04:35:26 PM CDT.
kernel-devel-6.8.5-301.fc40.x86_64 : Development package for building kernel modules to match the kernel
Repo        : updates-testing
Matched from:
Filename    : /usr/src/kernels/6.8.5-301.fc40.x86_64

As you can see the kernel-devel package provides one of those directories and its content and the kernel-modules-core package does the same for the other directory.

I would, though, recommend that you do a full update from the updates testing repo to ensure everything possible is up to date and matching in versions.
dnf update --refresh --enablerepo updates-testing

A simple ls command can tell you if those paths actually exist.

Hi,

I opened “NVIDIA Settings” application and it’s missing features?

I ran Superposition graphic benchmark and it does not recognize my GPU?
(Super position benchmark runs choppy - it freezes for a second every couple of seconds?)

Any ideas - KDE Plasma 6 uses Wayland so perhaps that is an issue?

Jesse

Please post the output from dnf list installed \*nvidia\* and inxi -Fzxx

I don’t know anything about the superposition benchmark but will test it if I can install it.
Where was it installed from?

I am only able to find version 1.1 with a date of 2019 so it seems a bit out of date. But will test anyway.

jlp@DESKTOP-VGC263Q:~$ sudo dnf list installed \*nvidia\*
[sudo] password for jlp: 
Installed Packages
akmod-nvidia.x86_64                                3:550.67-1.fc40            @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.8.5-301.fc40.x86_64.x86_64           3:550.67-1.fc40            @@commandline                   
nvidia-gpu-firmware.noarch                         20240410-1.fc40            @updates-testing                
nvidia-modprobe.x86_64                             3:550.67-1.fc40            @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64                         3:550.67-1.fc40            @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                             3:550.67-1.fc40            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                         3:550.67-1.fc40            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64                    3:550.67-1.fc40            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64               3:550.67-1.fc40            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                 3:550.67-1.fc40            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                    3:550.67-1.fc40            @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                   3:550.67-1.fc40            @rpmfusion-nonfree-nvidia-driver
jlp@DESKTOP-VGC263Q:~$
jlp@DESKTOP-VGC263Q:~$ inxi -Fzxx
System:
  Kernel: 6.8.5-301.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-34.fc40
  Desktop: KDE Plasma v: 6.0.3 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
    Distro: Fedora Linux 40 (KDE Plasma)
Machine:
  Type: Desktop System: Dell product: G5 5000 v: N/A
    serial: <superuser required> Chassis: type: 3 serial: <superuser required>
  Mobo: Dell model: 0M6C7G v: A00 serial: <superuser required> part-nu: 09BC
    UEFI: Dell v: 1.15.0 date: 08/09/2023
CPU:
  Info: 6-core model: Intel Core i5-10400F bits: 64 type: MT MCP
    arch: Comet Lake rev: 3 cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  Speed (MHz): avg: 800 min/max: 800/4300 cores: 1: 800 2: 800 3: 800 4: 800
    5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 bogomips: 69597
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] vendor: Dell driver: nvidia
    v: 550.67 arch: Turing pcie: speed: 2.5 GT/s lanes: 16 ports: active: none
    off: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 01:00.0 chip-ID: 10de:2187
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.6
    compositor: kwin_wayland driver: N/A display-ID: 0
  Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 2 drv: swrast
    gbm: drv: nvidia surfaceless: drv: nvidia wayland: drv: nvidia x11:
    drv: zink inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.67
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1650
    SUPER/PCIe/SSE2 display-ID: :0.0
  API: Vulkan v: 1.3.280 surfaces: xcb,xlib,wayland device: 0
    type: discrete-gpu driver: N/A device-ID: 10de:2187 device: 1 type: cpu
    driver: N/A device-ID: 10005:0000
Audio:
  Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:06c8
  Device-2: NVIDIA TU116 High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aeb
  API: ALSA v: k6.8.5-301.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.4 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks Dual Band
    Wi-Fi 6 Killer AX1650i 160MHz 2x2 driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0
  IF: wlo1 state: down mac: <filter>
  Device-2: Realtek Killer E2600 GbE vendor: Rivet Networks driver: r8169
    v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0
    chip-ID: 10ec:2600
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-14:5 chip-ID: 8087:0026
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11
Drives:
  Local Storage: total: 1.38 TiB used: 9.49 GiB (0.7%)
  ID-1: /dev/nvme0n1 vendor: Netac model: NS512GSSD530 size: 476.94 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 32.9 C
  ID-2: /dev/sda vendor: A-Data model: SU720 size: 931.51 GiB
    speed: 6.0 Gb/s serial: <filter> temp: 25 C
Partition:
  ID-1: / size: 475.35 GiB used: 9.11 GiB (1.9%) fs: btrfs dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 368.3 MiB (37.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 475.35 GiB used: 9.11 GiB (1.9%) fs: btrfs
    dev: /dev/nvme0n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 29.0 C pch: 33.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 32 GiB available: 31.11 GiB used: 4.09 GiB (13.1%)
  Processes: 494 Power: uptime: 1h 9m wakeups: 1 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: Compilers: gcc: 14.0.1 Shell: Bash v: 5.2.26 running-in: konsole
    inxi: 3.3.33
jlp@DESKTOP-VGC263Q:~$

Hi,

I am going to give up on Fedora at this point, and stay with Linux Mint.

In Linux Mint, to install proprietary nVidia display driver I do the following:

  1. Open “Driver Manager” application
  2. Select which nVidia driver I want to install
  3. Click [Install] button
  4. Reboot
  5. Done

Thanks for your help, but Fedora is complicated and not for people without deep knowledge of Linux.

Jesse

Did you try the released version of fedora(F39)?

1 Like

Encountered similar issue



seems some packages aren’t exist atm?

The kernel 6.8.6 packages for fedora are in the updates-testing repo.
If you were to run the installation of the nvidia drivers as shown at
https://rpmfusion.org/Howto/NVIDIA?highlight=(\bCategoryHowto\b)
that would automatically pull in the necessary dependencies for the latest kernel available in the fedora repo.
If you wish the 6.8.6 kernel with those drivers you then could run
dnf upgrade kernel* --enablerepo updates-testing and it would pull in the upgraded packages for the kernel to match the ones already installed from the earlier kernel version and build the drivers for the 6.8.6 kernel. The latest kernel-headers package at present is the 6.8.3 version.

1 Like