Nvidia and 5.18.13

Anyone have any suggestions on how to fix my 5.18.13/Nvidia problem. Good Lord, what a mess. I’ve just get a black screen.


Well, we would need to have some idea what you are referring to.

I have fedora 36, kernel 5.18.13, with nvidia GPU and drivers and have seen no issues.

Your question gives no info about what you may be experiencing.

BTW, just so you know, and advice to a new forum member.

Really crass terms such as you used are severely frowned upon here and are borderline to breaking the forum rules of allowed language.

Sorry for my meltdown. I’ve tried everything, i.e. uninstall NVIDIA, reinstalled the drivers, but I still get a black screen. 5.18.11 works great.

Can you give me a few instructions on how to identify the issue, please?

I’ve concluded that NVIDIA 515.57-1 is not compatible with kernel 5.18.13. See Nvidia driver not working on Fedora 36 (Dell m7540) - Linux - NVIDIA Developer Forums

That conclusion may be hardware specific or related to your specific config.

I have seen no other posts on this issue and that driver & kernel combination certainly works well for me.

Well, 5.18.13 just came out a few days ago. And 5.18.11 and 5.18.10 and NVIDIA 515.57 work GREAT.

The person on the NVIDIA forum (link above) describes it better.

What does your /etc/default/grub file look like? Perhaps there’s a boot param under your GRUB_CMDLINE_LINUX that could explain the issue? Perhaps the latest kernel doesn’t cope well with a flag you have there set for NVIDIA?

In my system which works perfectly with kernel 5.18.13 and nvidia drivers installed from rpmfusion, the /etc/default/grub file has as the kernel command line (which has only been modified by installing akmod-nvidia) reads
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init rd.lvm.lv=fedora/root rhgb quiet"

As suggested, check yours and see what that line says. Post the entire content of that file here please, using the </> Preformatted text tags available on the toolbar above.

GRUB_DISTRIBUTOR=“$(sed ‘s, release .*$,g’ /etc/system-release)”
GRUB_CMDLINE_LINUX=“rhgb quiet fips=0 boot=UUID=aba53867-4ab8-40c8-9c4a-75560998f793 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init”

I do not have, and never have had, fips=0 boot=UUID=aba53867-4ab8-40c8-9c4a-75560998f793 or anything like it in the GRUB_CMDLINE_LINUX=“xxxx” in that file.

I wonder if that may be the problem.?

You may try booting and when the grub menu appears press ‘e’ to edit the grub entry for kernel 5.18.13. Remove that portion from the line that begins with linux then press ctrl-X to continue booting.
If things work properly then you can make the change permanent by

  1. Edit /etc/default/grub and remove the noted portion of that command line
  2. run sudo grub2-makeconfig -o /boot/grub2/grub.cfg to update grub
  3. reboot

5.18.13 still give a black screen. 5.18.11 works fine with the changes.

PS On the NVIDIA forum thread, guy reports that it’s 5.18.13 + NVIDIA in F36 that’s the problem. F35 5.18.13 works fine.

Try modifying that line in /etc/default/grub to read GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init rd.lvm.lv=fedora/root rhgb quiet kvm.ignore_msrs=1" then rebuild grub.cfg again and reboot. to see if that one addition (kvm.ignore_msrs=1) makes the difference

Before we proceed with a goose-chase, what does kvm.ignore_msrs=1 do?

Exactlywhat it does I am not sure. I used it since I was experiencing intermittent hangs with keyboard & mouse and when I added that parameter to the kernel boot line it reduced the problem. There are several threads here that suggest it.

If you are uncertain you can add it for that one boot by editing the kernel command line during boot as suggested earlier and see the results.

On the NVIDIA forum, there’s more speculation that NVIDIA may not be compatible with F36, specifically simpledrm.

See Nvidia driver not working on Fedora 36 (Dell m7540) - #11 by generix - Linux - NVIDIA Developer Forums

It might help to know how you installed the driver.I used rpmfusion and haven’t had any issues with kernel 5.18.13 or nvidia 5.15.57.

rpmfusion. Again, as is being reported on NVIDIA’s Forum, it appears to be an issue with F36. 5.18.13 and 5.15.57 work fine on F35.

Myself and I’m pretty sure Jeff are running F36.Have you tried reinstalling the driver to make sure it built when you updated to kernel 5.18.13.I’m pretty sure also that 5.18.14 should also be out very soon as well.I use F36 testing repo quite abit so maybe there was something that I updated to that hasn’t made it into the regular repo yet.

I have not installed anything from the testing repo so that should not be a factor. I also have never installed anything nvidia related from anywhere but rpmfusion.

I could suggest a (rather extreme but usually effective) procedure. This is based upon the possibility that something may have been borked with an earlier install of nvidia from rpmfusion. It also has instructions based upon potential repo conflicts.

  1. dnf repolist
    If you see both rpmfusion-nonfree and rpmfusion-nonfree-nvidia-driver repos listed then disable the rpmfusion-nonfree-nvidia-driver during the reinstall in step 3.
  2. uname -a
    This is to verify which kernel you are booted from and you should always be running the latest installed kernel when you continue from this step.
  3. sudo dnf remove *nvidia*
    This removes all nvidia related packages from the system.
  4. sudo dnf upgrade
    This makes certain your system is fully updated.
  5. sudo dnf install akmod-nvidia-515* xorg-x11-drv-nvidia-cuda
    This is where you should disable the repo mentioned in step 2 above. To do that add --disablerepo=rpmfusion-nonfree-nvidia-driver to the command if you had both repos listed in step 2 above.
  6. Wait about 5 minutes then reboot and the nvidia drivers should just work for you.

Normally there is no conflict between rpmfusion-nonfree and rpmfusion-nonfree-nvidia-driver but there have been (rare) instances where the 2 repos are not in sync and it may cause problems when that happens. I recommend having one or the other but not both enabled for that reason.

Yep. Did that several times the other day. And with each try, still broken. That was the reason for my opening meltdown.

Do you now have the following in the kernel command line in /etc/default/grub?


If I recall correctly, at some point I had to add that for a similar black screen problem.