Non-Fedora Packages missing in "dnf update" after upgrading from F38 to F39


My packages are missing when i run dnf update after upgrading from F38 to F39.

I recently upgraded my system from F38 to F39 following this guide word for word. After the upgrade finished and I went in to update all my repositories with dnf update, it did not show me any of Fedora’s repositories or any of the ones that I had included. Only tor’s repository:

$ sudo dnf update
Tor for Fedora 39 - x86_64                      377  B/s | 265  B     00:00    
Errors during downloading metadata for repository 'tor':
  - Status code: 404 for (IP:
Error: Failed to download metadata for repo 'tor': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
Ignoring repositories: tor
Last metadata expiration check: 0:11:55 ago on Sat 28 Oct 2023 12:45:58 PM EEST.
Dependencies resolved.
Nothing to do.

Now I don’t mind the error tor is giving (of course I would like to get it fixed but that’s besides the point), but all my other repositories are gone. Same goes for dnf upgrade, returns the same thing.


Not yet known.

Related Issues

Have not found any yet :frowning:


None yet.

That is not a Fedora repo. You will need to ask the owner when they will be supporting Fedora 39.
Fedora 39 has not been released yet, it is still in Beta.

1 Like

What do you mean exactly?
Do you mean that all the files in /etc/yum.repos.d have been deleted?

You apparently just performed the update.
Dnf does not show the repos it is searching unless it is currently downloading the repo metadata when run with the upgrade.

If you run dnf repolist it should show the repos that are enabled.
If you run dnf upgrade --refresh it should show the repos as it downloads new metadata.
If you run dnf upgrade and see something like this

# dnf upgrade
Last metadata expiration check: 0:42:43 ago on Sat 28 Oct 2023 09:33:13 AM CDT.
Dependencies resolved.

which it showed you here

that means the cache of the repo metadata is current and it does not display the repos.

Oh okay so if it does not show me any of my other repos, then it means they don’t need any updates?

Because for some reason I remember before the update when I ran dnf update, it used to show me all my repos and confirmed their existence.

To reply to you, yes dnf repolist shows all my repos and dnf update --refresh also refreshes them aswell.

So this is how it’s supposed to be normally then and nothing has gone wrong?

Refreshing the metadata is not the same as needing updates. There may be pending updates while the metadata is still current, so you may get the same message saying last expiration check is current and not download the metadata while at the same time it downloads packages for updates.
This situation is quite common.

This happens any time the cache of the metadata has expired and not yet refreshed.