No WIFI Adapter Found and Bluetooth acting weird RTL8822BE

Hi! i have a low spec laptop that used to run WIN11 and always worked fine.
Now i wanted to try linux (fedora35) but after installation there was no WIFI so i had to make the connection via bluetooth tethering for all the updating stuff.
To make it short:

*Bluetooth is always on when laptops boot (even if turned off before shut down)
*When i turn bluetooth off, then airplane mode turns it self on and if i turn airplane mode off, again BT is back on (facepalm)
*WIFI adapter is always disabled, no menu, no nothing

I have tried many online possible solutions and sometimes after that, WIFI adapter shows up (has menu, i can see network near me and even connect to mine) but as soon as i open youtube or anything BOOM it disconnects and is not going to show again (no networks near me, no name in the up right menu, nothing)

So after many many attempts i discovered that if i turn bluetooth off, then turn airplane mode off, then again my bluetooth off and then turn off my laptop (not reboot but complete turn off) then when i go back on, the WIFI adapter will appear and i can interact with it (looking to networks nearby, making a succesful connection to mine) but as soon as i put any load on it BOOM dissapears again.

So thats the problem after installing and reinstalling my Realtek drivers, im stuck with bluetooth tethering jejeje i have to say, im learning a lot :slight_smile:

[annamemnon@adamski ~]$ inxi -Nxx
Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter driver: N/A pcie:
  speed: Unknown lanes: 63 bus-ID: 02:00.0 chip-ID: 10ec:b822
[annamemnon@adamski ~]$ [annamemnon@adamski ~]$ inxi -Nxx

I can see from top to bottom the first rtw_8822be entry without any driver even tho i just installed the thing :thinking:

[annamemnon@adamski ~]$ lsmod
Module                  Size  Used by
uinput                 20480  0
rfcomm                 94208  4
snd_seq_dummy          16384  0
snd_hrtimer            16384  1
nft_objref             16384  1
nf_conntrack_netbios_ns    16384  1
nf_conntrack_broadcast    16384  1 nf_conntrack_netbios_ns
nft_fib_inet           16384  1
nft_fib_ipv4           16384  1 nft_fib_inet
nft_fib_ipv6           16384  1 nft_fib_inet
nft_fib                16384  3 nft_fib_ipv6,nft_fib_ipv4,nft_fib_inet
nft_reject_inet        16384  6
nf_reject_ipv4         16384  1 nft_reject_inet
nf_reject_ipv6         20480  1 nft_reject_inet
nft_reject             16384  1 nft_reject_inet
nft_ct                 20480  16
nft_chain_nat          16384  2
nf_nat                 57344  1 nft_chain_nat
nf_conntrack          163840  4 nf_nat,nft_ct,nf_conntrack_netbios_ns,nf_conntrack_broadcast
nf_defrag_ipv6         24576  1 nf_conntrack
nf_defrag_ipv4         16384  1 nf_conntrack
ip_set                 61440  0
nf_tables             274432  272 nft_ct,nft_reject_inet,nft_fib_ipv6,nft_objref,nft_fib_ipv4,nft_chain_nat,nft_reject,nft_fib,nft_fib_inet
nfnetlink              20480  3 nf_tables,ip_set
qrtr                   49152  4
bnep                   28672  3
sunrpc                655360  1
snd_sof_pci_intel_cnl    16384  0
snd_sof_intel_hda_common   110592  1 snd_sof_pci_intel_cnl
soundwire_intel        45056  1 snd_sof_intel_hda_common
soundwire_generic_allocation    16384  1 soundwire_intel
soundwire_cadence      36864  1 soundwire_intel
snd_sof_intel_hda      20480  1 snd_sof_intel_hda_common
snd_sof_pci            20480  2 snd_sof_intel_hda_common,snd_sof_pci_intel_cnl
snd_sof_xtensa_dsp     16384  1 snd_sof_intel_hda_common
snd_sof               167936  2 snd_sof_pci,snd_sof_intel_hda_common
rtw_8822be             16384  0
soundwire_bus          94208  3 soundwire_intel,soundwire_generic_allocation,soundwire_cadence
rtw_8822b             229376  1 rtw_8822be
snd_soc_skl           176128  0
snd_soc_hdac_hda       24576  2 snd_sof_intel_hda_common,snd_soc_skl
snd_hda_ext_core       36864  4 snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
rtw_pci                28672  1 rtw_8822be
snd_soc_sst_ipc        20480  1 snd_soc_skl
snd_hda_codec_hdmi     73728  1
snd_soc_sst_dsp        36864  1 snd_soc_skl
snd_soc_acpi_intel_match    61440  3 snd_sof_intel_hda_common,snd_soc_skl,snd_sof_pci_intel_cnl
rtw_core              245760  2 rtw_8822b,rtw_pci
intel_tcc_cooling      16384  0
x86_pkg_temp_thermal    20480  0
snd_soc_acpi           16384  3 snd_soc_acpi_intel_match,snd_sof_intel_hda_common,snd_soc_skl
intel_powerclamp       20480  0
iTCO_wdt               16384  0
intel_pmc_bxt          16384  1 iTCO_wdt
snd_soc_core          348160  5 soundwire_intel,snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl
iTCO_vendor_support    16384  1 iTCO_wdt
snd_hda_codec_realtek   163840  1
coretemp               20480  0
snd_compress           28672  1 snd_soc_core
snd_hda_codec_generic    98304  1 snd_hda_codec_realtek
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_sof
mei_pxp                20480  0
ac97_bus               16384  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
kvm_intel             368640  0
spidev                 24576  0
mei_hdcp               24576  0
snd_hda_intel          57344  2
intel_rapl_msr         20480  0
snd_intel_dspcfg       32768  3 snd_hda_intel,snd_sof_intel_hda_common,snd_soc_skl
snd_intel_sdw_acpi     20480  2 snd_sof_intel_hda_common,snd_intel_dspcfg
snd_hda_codec         172032  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda
btusb                  65536  0
snd_hda_core          110592  10 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
kvm                  1064960  1 kvm_intel
snd_hwdep              16384  1 snd_hda_codec
snd_seq                90112  7 snd_seq_dummy
vfat                   20480  1
fat                    86016  1 vfat
btrtl                  28672  1 btusb
mac80211             1191936  2 rtw_core,rtw_pci
snd_seq_device         16384  1 snd_seq
irqbypass              16384  1 kvm
uvcvideo              126976  0
libarc4                16384  1 mac80211
btbcm                  20480  1 btusb
snd_pcm               151552  11 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,soundwire_intel,snd_sof,snd_sof_intel_hda_common,snd_compress,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
videobuf2_vmalloc      20480  1 uvcvideo
rapl                   20480  0
btintel                49152  1 btusb
asus_nb_wmi            28672  0
intel_cstate           20480  0
videobuf2_memops       20480  1 videobuf2_vmalloc
asus_wmi               57344  1 asus_nb_wmi
intel_uncore          212992  0
videobuf2_v4l2         36864  1 uvcvideo
btmtk                  16384  1 btusb
i2c_i801               36864  0
sparse_keymap          16384  1 asus_wmi
videobuf2_common       69632  4 videobuf2_vmalloc,videobuf2_v4l2,uvcvideo,videobuf2_memops
snd_timer              49152  3 snd_seq,snd_hrtimer,snd_pcm
cfg80211             1044480  2 rtw_core,mac80211
platform_profile       16384  1 asus_wmi
pcspkr                 16384  0
wmi_bmof               16384  0
bluetooth             798720  38 btrtl,btmtk,btintel,btbcm,bnep,btusb,rfcomm
snd                   114688  19 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_sof,snd_timer,snd_compress,snd_soc_core,snd_pcm
spi_pxa2xx_platform    36864  0
videodev              278528  3 videobuf2_v4l2,uvcvideo,videobuf2_common
soundcore              16384  1 snd
i2c_smbus              20480  1 i2c_i801
mei_me                 45056  2
dw_dmac                16384  0
mei                   151552  5 mei_hdcp,mei_pxp,mei_me
processor_thermal_device_pci_legacy    16384  0
processor_thermal_device    20480  1 processor_thermal_device_pci_legacy
joydev                 28672  0
mc                     69632  4 videodev,videobuf2_v4l2,uvcvideo,videobuf2_common
processor_thermal_rfim    16384  1 processor_thermal_device
ecdh_generic           16384  2 bluetooth
idma64                 20480  0
processor_thermal_mbox    16384  2 processor_thermal_rfim,processor_thermal_device
rfkill                 36864  6 asus_wmi,bluetooth,cfg80211
processor_thermal_rapl    20480  1 processor_thermal_device
intel_rapl_common      28672  2 intel_rapl_msr,processor_thermal_rapl
intel_pch_thermal      20480  0
intel_soc_dts_iosf     20480  1 processor_thermal_device_pci_legacy
int3403_thermal        20480  0
int340x_thermal_zone    20480  2 int3403_thermal,processor_thermal_device
acpi_tad               16384  0
acpi_pad              184320  0
int3400_thermal        20480  0
acpi_thermal_rel       16384  1 int3400_thermal
zram                   28672  2
i915                 3162112  14
crct10dif_pclmul       16384  1
nvme                   49152  3
crc32_pclmul           16384  0
hid_multitouch         32768  0
crc32c_intel           24576  3
ghash_clmulni_intel    16384  0
nvme_core             143360  4 nvme
serio_raw              20480  0
ttm                    81920  1 i915
wmi                    32768  2 asus_wmi,wmi_bmof
i2c_hid_acpi           16384  0
i2c_hid                32768  1 i2c_hid_acpi
video                  57344  2 asus_wmi,i915
pinctrl_cannonlake     36864  0
ip6_tables             36864  0
ip_tables              36864  0
ipmi_devintf           20480  0
ipmi_msghandler       122880  1 ipmi_devintf
fuse                  172032  5
            .',;::::;,'.                annamemnon@adamski 
         .';:cccccccccccc:;,.            ------------------ 
      .;cccccccccccccccccccccc;.         OS: Fedora Linux 36 (Workstation Editi 
    .:cccccccccccccccccccccccccc:.       Host: VivoBook_ASUSLaptop X430FA_S430F 
  .;ccccccccccccc;.:dddl:.;ccccccc;.     Kernel: 5.17.3-300.fc36.x86_64 
 .:ccccccccccccc;OWMKOOXMWd;ccccccc:.    Uptime: 16 mins 
.:ccccccccccccc;KMMc;cc;xMMc:ccccccc:.   Packages: 1883 (rpm) 
,cccccccccccccc;MMM.;cc;;WW::cccccccc,   Shell: bash 5.1.16 
:cccccccccccccc;MMM.;cccccccccccccccc:   Resolution: 1920x1080 
:ccccccc;oxOOOo;MMM0OOk.;cccccccccccc:   DE: GNOME 42.0 
cccccc:0MMKxdd:;MMMkddc.;cccccccccccc;   WM: Mutter 
ccccc:XM0';cccc;MMM.;cccccccccccccccc'   WM Theme: Adwaita 
ccccc;MMo;ccccc;MMW.;ccccccccccccccc;    Theme: Adwaita [GTK2/3] 
ccccc;0MNc.ccc.xMMd:ccccccccccccccc;     Icons: Adwaita [GTK2/3] 
cccccc;dNMWXXXWM0::cccccccccccccc:,      Terminal: gnome-terminal 
cccccccc;.:odl:.;cccccccccccccc:,.       CPU: Intel i3-8145U (4) @ 3.900GHz 
:cccccccccccccccccccccccccccc:'.         GPU: Intel WhiskeyLake-U GT2 [UHD Grap 
.:cccccccccccccccccccccc:;,..            Memory: 1825MiB / 7797MiB 


I would try this:

Thanks Tom.

I can confirm that I am attempting to install the modules for rtl8821CU on three distros. (Ubuntu, Manjaro & Fedora) and for each I required …

Clone the appropriate git repo.
Install dkms
Run the dkms script downloaded from git

Well, i can confirm now that drivers are indeed installed but just not loading properly.
I was able to download 25Gb worth in data last night via WIFI, it worked flawlessly :thinking: weird i know…

i did this:
turned everything off (buggy wifi that is not showing properly, BT)
Shut down laptop
Turn On laptop
My BT is ON on its own as usuall
My WIFI its off as it should
So then i turn off BT, airplane mode turns ON by itself
I shut it off
BT turns on automatically after shutting airplane thingy off but i inmediately switched off again
Now everything is off
I turn WIFI on and it worked!
Downloaded a bunch of stuff but…

After reboot, everything went caos again “No wifi network adapter found” therefore i dont have any WIFI menu, just stuck with bluetooth menus so i cannot replicate steps above anymore :wink:

[annamemnon@adamski ~]$ rfkill list
0: asus-wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: asus-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no


Looks like the link I provided was out of date, please try the latest drivers:

Thanks Tom.


I was able to replicate my steps after i remove rtw_8822be Module and load 8821ce module and then restart.
My WIFI showed buggy (no name on it, just the antenna icon) but at least i could turn it off and replicate steps shown on first post and then reboot.
i have a working WIFI. Not a solution but it feels good :slight_smile:

Im goint to try your second link @tjdoyle and let you know if i can manage a permanent solution.
Thank you!

(proof now i have a driver :point_down:t3:)

[annamemnon@adamski ~]$ inxi -Nxx
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: AzureWave
    driver: rtw_8822be v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: 3000
    bus-ID: 02:00.0 chip-ID: 10ec:b822

1 Like

One thing I have to do to get the WIFI working properly is to disable the USB CD ROM mode of these adapters.

my lsusb show this before disabling :slight_smile:

$ lsusb
Bus 001 Device 002: ID 0bda:1a2b Realtek Semiconductor Corp. RTL8188GU 802.11n WLAN Adapter (Driver CDROM Mode)

$ sudo usb_modeswitch -KW -v 0bda -p 1a2b

But after the mode switch the device characteristic change to :

$ lsusb
Bus 001 Device 005: ID 0bda:c820 Realtek Semiconductor Corp. 802.11ac NIC

After switching the mode the wifi is automatically detected and my network connects.

Unfortunately this is my output for lsusb… No (Driver CDROM mode) to test in my system.

[annamemnon@adamski ~]$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 13d3:3526 IMC Networks Bluetooth Radio
Bus 001 Device 003: ID 13d3:56c1 IMC Networks USB2.0 HD UVC WebCam
Bus 001 Device 002: ID 145f:020d Trust GXT 164 Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

But thank you for posting :metal:t3:

This is a different issue with your RTL8188GU adapter and the RTL8821BE adapter posted by @annamemnon .

Little update here.

This only happens when my laptop is connected to the power.
When i turn it on battery only, wifi appears (glitchy but appears) so i can then reproduce this steps.


Waiting for the official Fedora36 still :slight_smile:

OK, just a bit of my $0.02.
The indication of airplane mode on is based on the fact that all wireless communications are disabled (both wifi and bluetooth) so that would be expected.

Since bluetooth was the last disabled and that is what turned on airplane mode, then turning off airplane mode would automatically re-enable bluetooth.

Your real issue is the driver for the wireless adapter. It appears that you do not have the proper driver, and the driver you do have only supports bluetooth on that adapter chipset.

Lets quit worrying about how the issue is presented and instead handle the fix. Locate and install the proper driver.

A quick google search for driver for wifi adapter 10ec:b822 (which is your chipset) shows many links and it will be up to you to see which is the best for your needs. Adding ‘fedora’ or ‘linux’ to that search changes the number of results and may or may not narrow down what is needed.

My device is an 8821CU (IEEE 802.11ac/a/b/g/n WLAN and Bluetooth combo module with on-board 2.4Ghz and 5.8Ghz Dual band antenna)

Realtek RTL8821CU chipset ( USB ID = 0BDA:C820, Initial CDROM mode = 0BDA:1A2B )

Why it shows as a 8188GU under lsusb is anyones guess.

What I’m saying is a lot of realtech devices default to CDROM mode and sometimes that needs to be addressed.

I had the same issue with fedora 36 and RTL8822CE 802.11ac adapter. I removed all firmware using

sudo dnf remove *-firmware

and then reinstall and updated all firmwares

sudo dnf install *-firmware

worked for me. Make sure you keep your data safe before trying on yours