No Wi-Fi adapter found

Hi guys!

I’m really new to fedora and I really like the project but I can’t connect to the wifi!

I just installed it and when i go into the wifi settings I receive the “No Wifi adapter found” I can’t find anything online to help so I hope the community will be able too.

Here are a few screenshots to help troubleshoot :


I appreciate any kind of help

1 Like

Hello @kwams and welcome to ask :fedora:

Please post the output of lspci -nn and try to show all the output that may be network adapter related. The part that says Network controller may be for the ethernet adapter and there should be more that shows something like

04:00.0 Network controller [0280]: Qualcomm Atheros AR93xx Wireless Network Adapter [168c:0030] (rev 01)
06:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)

There also is a possibility, no matter how slight, that secure boot may prevent loading the modules.

Try lsmod | grep rtw to see if any modules are loading for that realtek adapter and report the results.


Hey @computersavvy , Nothing shows up with lsmod | grep rtw

Also, there is no other network related input but here is the full screenshot

Thank You so much for help!

I disabled fast boot and secure boot and no results yet

Please try some way to get what you see on the screen to a text file that can then be uploaded as text into your posts. There are several commands that will have several screens of output and screenshots are not ideal for us to read, analyze, and comment upon the posts.

The first of this sort is dmesg, of which the entire output would be useful. It could be saved to a file with dmesg > dmesg.txt then the file just created could be put onto a usb, transferred to another PC (the one you are using to post) and the content then pasted into the post using the </> preformatted text button on the toolbar just above your text entry to retain the original display format.

The output of lsmod | grep rtw is also useful.

1 Like

Got it for the scrrenshots.

I can’t put the whole output of dmseg because of the length being over the limit.

Here is a link to the text file : dmesg.txt - Google Drive

Thank you so much for your help

Also, lsmod | grep rtw does not output anything.

What should I look for in the dmseg output ? Do you want me to share only errors?

Does wifi work when you boot a Fedora or other distro Live USB? It is often helpful to have other distro installers when troubleshooting hardware issues. I suggest live images with pre-installed hw-probe: Debian, ArcoLinux or OpenMandriva. These provide
the hw-probe tool, which (assuming networking works) will upload a sanitized snapshot of your hardware configuration. This helps build a database of hardware and drivers that work in linux.

sudo -E hw-probe -all -upload
Probe for hardware ... Ok
Reading logs ... Ok
Uploaded to DB, Thank you!

Probe URL:

The “Network controller” line shows a Realtek “10ec:b852”, but there are multiple wifi chips with this ID. The output of sudo hwinfo show give something like:

11: PCI 300.0: 0282 WLAN controller
  [Created at pci.386]
  Unique ID: hAO_.pzD43Xd2gkD
  Parent ID: hoOk.1poxqOoK3I0
  SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:03:00.0
  SysFS BusID: 0000:03:00.0
  Hardware Class: network
  Model: "Broadcom BCM4360 802.11ac Wireless Network Adapter"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x43a0 "BCM4360 802.11ac Wireless Network Adapter"
  SubVendor: pci 0x106b "Apple Inc."
  SubDevice: pci 0x0111 
  Revision: 0x03
  Driver: "wl"
  Driver Modules: "wl"
  Device File: wlp3s0
  Features: WLAN

The SubVendor and SubDevice can be used to search for your device at Hardware for Linux.

1 Like

maybe this will help

sudo dnf install git bc
git clone GitHub - HRex39/rtl8852be: Realtek Linux WLAN Driver for RTL8852BE
cd rtl8852be
sudo make install
sudo modprobe 8852be

from askubuntu

Hey @gnwiii thanks for your help, here is the output for hw-probe :

sudo -E hw-probe -all -upload
Probe for hardware ... Ok
Reading logs ... Ok
WARNING: Unknown vendor '31B5'
Uploaded to DB, Thank you!

Probe URL:

now here is the output for hwinfo

PCI 100.0: 0280 Network controller
  [Created at pci.386]
  Unique ID: VCu0.Zm7RQA7Sa7D
  Parent ID: jDmU.JhR1dXh1J9E
  SysFS ID: /devices/pci0000:00/0000:00:02.2/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: network
  Model: "Realtek Network controller"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0xb852 
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x88e3 
  I/O Ports: 0xf000-0xffff (rw,disabled)
  Memory Range: 0xfcf00000-0xfcffffff (rw,non-prefetchable,disabled)
  IRQ: 255 (no events)
  Module Alias: "pci:v000010ECd0000B852sv0000103Csd000088E3bc02sc80i00"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #40 (PCI bridge)

1 Like

@rebok232 I tried …

kwams@fedora ~]$ git clone -b dev
Cloning into 'rtl8852be'...
remote: Enumerating objects: 1067, done.
remote: Counting objects: 100% (154/154), done.
remote: Compressing objects: 100% (92/92), done.
remote: Total 1067 (delta 72), reused 133 (delta 53), pack-reused 913
Receiving objects: 100% (1067/1067), 4.56 MiB | 2.03 MiB/s, done.
Resolving deltas: 100% (249/249), done.
[kwams@fedora ~]$ cd rtl8852be
[kwams@fedora rtl8852be]$ make -j8
#rm -f .symvers.8852be
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.17.5-300.fc36.x86_64/build M=/home/kwams/rtl8852be  modules
make[1]: *** /lib/modules/5.17.5-300.fc36.x86_64/build: No such file or directory.  Stop.
make: *** [Makefile:637: modules] Error 2

ok official instructions from repo:

Prerequisites (for Fedora)

kernel-devel-`uname -r`

Build(for kernel >= 5.18)

#Turn off your Security Boot in BIOS

git clone -b dev
cd rtl8852be
make -j8
sudo make install
sudo modprobe 8852be

maybe that would help

tried again, couldn’t get it to work. Even after installing everything, same error

Says: " We have not found a driver for the device in any Linux kernel versions up to 6.0 (according to the LKDDb) or known additional packages."

Many laptops have wifi on a removable card, so you may be able to substitute another wifi card. There are many high-quality wifi cards pulled from systems only a few years old when businesses upgraded to newer wifi standards. There is often a years or so lag before a new wifi card gets a
linux driver, so for many linux users an older card works well.

I concur with George.
Someone a short time back purchased an intel wifi card for their laptop to replace a realtek and was very happy with the intel.

In fact here is an intel AX210 on amazon that is <$30 and is supported by linux