No sound on fedora server 37

aplay -l outputs:

aplay: device_list:274: no soundcards found...

lspci does recognize the soundcard:

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)

There is also an HDMI device present:

01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Barts HDMI Audio [Radeon HD 6790/6850/6870 / 7720 OEM]

I tried modprobe snd-hda-intel which did nothing. Is this even the correct module?

When I run aplay /usr/share/sounds/alsa/Front_Left.wav as a normal user, it takes a moment before returning. However, when I run it with sudo, I get an error:

aplay: main:831: audio open error: Host is down

cat /proc/asound/cards shows:

0 [PCH            ]: HDA-Intel - HDA Intel PCH
                     HDA Intel PCH at 0xf7f00000 irq 36
1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                     HDA ATI HDMI at 0xf7e40000 irq 37

And finally aplay -L:

    Discard all samples (playback) or generate zero samples (capture)
    PipeWire Sound Server
    Default ALSA Output (currently PipeWire Media Server)

What do I have to do to get sound from the internal speakers?