How do I check proper audio setup in new wireplumber/pipewire resease

Having difficult time in understanding wireplumber/pipewire/pulseaudio interplay and setup parameters . I have used Linux since 1999 RedHat 6.0 . However, I am having a difficult time wrapping my arms around the audio changes with Wireplumber/pipewire /pulsaudio .

System is Dell 7530 running Fedora 35, Xeon processor, 32 GB RAM, last update was yesterday

Basically, I understand that there is a program which actually decodes the music, it interfaces with some sort of manager .

Here is a dialog
systemctl --user status wireplumber
● wireplumber.service - Multimedia Service Session Manager
Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2022-01-07 11:24:31 CST; 2h 49min ago
Main PID: 2024 (wireplumber)
Tasks: 4 (limit: 38259)
Memory: 7.5M
CPU: 109ms
CGroup: /user.slice/user-1002.slice/user@1002.service/session.slice/wireplumber.service
└─2024 /usr/bin/wireplumber

Jan 07 11:24:31 rhino systemd[1277]: Started Multimedia Service Session Manager.
Jan 07 11:24:56 rhino wireplumber[2024]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply

I do not understand the getmanaged objects-

Pulseaudio outputs

pavucontrol status
[david4@rhino ~]$ aplay -l
aplay: device_list:274: no soundcards found…
[david4@rhino ~]$ aplay -L
Discard all samples (playback) or generate zero samples (capture)
PipeWire Sound Server
PulseAudio Sound Server
Default ALSA Output (currently PulseAudio Sound Server)

The system only shows “dummy” output device . I feel there is a disconnect between some modules , but do not understand the framework which is necessary . Any insight you could offer would be greatly appreciated .

Maybe you could check here the common problem with those services.

My understanding, the pulseaudio.service in Fedora 35 are replaced by wireplumber.service. We need to choose which one we want to use.

alsa → pipewire → pulseaudio or alsa → pipewire → wireplumber

But because when you’re running aplay -l and aplay -L, there no report on your terminal, I believe it’s more likely there also a problem with your driver since both command are directly call to alsa driver to make a list the available soundcards you have.

Thank you for your suggestions . The session slice produced the following output

systemctl --user status session.slice
● session.slice - User Core Session Slice
Loaded: loaded (/usr/lib/systemd/user/session.slice; stat>
Drop-In: /run/systemd/user/session.slice.d
Active: active since Tue 2022-01-11 11:08:28 CST; 10min a>
Docs: man:systemd.special(7)
Tasks: 125
Memory: 593.3M (min: 250.0M)
CPU: 10min 54.912s
CGroup: /user.slice/user-1002.slice/user@1002.service/ses>
│ ├─2012 /usr/libexec/at-spi-bus-launcher
│ ├─2019 /usr/bin/dbus-broker-launch --config-fil>
│ └─2020 dbus-broker --log 4 --controller 9 --mac>
│ ├─1341 /usr/bin/dbus-broker-launch --scope user
│ └─1342 dbus-broker --log 4 --controller 10 --ma>
│ ├─1356 /usr/libexec/gvfsd
│ ├─1361 /usr/libexec/gvfsd-fuse /run/user/1002/g>
│ └─2666 /usr/libexec/gvfsd-http --spawner :1.5 />
│ └─2035 /usr/bin/pipewire-pulse
│ └─2033 /usr/bin/pipewire
│ ├─1552 /usr/bin/kded5
│ ├─1703 /usr/bin/xsettingsd
│ ├─2661 /usr/libexec/kf5/kioslave5 /usr/lib64/qt>
│ └─2663 /usr/libexec/kf5/kioslave5 /usr/lib64/qt>
│ └─1550 /usr/bin/ksmserver
│ └─1555 /usr/bin/kwin_x11 --replace
│ └─1677 /usr/bin/plasmashell --no-respawn

It does not say pulseaudio running (as it should not be,if I understand the system ) but the pipewire pulse ,pipewire and wireplumber are present which I thought were necessary for the sound to work . Perhaps they are not in the right directories ??

Is there a list as to where certain files should be for the sound to work properly with a given configuration ( e.g. wireplumber )? Suggestions ?

Thank you

As I do understand the default is in /usr/share/ and gets copied to /etc/... If you want a User specific config you have to copy it to ~/.config

whereis appname shows you the binary, config-files, and the location of the man pages.

Thank you for suggestions, in regard to your statement that files from /usr/share/ “gets copied” to /etc/ . Then it is my responsibility to copy the files , the system does not do this automatically on upgrade ? If so, where are they to go ? /etc/wire*** . what is the tree structure relative to /etc/ ? Sorry I am so dense on this .
Thank you

Please don’t change anything first with your pipewire and wireplumber (or any custom configuration), since alsa failed to detect your hardware.

Would you like to run bellow command and post the result here:

dmesg | grep -iE "sound|snd|hda|codec|sof"

Please read the top of the config files in /usr/share/pipewire, there everything is explained.
If you not have any personal settings pipewire takes the config files from /usr/share/pipewire. If there is an update this directory gets updated.

As @oprizal mentioned, for the moment you don’t have to change the config files.

The first lines for each of the config files indicate that one is to copy the config file to the /etc/ dir for system wide usage . Does this mean all config files under /share/pipewire ?

Thank you

Here is result of dmesg output you requested

$ dmesg | grep -iE “sound|snd|hda|codec|sof”
[ 0.591175] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giomett>
[ 0.628109] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[ 0.628109] software IO TLB: mapped [mem 0x0000000050bcf000-0x0000000054bcf000] (64MB)
[ 1.076544] integrity: Loaded X.509 cert ‘Microsoft Corporation UEFI CA 2011: 13adbf4309b
[ 1.076563] integrity: Loaded X.509 cert ‘Microsoft Windows Production PCA 2011: a9290239

Hi, if recently you add some configurations inside directory /etc/modprobe.d/ related to soundcard (for example using blacklist snd_hda_intel or any) also any custom boot/kernel parameter (either inside /etc/default/grub or using sudo grubby) related to sound card, please remove it.

After that, please reboot and run dmesg | grep -iE "sound|snd|hda|codec|sof" again and also lspci -v | grep -A 6 -i audio

Assuming your sound card physically fine, the only thing I can reproduce your dmesg result is by adding module blacklist.


If you get different result with dmesg, please also post the result of aplay -lL

I have made no changes to config. Here are the outputs to commnands you suggested–

$ lspci -v | grep -A 6 -i audio
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
DeviceName: Onboard - Sound
Subsystem: Dell Device 0831
Flags: fast devsel, IRQ 255
Memory at a2130000 (64-bit, non-prefetchable) [disabled] [size=16K]
Memory at 404a000000 (64-bit, non-prefetchable) [disabled] [size=1M]

01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)
Subsystem: Dell Device 1831
Flags: fast devsel, IRQ 255
Memory at a4080000 (32-bit, non-prefetchable) [disabled] [size=16K]

6d:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5260 PCI Express Card Reader (rev 01)

dmesg same as before , no changes to conf .

I know the sound cards work, its a dual boot , worked before with Fedora , but since upgrades does not. Windz side still works so hardware should be fine

According to the comments at top of the usr/share/pipewire/config files , as suggested by ilikelinux, it would appear that some/all config files should be in the /etc/pipewire directory,(systemwide changes) but which files, all or specific based upon my system config ?

I think I know the problem. May be you need to install proprietary Nvidia driver or if you already have one (from previous installation on previous Fedora version), maybe you need to try to uninstall and reinstall it again.

I’m currently with my laptop that have Nvidia driver and when I run aplay -lL it give me following result:

[testcase@fedora ~]$ aplay -lL
    Discard all samples (playback) or generate zero samples (capture)
    PipeWire Sound Server
    Default ALSA Output (currently PipeWire Media Server)
    HDA NVidia, ALC269 Analog
    Default Audio Device
    HDA NVidia, ALC269 Analog
    Front output / input
    HDA NVidia, ALC269 Analog
    2.1 Surround output to Front and Subwoofer speakers
    HDA NVidia, ALC269 Analog
    4.0 Surround output to Front and Rear speakers
    HDA NVidia, ALC269 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    HDA NVidia, ALC269 Analog
    5.0 Surround output to Front, Center and Rear speakers
    HDA NVidia, ALC269 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    HDA NVidia, ALC269 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    HDA NVidia, HDMI 0
    HDMI Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output
    HDA NVidia, HDMI 0
    HDMI Audio Output
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia_1 [HDA NVidia], device 0: ALC269 Analog [ALC269 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Per request here is output

aplay -lL
Discard all samples (playback) or generate zero samples (capture)
PipeWire Sound Server
PulseAudio Sound Server
Default ALSA Output (currently PulseAudio Sound Server)
aplay: device_list:274: no soundcards found…

The default ALSA output shows Pulseaudio , could this be the disconnect ?

It also possible base on this common problem here that I shared before.

Just did update on my system. Received several updates for Pipewire, pulse, and the like . I will retry your previous suggestions and see if the updated wireplumber/wirepipe code solves anything . Thank you for your inputs. I will advise if I have any luck .