No sound in Fedora, installed on the Virtualbox

Hello. I am getting acquainted with the Fedora operating system installed on Virtualbox. I noticed that there is no sound when you select the Intel HD Audio audio codec in the Virtualbox settings. In Ubuntu, which is also installed on Virtualbox, there is no such problem. When choosing the AC97 codec, there are problems such as sound jitter, intermittent sound when playing a video. Therefore, I decided to use Intel HD Audio, but as a result there is no sound.

Welcome to the Fedoraproject @alex1973021

Did you install the codecs on the new fedora install?

I have installed the plugins according to the instructions you provide. I have made a reboot. There were no installation errors. Unfortunately, there’s no sound.
I suspect that the problem here is related to the problem of the Intel HD Audio controller (Virtualbox>Settings>Audio-Audio Controller>Intel HD Audio). I think that the specified audio controller does not work in Fedora (missing driver or other reason)

Having the same problem with Virtualbox. I installed a VM of Fedora 38, and it initially had sound. After running sudo dnf upgrade and rebooting, it no longer has sound. I have installed the codecs/plugins for playing movies and music. When I power down the Fedora VM and swap the audio controller Virtualbox uses, then boot back in, it does modify the ‘Output Device’ of Fedora’s sound settings. But, still no sound with any of the three audio controllers.