No option for KDE after upgrading to F40

I just upgraded to F40. Everything seemed to work okay. BUT I no longer have an option for the KDE desktop despite many KDE/Plasma files being installed.

I installed LightDM as mentioned in another post. Starting it gives the error:

Failed to enable unit: File /etc/systemd/system/display-manager.service already exists and is a symlink to /usr/lib/systemd/system/gdm.service.

The file “gdm.service” contains no reference to KDE, Plasma or Wayland.

There are no files under /etc/sddm.conf.d/

There is a plasma.desktop file under /etc/sddm.conf.d/ but not a plasma wayland.

I tried running
systemctl disable kde
systemctl enable sddm
but kde is not running, sddm is, so both give an error.

I tried opening a terminal window and running “startplasma-wayland”. It works, mostly. When it starts up I get the following:

startplasma-wayland
kf.dbusaddons: Skipping syncing of environment variable  "BASH_FUNC__module_raw%%" as name contains unsupported characters
kf.dbusaddons: Skipping syncing of environment variable  "BASH_FUNC_ml%%" as name contains unsupported characters
kf.dbusaddons: Skipping syncing of environment variable  "BASH_FUNC_module%%" as name contains unsupported characters
kf.dbusaddons: Skipping syncing of environment variable  "BASH_FUNC_scl%%" as name contains unsupported characters
kdeinit5_wrapper: Warning: connect(/run/user/1000/kdeinit5__1) failed: : No such file or directory
Error: Can not contact kdeinit5!
org.kde.startup: "kdeinit5_shutdown" QList() exited with code 255
startplasma-wayland: Shutting down...
startplasmacompositor: Shutting down...
startplasmacompositor: Done.

Suggestions?

sudo dnf group install kde-desktop

That should fill any holes where some how you might have not installed a few KDE packages

thanks but still no option for plasma login
I got the following messages:

Fedora 40 openh264 (From Cisco) - x86_64        418  B/s | 271  B     00:00    
Errors during downloading metadata for repository 'fedora-cisco-openh264':
  - Status code: 404 for https://codecs.fedoraproject.org/openh264/40/x86_64/repodata/repomd.xml (IP: 8.43.85.73)
Error: Failed to download metadata for repo 'fedora-cisco-openh264': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
Ignoring repositories: fedora-cisco-openh264
Last metadata expiration check: 2:23:43 ago on Wed 01 May 2024 11:09:37 AM PDT.
Dependencies resolved.

so I’m thinking not everything installed?

Follow the instructions here: KDE - Fedora Project Wiki

The website also contains instructions on installing SDDM, which is the
KDE Display Manager. I could be wrong, but I don’t believe that LightDM supports
Wayland. If you don’t like SDDM for some reason, GDM is compatible with Wayland.

I installed LightDM because SDDM didn’t seem to be working (suggested in another forum post). SDDM seems to have a firm hold on my system and LightDM won’t load.

I haven’t used LightDM for many many years so don’t know much about it. Perhaps someone else can comment on that. I would recommend that you follow the instructions in the KDE - Fedora Project Wiki, and for the time being remove LightDM, at least until you get your system stabilized. If for some reason SDDM still isn’t working for you, try GDM for the time being.

I removed LightDM.
SDDM and GDM are installed (they were part of the upgrade)
Still no option to go to KDE/Plasma at login

Very odd. What is the output from the command:
dnf install @kde-desktop-environment

The stated error claiming that display-service.service is a symlink to gdm.serviceseems to indicate that GDM (GNOME Display Manager) is the current display manager. GDM can have issues with Wayland, especially on NVIDIA GPUs.

To disable GDM from acting as your current display manager, you can open a console as a regular user (in another desktop environment or pressing Ctrl + Alt + F5 on the login screen) and run sudo systemctl disable --now gdm. This will likely instantly end your graphical session and log you out if you did it in a GUI environment (i.e. not in a TTY console).

To now enable SDDM, you can run sudo systemctl enable --now sddm. After this, you should see the SDDM login screen (press Ctrl + Alt + F1 if you were using a TTY). If that doesn’t work, reboot and see if you can access SDDM now.

The --now flag allows systemd to start and stop services immediately. enable and disable make systemctl permanently enable or disable services starting from the next boot by default, passing --now allows changes to take place immediately. (If you just want to temporarily start or stop a service, sudo systemctl start and sudo systemctl stop are useful for that.)

2 Likes

What exactly is your OS set-up?

I assumed you upgraded from F39 KDE to F40 KDE and have Plasma 6, but there’s mentions of GDM and LightDM (KDE afaik is SDDM), and kdeinit5 sounds like Plasma 5. I only used F40 KDE for a few days, but I definitely don’t recall LightDM or GDM and can’t think of why they would be there.


Judging from all that chaos, I’d recommend just clean-installing F40 KDE, unless you’re really into troubleshooting, or are trying to run multiple DEs on one Fedora install.

Apparently it wasn’t installed. It has now been installed. I rebooted - still no option for KDE at login

What is the output from the command:
dnf install @kde-desktop-environment

sigh… the coffee hasn’t kicked in. I disabled gym and now don’t seem to have any display manager loaded and will have to find another way to log in.

Yeah! It worked!

Many thanks

Mr. Cox. I’m using Fedora as a VM on an ESXI V 8.0 host with Intel Gold processors. UEFI, BIOS doesn’t seem to make a difference. VMware is up to date. I brought it to the very latest a few days ago and rebooted.

I have tried to get plasma/kde to run a few ways. The Fedora kde/plasma spin off the fedora project site. I’ve taken the server spin that works and tried loading plasma like I did in 39 for a local network kickstart instance. I simply typed the commands in by hand. No errors. No warnings. The last way was a test machine that was running 39/kde and tried to upgrade. The server and upgrade give me the same results when I was at your command you wanted output to:

root@other:~# dnf install @kde-desktop-environment
Last metadata expiration check: 3:01:30 ago on Sat 04 May 2024 09:17:14 AM EDT.
Dependencies resolved.
===============================================================================================================================================================================================
 Package                                       Architecture                                 Version                                        Repository                                     Size
===============================================================================================================================================================================================
Installing Environment Groups:
 KDE Plasma Workspaces                                                                                                                                                                        
Installing Groups:
 Administration Tools                                                                                                                                                                         
 base-graphical                                                                                                                                                                               
 Core                                                                                                                                                                                         
 Desktop accessibility                                                                                                                                                                        
 Dial-up Networking Support                                                                                                                                                                   
 Fonts                                                                                                                                                                                        
 Guest Desktop Agents                                                                                                                                                                         
 Hardware Support                                                                                                                                                                             
 Input Methods                                                                                                                                                                                
 KDE                                                                                                                                                                                          
 Multimedia                                                                                                                                                                                   
 Common NetworkManager Submodules                                                                                                                                                             
 Printing Support                                                                                                                                                                             
 Standard                                                                                                                                                                                     

Transaction Summary
===============================================================================================================================================================================================

Is this ok [y/N]: y
Complete!
root@other:~# 

Complete? That was a surprise. I hoped it would download and install stuff.

I can tell you that when it boots and I hit escape everything seems to run along just fine until it switches to where the desktop should pop up. Then I get a cursor at the top left corner. I can still login to the machine. Commands still work. I don’t remember how to tell it how to stop and start KDE to the default display from the CLI. Thankfully, I haven’t had to worry about display stuff in a long time.

I’m sure it’s something simple. Maybe a spec file from a wrong git branch tree or something.

Thanks,
Rob

I updated the old Fedora 39 tonight. 77 packages updated. It works at the vmware console. xrdp still won’t work.
Upgraded:
R-core-4.4.0-1.fc40.x86_64 autocorr-en-1:24.2.3.2-2.fc40.noarch btrfs-progs-6.8.1-1.fc40.x86_64
cantor-24.02.2-2.fc40.x86_64 cantor-R-24.02.2-2.fc40.x86_64 cantor-julia-24.02.2-2.fc40.x86_64
cantor-libs-24.02.2-2.fc40.x86_64 default-editor-7.2-7.fc40.noarch firefox-125.0.3-1.fc40.x86_64
firefox-langpacks-125.0.3-1.fc40.x86_64 fwupd-1.9.19-1.fc40.x86_64 fwupd-plugin-flashrom-1.9.19-1.fc40.x86_64
fwupd-plugin-modem-manager-1.9.19-1.fc40.x86_64 fwupd-plugin-uefi-capsule-data-1.9.19-1.fc40.x86_64 gdcm-3.0.23-5.fc40.x86_64
gimp-2:2.10.38-1.fc40.x86_64 gimp-libs-2:2.10.38-1.fc40.x86_64 git-2.45.0-1.fc40.x86_64
git-core-2.45.0-1.fc40.x86_64 git-core-doc-2.45.0-1.fc40.noarch gstreamer1-1.22.12-1.fc40.x86_64
gstreamer1-plugin-libav-1.22.12-1.fc40.x86_64 gstreamer1-plugin-openh264-1.22.12-1.fc40.x86_64 gstreamer1-plugins-bad-free-1.22.12-1.fc40.x86_64
gstreamer1-plugins-bad-free-libs-1.22.12-1.fc40.x86_64 gstreamer1-plugins-base-1.22.12-1.fc40.x86_64 gstreamer1-plugins-good-1.22.12-1.fc40.x86_64
gstreamer1-plugins-good-gtk-1.22.12-1.fc40.x86_64 gstreamer1-plugins-good-qt-1.22.12-1.fc40.x86_64 gstreamer1-plugins-good-qt6-1.22.12-1.fc40.x86_64
gstreamer1-plugins-ugly-free-1.22.12-1.fc40.x86_64 gtk4-4.14.4-1.fc40.x86_64 java-21-openjdk-headless-1:21.0.3.0.9-1.fc40.x86_64
javascriptcoregtk4.0-2.44.1-1.fc40.x86_64 kernel-tools-6.8.8-300.fc40.x86_64 kernel-tools-libs-6.8.8-300.fc40.x86_64
kwin-6.0.4.1-2.fc40.x86_64 kwin-common-6.0.4.1-2.fc40.x86_64 kwin-libs-6.0.4.1-2.fc40.x86_64
kwin-wayland-6.0.4.1-2.fc40.x86_64 libRmath-4.4.0-1.fc40.x86_64 libphonenumber-8.13.35-1.fc40.x86_64
libreoffice-calc-1:24.2.3.2-2.fc40.x86_64 libreoffice-core-1:24.2.3.2-2.fc40.x86_64 libreoffice-data-1:24.2.3.2-2.fc40.x86_64
libreoffice-emailmerge-1:24.2.3.2-2.fc40.x86_64 libreoffice-graphicfilter-1:24.2.3.2-2.fc40.x86_64 libreoffice-gtk3-1:24.2.3.2-2.fc40.x86_64
libreoffice-gtk4-1:24.2.3.2-2.fc40.x86_64 libreoffice-help-en-1:24.2.3.2-2.fc40.x86_64 libreoffice-impress-1:24.2.3.2-2.fc40.x86_64
libreoffice-kf5-1:24.2.3.2-2.fc40.x86_64 libreoffice-kf6-1:24.2.3.2-2.fc40.x86_64 libreoffice-langpack-en-1:24.2.3.2-2.fc40.x86_64
libreoffice-ogltrans-1:24.2.3.2-2.fc40.x86_64 libreoffice-opensymbol-fonts-1:24.2.3.2-2.fc40.noarch libreoffice-pdfimport-1:24.2.3.2-2.fc40.x86_64
libreoffice-pyuno-1:24.2.3.2-2.fc40.x86_64 libreoffice-ure-1:24.2.3.2-2.fc40.x86_64 libreoffice-ure-common-1:24.2.3.2-2.fc40.x86_64
libreoffice-writer-1:24.2.3.2-2.fc40.x86_64 libreoffice-x11-1:24.2.3.2-2.fc40.x86_64 nano-7.2-7.fc40.x86_64
nano-default-editor-7.2-7.fc40.noarch perl-Git-2.45.0-1.fc40.noarch python-unversioned-command-3.12.3-2.fc40.noarch
python3-3.12.3-2.fc40.x86_64 python3-libs-3.12.3-2.fc40.x86_64 python3-perf-6.8.8-300.fc40.x86_64
python3-tkinter-3.12.3-2.fc40.x86_64 spglib-2.4.0-1.fc40.x86_64 webkit2gtk4.0-2.44.1-1.fc40.x86_64
Installed:
kernel-6.8.8-300.fc40.x86_64 kernel-core-6.8.8-300.fc40.x86_64 kernel-modules-6.8.8-300.fc40.x86_64 kernel-modules-core-6.8.8-300.fc40.x86_64 kernel-modules-extra-6.8.8-300.fc40.x86_64
Removed:
kernel-6.8.5-201.fc39.x86_64 kernel-core-6.8.5-201.fc39.x86_64 kernel-modules-6.8.5-201.fc39.x86_64 kernel-modules-core-6.8.5-201.fc39.x86_64 kernel-modules-extra-6.8.5-201.fc39.x86_64

When I upgraded the system installed the Gnome display manager and didn’t give any other desktop options. I had to uninstall gdm and install sddm to get an option for plasma/kde. Check to see what display manager is installed.

The cisco-openh264 has nothing to do with KDE not starting or sddm problems.

So do you not even get the SDDM login manager? If you do you should check the menu in the corner for the plasma related selection to get it selected.

The secret sauce seems to be adding the package plasma-workspace-x11. It’s not included in the upgrade packages. xrdp will also work once this is done.
I successfully loaded a server base, added the same kde list as with 39, added plasma-workspace-x11 and everything seems great once the machine is post upgraded to the latest versions.

at below is an at sign. It thinks I’m referencing other users if I use the at sign.

%packages
at^kde-desktop-environment
atfirefox
atkde-apps
atkde-media
emacs
plasma-workspace-x11
openssh-server
%end

bottom of file

%post
systemctl enable sshd
%end

This worked! Wacom tablet and Kcalc now work! Thanks