No input method switcher at the right of topbar

I made a fresh installation of F34 on a Huawei laptop. I have two problems.

  1. There is no input method switcher at the right of the topbar.

  2. The heights of the terminal differ much between in English and in Chinese environments, as can be seen in the snapshots of the full screens.

The different terminal heights are probably because the fonts are different sizes. Does adjusting the font size in the terminal profile fix it?

The fonts have the same sizes.

Did you try this with the other extensions disabled or on a new user with a clean profile?

I just tried this on my install and it was there after I added an additional input source to keyboard settings.

Yes, I did both as you suggested. There is still no switcher.

I used Fedora for more than 20 years. This is the first time I have this problem.

I changed the title of your Request. Fedora 34 Problem is to generic.

When I see the pictures of the two terminals, switching for and backwards, the cursor gains in size. So I would say the chines characters are occupying more space as the other ones, So I think the spacing is a bit bigger.

1 Like

Maybe you are right. But I have never seen terminal with such a large height in Chinese environment in previous versions of Fedora.

Are there multiple input sources listed under keyboard?
Does super + space work for inport source switching?

You might want to go ahead and file a bug