Can not get my keyboard to US English. it's stuck on Portuguese keyboard input!

When I installed Fedora 33, it was from a USB stick - a totally new install. I choose to install it in Portuguese, because I am studying that language.

I just installed Fedora 34, and I have a new problem. My keyboard is still in Portuguese mode, and certain characters are not available, such as the pipe key or the question mark or the backslash key (for starters).

What command or commands can I use so that my keyboard will revert to US English:

I tried /usr/bin/pkexec /usr/share/system-config-language/,
but that didn’t affect the keyboard. I still get dialog boxes in Portuguese, too.


Which Desktop you use? Gnome?

1 Like

I should mention that this was in in place, dnf-oriented installation of Fedora 34. I was having the same problem with 33

please execute in terminal the following command:

and past us the 2 lines:

Operating System: Fedora 34 (MATE-Compiz)
Kernel: Linux 5.11.18-300.fc34.x86_64

baz î‚° ~ î‚° hostnamectl
Static hostname:
Icon name: computer-desktop
Chassis: desktop
Machine ID: 053e2b77b9044f609c1eda1460a70c83
Boot ID: 088c7bb6ea61456e83605c74a0cd34fc
Operating System: Fedora 34 (Xfce)
CPE OS Name: cpe:/o:fedoraproject:fedora:34
Kernel: Linux 5.11.18-300.fc34.x86_64
Architecture: x86-64
Hardware Vendor: Dell Inc.
Hardware Model: OptiPlex 7010

Thatś the output to the command ḧostnamectl

In XFCE to revert to English you have to go to Applications >> Settings >> Language >> There you click on the language you want to change back. On the bottom you click on SystemDefault to make the selected language System Default. Of course you also have to select the English language and click OK. After log out and in again it should be English.

Applications >> Settings >> Keyboard >> Layout
Look that the choosen language is the same as your keyboard. If you like to work with just English you can remove Portuguese.

If you want to use both check that your preferred language layout is on the top. You can change the position with the arrow keys on the right site.

The instructions above are for Xfce in the graphical environment.


First of all, thank you for the advice.

I followed your advice. The applications still talk to me in US English. System messages are still in Portuguese. So far, so good. I can understand the messages. The xfce ¨Applications" button still says Applications in Portuguese, which I can no longer write in Portuguese.

The real problem is with the keyboard. I must have known how to invoke the program that changes keyboard input. Ctrl+Alt+Space ostensibly changes the keyboard input method. This seems to be a global setting. When I reset the keyboard, I still have problems with single quote (´) and double quotes (¨). I can remember

For example, ¨single quote¨ gives me ´ ( have to press the key twice to get anything at all. Double quote gives me ¨. You may have noticed. I also have to press the key twice. A single key press gives me nothing.

I got success with backslash , forward slash / and pipe |. Before, these were
unattainable. But no luck with single and double quotes. If you can pardon the stupid question, what is the program that allows me to change keyboard settings to different language?

Thank you for your help so far, ilike linux.

I finally got it.

This may be the "blunt instrument approach, but I found a file called

I didn’t want to try to decipher the xml, so I just deleted it, figuring the the system would supply a new, default version of the file.

I figured right. I can get formerly unattainable characters like ', ", , |, `, [, ] and others. Now, I have to find the program that adds languages (e,g, Portuguese, Japanese (Kana/Kanji) , and Russian). And take better notes this time.

I appreciate the time you took to help me, ilikelinux. Thank you very much.


1 Like