No Audio

My audio was working last night, but today I have it a 100% and it looks like it is putting out a little bit of sound, but I am hearing nothing.

1 Like

Try this update:

Same thing is happening. I did a reboot as well just in case.

1 Like

This might be of help too: Configuration - RPM Fusion

Last night I did this configuration. I installed all but the “Tainted Repos” at the end and I did not do the command line setup portion. I am thinking this might have something to do with it.

1 Like

You may want to check the DNF transaction history and undo the recent commands:

1 Like

Alrighty. That is on my list of things to do tonight. Thank you!

1 Like

Thanks a ton for this. I got some time to do it just now. I got my volume working again by removing whatever I did last night. The only issue is that my actually volume comes out at 100%. When I move the volume up and down it does not increase or decrease. This really isn’t a problem because I can use the volume adjustments on the videos, but it is something I will be looking into.

1 Like

This seems like an incredible coincidence. This is exactly why I am here, too. I’ve been using Fedora 33 for months. Tonight, I got up in the middle of the night to put on a movie, or maybe do some absent-minded scrolling, and I wound up instead messing around for an hour so far, trying to get my computer to do make any sound at all. If I use bluetooth, the system sounds work fine, but there’s no sound from any of the programs. I can hear the little “pop” sound if I raise or lower the volume, but… no sound in firefox or whatever the media app is called. I haven’t done anything recently and my wife was on discord all night. We haven’t changed anything.

Btw, whoever sent us to the post with alt+ctl+F3… that was… not helpful.

1 Like

That is exactly what mine was doing. I could hear the pop when I would turn the volume up or down and my bluetooth headphones worked like they were supposed to. The volume meter also looked like sound was coming out, but nothing was happening. After I uninstalled some packages that I had downloaded the night before, everything went back to normal.

However, now my volume appears to be set at 100% regardless of where I put the level. The only thing I can do is to increase the volume more than 100%. Then I get more volume, but I can’t seem to get less than 100% volume on my system. I can, however, increase and decrease the volume perfectly when I use the volume within YouTube, Disney+, or really any video that has a volume control on it. My Bluetooth devices also still work perfectly. I haven’t had any time to investigate this any further due to a final project for this damn degree of mine.

When I get time, I will do some research and let you know if I find anything that works! I’m hoping things slow down for me a bit after this week and I can have some fun for once lol. Take care.

What eventually solved my issue was typing alsactl init into command prompt, then pulseaudio -k to restart pulseaudio. I went to setting, changed to my prefered audio output, which immediately crashed and then reset itself. It’s worked perfectly ever since. If that works, but you find you have to redo it with every boot, then you should be able to fix that with alsactl store. That should write your current settings to disk, so make sure you have it working first.

I got the instructions from here, at the bottom:

@fedorable and @d2r would you be so kind to complete the information so that people after you have it easier to understand what was the problem with the audio.

You both used Fedora 33 workstation? Was it while installing an update or just a random software?
What kind of Hardware are you using while having that problem?

There’s not really much more to tell. F33 Workstation, yes. Desktop build, nvidia driver. Nothing new had been installed in the last few weeks. My wife plays DND using firefox and discord, and uses headphones for audio output, and a webcam for audio input. She’d just gamed the entire evening and her audio experience was fine. The next time the computer booted up - headphones had been removed - and there was no audio from any programs, only from the system settings, like if you raise or lower the volume, or accidentally delete too far in terminal. Interestingly, the “test audio” function in sounds (“front left, front right”) wasn’t working either. Bluetooth headphones had the exact same response, system sounds, nothing else.

But we could see signal coming through the S/PDIF option, which I still don’t understand. So I hooked up a soundbar, and that worked for a couple of hours. Then it stopped working. No amount of reboots would bring it back. The headphones/line out still worked fine.

I tried multiple reboots and killing + restarting pulseaudio, and eventually just switched to windows for a couple of days while I figured out what to do. Restarting the sound server did it.

1 Like

Until Fedora 33 with Pulsaudio:

aplay -l = List’s the hardware
sudo alsactl init # = to reinitialize the hardware driver for that card (for “#” see aplay-l)
pulseaudio -k = restarts the sound server

A summary for slow readers :wink:

I’ll just add that I skipped the aplay -l step, and just used alsactl init without sudo or a specific number. It just initialized all the hardware, which seemed to work fine. A summary for lazy typers :slight_smile:

I had to run it a second time, and that time it didn’t just fix itself, but began working again after I skipped ahead a few seconds in a video I was streaming. The system was sending sound to the wrong output, and I’m not sure why, so I installed and used the paman tool (pulse audio manager) and corrected it. shrugs

So here’s a few more useful resources, if this hasn’t fixed you up 100%, just to have a definitive repair solution page:

Pulseaudio runs but there is no sound

Pulseaudio not working properly


Speakers must be manually enabled

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.