No sound from software - Fedora 31

Hi there, this is my first message here, and I came with a quite interesting/weird situtation. I want to use my headset with my desktop computer, but I’m not lucky. Am I sure the headset works properlly? Yes, I am. I use this very same headset with my laptop and everything goes fine. The laptop and the desktop machine runs Fedora 31, kernel 5.5.9-200.fc31.x86_64

What does happen with my desktop machine? I have no sound from software when using headphones. It doesn’t matter if the headphones are connected to “line out” or “headphones frontal” jacks.

Why do I say “sound from software”? Because I can speak in the microphone, and I hear what I say. I can even use the mixer (alsamixer, or the graphical GNome Shell mixer) and mute the microphone, or the headphones. However, when I want to listen to some music I just hear nothing. This behaviour makes me thing that the jacks are working fine, and that the motherboard is capturing the sound and playing it back.

One curious thing is that the GUI mixer shows me that applications (music player, browser, etc) is playing audio, and the sound bar goes up and down. However, I listen to nothing. The only way I have now to listen to music from software is using a bluetooth device.

Any help?


1 Like

Welcome to the Fedora Communty @phanxen,

Sorry that you are having issues with sound on your machine. Install pavucontrol and take a look at the following tabs:

  1. Playback
  2. Output Devices
  3. Configuration

Watch the “Playback” tab while playing music from your App (Rhythmbox?). Is the playback Slider for the App adjusted? Now check the “Output Devices” tab. Make sure that the Port says “Headphones (plugged in)” Is the playback Slider for your sound device adjusted? If you do not find solution in the first two tabs, then look at the last one. Make sure you selected a profile that matches the specifications of the sound-card on your machine then try the first two again

How did it go?

Thank you so much for answering.

Unfortunately I had no success. I tried the steps you suggested with all the profiles available, and the behavior was always the same.

I also was sure the headphones was connected, and was detected by the command hdajacksensetest. For instance, this is the output of this command:

Pin 0x14 (Green Line Out, Rear side): present = Yes
Pin 0x18 (Pink Mic, Rear side): present = Yes

So, no lucky.



Could you repeat your attempt on Fedora 30 or 32(Beta) perhaps? This might be a regression (bug).

On my desktop (F31) I find that when I switch audio outputs (HDMI, USB, SPDIF, or wired headphone) I need to go into the setup/sound panel and select the output I want to use.
This is not a problem for me and AFAIK most systems with multiple sound outputs require you to select the specific device to be used.
Maybe you should try that.

Also, there are different selectors for input and output. If there is only one choice then the device is selected automatically and “just works” when you attach it (microphone) but with multiple choices I have to select the device. You may have digital outputs as well as the system analog outputs (headphones) if you have HDMI and/or SPDIF connections on your system

you could try to download some .wav file and play it with:
aplay test.wav

Also the output of:
aplay -l
and aplay -L
could be usefull.

If aplay works fine… it kind of suggest pulseaudio is in cause… I remember having seen that happens but … yeah, I think if I was rebooting the laptop with the earphones plugged, then I had sound working.

Sometimes the problem is pulseaudio use a kind of virtual device when it does not find a real output, so you do see the meters move, but no output.

Note that you can use -D to select one of the output of -L

aplay is in alsa-utils package

Thank you @twohot !

This answer solved my problem, which was that my Windows-10 VM running under virt-manager stopped getting redirected the Mic and Speaker after updating to F31.

I was able to fix this with pavucontrol.

1 Like


Don’t forget to mark the response that solved your question or drew attention the solution,
Go to the post and tick it as the solution. That should help others find the solution in the future too