[NEW USER] Proton Mail Bridge

,

Hi All…

So I have almost everything sorted now and loving Asahi :]

My last real challenge is email. I use Proton Mail for personal and business, so as my only email provider, I would really like to get this working locally, rather than just via the Browser. Proton offer their “bridge” app to work with Thunderbird, only I have tried everything I can, following all their “install guides for Linux”, but with no success.

So my question, has ANYONE been able to get Proton Mail / Bridge working in Asahi… ? The link below talks about installing it for Linux from an RPM file. Is RPM V’s PKGBUILD V’s DEB, the right way… ?

If I run the command “dnf install protonmail-bridge-3.8.2-1.x86_64.rpm” I get this output:

Last metadata expiration check: 4:23:04 ago on Wed 21 Feb 2024 11:49:49.
allow_vendor_change is disabled. This option is currently not supported for downgrade and distro-sync commands
Error:
Problem: conflicting requests

  • package protonmail-bridge-3.8.2-1.x86_64 from @commandline does not have a compatible architecture
    (try to add ‘–skip-broken’ to skip uninstallable packages)

Here’s the link for PROTON GUIDE for Linux

Thanks for any guidance…
VAULT

I don’t use it. But maybe you can check this: Doesn't run on aarch64 (Asahi Linux M1) · Issue #271 · ProtonMail/proton-bridge · GitHub

1 Like

Thanks for the assistance once again HH… very Honorable of you :]

I did google and find that, but not sure how to utilise the info, as I am VERY new to Linux, packages, installing etc.

Respectfully, I will see if anyone else has any thoughts about the error message it displayed…
VAULT

You have to build it for now (I’m the author of the linked issue)

Hi Carlo…

Thanks for your reply… I have been using macOS for 25+ years, but using Linux for a total of 3 days now :] So… I don’t even really know what that means. I assume you are telling me I have to build / compile it or such, which is well beyond my skills at this time.

If so, then I guess Proton Mail / Bridge is NOT available for new Asahi Linux users then… ?

Thanks for responding at least… :slight_smile:

VAULT

In the next few days I’ll try to write a guide and link a build so you can use it

1 Like

Wow… thanks so much! :slight_smile:

The architecture of a system refers to the processor which powers it. x86_64 compatibility is not the correct architecture it means you have to find an RPM with the suffix .aarch64.
It looks like that proton is just offering x86_64 architecture to download. So the only thing you can try is to compile it for aarch64 using the source-code as mentioned above.

p.s.
just to clarify what the error is about.

Multiple common mistakes.

Linux doesnt work that way. Never install random program files (RPM is the one used in Fedora) unless there is no other option.

Always use fedora repositories first: sudo dnf install protonmail-bridge.

Other option is to add another repository, a source of apps (including secure cryptographic verification and updates with the rest of your system). Repos are really important.

So if the package is not shipped by Fedora, maybe the software supplier has an official repository that you can add. Just download the *.repo file to /etc/yum.repos.d/ this works on all Fedorq variants.

If the software supplier has no repo, maybe there is a COPR, or a repo on OpenBuildService that also has Fedora versions. Note that Fedora RPMs are somewhat compatible with Opensuse RPMs but some packages are called differently so in practice they are not.

If that is also not working, then using some local RPM (after writing the devs to please add a repo) can be an option.

The last option would be to compile the package yourself, or even make a COPR repo that does that. I have no experience with any of those, some apps are easy to build but I find COPR very confusing.

And then yes, that local RPM clearly states x86_64 which is the traditional desktop CPU architecture, while you need aarch64

@ilikelinux @boredsquirrel
Thanks guys for those detailed replies… very helpful, giving me a better understanding of how it all works. Have made a note and I keep learning :] Keen on @cmalvi offer to provide a guide and build for Proton Mail / Bridge and very grateful for his offer!

VAULT

1 Like

Hi, here’s the build and a little guide:

For now you can only use the no-gui version of the proton bridge, because the gui one doesn’t build correctly.
If you want to try to build it, visit the official build guide, in the same page you can also find how to use the no-gui version.

In the zip there is the build of the app, the icon and a premade desktop file.
Extract the content under HOME/Applications so the path of the app should be HOME/Applications/proton-bridge-cli and place the desktop file under HOME/.local/share/applications.

First you have to run the bridge from terminal and configure your account following the documentation, then you can use the premade desktop file to set it as startup application with Gnome tweaks or similar.

ZIP: Send

1 Like

Hi @cmalvi

Thank you for these files and guide. I just need a little help please :slight_smile:

I have:

  1. D/Loaded the zip

  2. I could NOT extract into “Applications” folder as it did NOT exist. So I used the terminal to mkdir Applications.

  3. I then extracted the zip in there = /home/vault/Applications/proton-bridge-cli/

  4. I then tried to move the desktop file (protonmail-bridge-nogui.desktop) to folder /HOME/.local/share/applications but it did not exist. So I looked around and found it as: /home/vault/.local/share/Applications/ and moved the file there.

  5. I then type bridge to run the bridge app in terminal (konsole) but it doesn’t look like it runs the file. I get a terminal output of:

$ bridge
Usage: bridge [ OPTIONS ] OBJECT { COMMAND | help }
bridge [ -force ] -batch filename
where OBJECT := { link | fdb | mdb | vlan | monitor }
OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] |
-o[neline] | -t[imestamp] | -n[etns] name |
-c[ompressvlans] -color -p[retty] -j[son] }

SO… I am NOT sure what to do next… ?

If I open the desktop file, and look at line 3 and 8, I think the directory structure may be wrong as it was missing my dir “vault”. I tried adding it but still don’t think it’s working:

[Desktop Entry]
Type=Application
Icon=$HOME/vault/Applications/proton-bridge-cli/bridge.ico
Name=Proton Mail Bridge
Name[en]=Proton Mail Bridge
Name[en_US]=Proton Mail Bridge
Name[en_US.UTF-8]=Proton Mail Bridge
Exec=$HOME/vault/Applications/proton-bridge-cli/bridge -n
Hidden=false
NoDisplay=false
StartupNotify=false
Terminal=false

Do I need to restart the Mac or something for it to “read / see” the new desktop file… ?

Sorry to be annoying, but I am trying to learn to use Linux, I am just very new to it :slight_smile:

Thank you…
VAULT

That is another app, you have to move to it’s folder and then launch it like this

cd $HOME/Applications/proton-bridge-cli

then launch it using the correct argument to use the interactive mode -c

./bridge -c

if you prefer you can do it in one step

$HOME/Applications/proton-bridge-cli/bridge -c

NOTE: i think there is a misunderstanding about $HOME:

$HOME is an environment variable that point the current user home directory, in your case

$HOME = /home/vault

you can see it from terminal running

echo $HOME

so remove vault from Icon and Exec path

1 Like

Thanks Carlo

That all made sense and I have the Bridge App running in the terminal. Thank you for your assistance!!

VAULT

1 Like

Hi @cmalvi

One hopefully final question, now I have Bridge installed and working, Thunderbird installed and working, I need to manually start terminal and run command each morning:
“$HOME/Applications/proton-bridge-cli/bridge -c”

  1. Can I set this up somehow / where to auto run at Bootup… ?
  2. Can it keep running after I close the Terminal app… ?

Thanks for all the help! It’s been appreciated, and hopefully others will find this tread and be able to use Proton Bridge + Thunderbird also :slight_smile:

VAULT

You are on Asahi which means KDE. Tbh no idea if this is a general solution, but in KDE:

cat >> /.local/bin/start-proton-bridge <<EOF
#!/bin/bash

# create a logfile in same dir
logfile="$HOME/Applications/proton-bridge-cli/bridge.log"

echo "==================================" >> "$logfile"
echo "$(date)" >> "$logfile"
echo "==================================" >> "$logfile"

# run and direct all standard error to log
$HOME/Applications/proton-bridge-cli/bridge -c >> "$logfile" 2>&1

EOF

Complex command, here it how it works:

  • cat > file can write text to a file. cat >> file will append (add to the last line) text
  • this strange <<EOF EOF is called a heredoc, no idea where it comes from but basically instead of “EOF” you can write what you want and it will “listen to any text” until you enter that sequence. This is worlds better than echo "stuff stuff2 stuff3" because it allows linebreaks, ANY character etc. There are many ways to write files, this is the best imo.
  • #!/bin/bash is calles a shebang or something, it indecates the filetype I think. Note that a script doesnt need “.sh” or “.bash” at the end, Linux doesnt need that and it looks nicer
  • the date command displays the date
  • echo $(command) gives the output of that command as text, that you can >> (append), > (write) etc. Using | (pipe) you can send the output to another command to process it further.
  • then you have a logfile where all errors are but, this is always done with this cryptic 2>&1. ChatGPT told me its “file descriptor 2”. If you want to output everything, just use >> but that will spam that log.
  • the log may get huge over time, there is currently no autodelete system. Placing touch $logfile right after defining what it is should do the trick. Basically the same as echo "" > $logfile which should be the same as echo > $logfile. Just dont rm the file, because the other commands only append, and dont create (afaik)

Thats for the command. Now you wrote that script to ~/.local/bin/ which is in your $PATH. That means everything in there can be ran directly from the terminal without specifying its location.

echo $PATH tells you where that is. You could replicate something similar with cat ~/.bashrc | grep PATH, where you see a use case of the “pipe”. ~ is the same as $HOME, but not sure if it always works.

Some more “refer to directories” stuff:

  • bash ./file.txt, the . refers to this directory
  • cd .. or cat ../file.txt, .. refers to the previous directory. cd ../.. will go 2 directories back
  • cd / will go to the root folder
  • cd ~ to your users home
  • pwd shows you where you are
  • whereis locates executable files
  • various tools like fzf/skim, locate, find can help you find files based on name or even content

Btw the . is hidden in ls, you can show it with ls -a. On Unix/Linux the pointer to the current and previous directory are literally also a file (I think), which is very funny. That it was hidden was used by a bug that became a feature, files and folders like .config are also hidden and are called “dotfiles”.

But one thing is missing, here no idea if this is KDE only, you need a desktop entry. In the appmenu search for “autostart”. Find “add new” and “add new autostart script”. Here you search for the script you created, the settings will create the .desktop file for you, it lands in ~/.config/autostart.

For some reason just placing a script there doesnt do anything.

KDE will warn you that the script is not executable, and you can make it so. In the terminal that would be chmod +x SCRIPT

Now the bridge should autostart.

If it was a normal package you could skip some steps and just add the app in the “autostart” page. If there is a .desktop file included, put that into ~/.config/autostart/ and change the Exec= line to point to the right binary.

1 Like

Use the desktop shortcut that was in the zip file, you already copy it in the correct path.
If you are on Gnome, use Tweak app to add the bridge to startup application.
On KDE I don’t know sorry , but sure there will be a similar method

2 Likes

@vault I’m also a long term Mac user taking my first few steps on Asahi Linux Remix 39 (Gnome).

Without hijacking this thread, I’m interested in your reasons for switching. Briefly outlining the case for me, I think Apple de-prioritised macOS years ago and it shows. It used to have industry-leading UI designers, but nowadays, they seem content to hire university graduates who took 1 module of UI design in their Marketing degree. These hacks design everything on Swift (mainly for tablet) and then sling it over the wall to macOS with little user testing or performance testing. I don’t like the direction it’s heading – macOS is becoming an unstable, embarrassing candy bag of gimmicks given a yearly facelift. Plus, Apple forces you to install their trash – if you’re not on the latest OS, you don’t get full security updates.

Meanwhile, Gnome’s interface is top draw and the Asahi Linux team are so impressive, they leave Apple’s own software teams in the dust at times. So, to me, combining the best hardware available (M-series Macs) with a more stable, polished, flexible, privacy-friendly and fully-supported OS seemed the better alternative. (When microphone and touchID arrive and more battery optimisations are available, as per the official Asahi release, it’ll become my main driver.)

Why did you switch?

1 Like

Hi @tommyrot

Thanks for sharing. I started on System 7 with my first mac, so yes it’s been awhile and I agree with your comments. I also have a strong interest in privacy, so have reached a point where I am not willing to continue with Apples spying behaviour.

I had the first iPhone [iPhone 1 which I jailbroke to do things with it that Apple didn’t want us to :] when living overseas in Panama and stayed with iPhone to my iPhone X… but finally found a way to leave them behind, and deGoogled my first phone three years ago. I run my own I.T. business, and researched deGoogling phones, and found most are done very poorly, and 2 years back switched to Graphene OS which is the most amazing OS I have ever come across! I now deGoogle phones for clients too.

Asahi Linux is the final piece for me in exiting the Apple Spy EcoSystem and I find it rather exciting. Having little experience using Linux, though installed Linux Mint, Ubuntu, Tails and others on USB drives to trial, they never ran well on Macs as you know.

I went with Asahi KDE as it seemed to me from reading the website, to be the most stable, polished option. As I wanted this to be my daily driver, I went with KDE, though my understanding is GNOME would feel more like macOS. However my commitment was 100% to make this the time to move to Linux on my MacBook Pro 16", so I have a whatever it takes attitude, and if that means moving back to an OS that “looks” a little less macOS visually refined, and a bit more visually clunky blocky, then so-be-it. Privacy is more important to me… but nice to keep the high quality Mac hardware :]

I have now moved 100% over the Asahi… and my experience has been rather good. As stated, everything just works, well the features on the list at least… and if/when we get the few remaining features [Touch ID, TB 4, etc] then that to me is just a bonus. I did find it a little challenging to find, install say Proton VPN, and this Proton Bridge has certainly been a task, but with the help from those here, it was achieved.

I think it could be interesting to do a side by side comparison of Asahi KDE and GNOME…

Hopefully, this post will encourage others considering the move, to actually take the jump :]

VAULT

1 Like

Thanks @boredsquirrel

I had to read all that twice :] I will have a play with it later today. Yes would be much easier if we could just put it in autostart like I did for the Proton VPN app :]

1 Like