New user - How to install Telegram or any other 'executable' type file?

Hey, I am new to Fedora and Linux in general, I couldn’t find an answer for what seems to be a very simple question (maybe too simple :thinking:).
How to install an executable type file?
More specifically, what is the right way to install a program that does not appear in the Software search?
What I did is to download the file from the website (Telegram) extract it and double click to run it.
It worked but there is no Icon and after I close the application it’s gone, so it is probably not the right way to do it…
Thank in advance.

1 Like

Welcome to the community! I suggest you think about the Software application as your app store. But your app store can be expanded to include other collections of applications (repositories). There are lots of other ways to add software to your system, but it’s probably best to stick to the software application if you’re just beginning out.

Both the flathub and rpmfusion repositories both have telegram.

This link has instructions for adding rpm fusion:

This link has Instructions for adding/enabling flathub/flatpak:

Once you’ve added those repositories, you can restart your system and reload the software application and search for telegram and it should show up.


I’m not sure what the default software application has available, but you can check the following as well:

  1. In the Software app, go to the menu in the top right
  2. Select Software Repositories
  3. Enable Third Party Repositories
  4. Enable the relevant repositories

I have enabled the following beyond the defaults:
RPM Fusion for Fedora 33 - Nonfree - Steam
RPM Fusion for Fedora 33 - Free
RPM Fusion for Fedora 33 - Free - Updates
RPM Fusion for Fedora 33 - Free tainted
RPM Fusion for Fedora 33 - Nonfree - Updates


Thank you for your answer, I had the RMP fusion repositories enabled before and now added flathub too.
But still searching “telegram” give no result.

Have you rebooted your system?

Just did and it worked! Thank you very much I can install telegram now :smiley:
BTW log out was not sufficient… a restart was reqiuered. :sweat_smile:


This seems to have worked but rebooting is a Windows thing that is usually not required in Linux (unless you want to boot into an updated kernel or some low-level stuff).

It would have been sufficient to update the repositories metadata information.

When managing packages and updates using dnf, the command for fetching latest package information is:

sudo dnf update --refresh

Or, if you prefer to use Gnome Software, the graphical app store, it has a reload button in the top left corner:

The corresponding command is

pkcon refresh force

After adding flatpak repo from flathub, your best friend is:

flatpak search telegram

You can then install (any flatpak) by using the Application ID in the following command:

 flatpak install <App ID>


flatpak install org.telegram

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.