New install for Fedora 33 with Nvidia videocard

HI there,

I am running a work computer which runs the following hardware…

CPU: Intel i5-3570K (4) @ 4.100GHz

I would like to install Fedora 33 workstation. I am coming from Pop OS and it runs great but my system freezes everytime I try to install Fedora.

I tried to run the command “inxi -Fmrp”

but i get an error

I would appreciate your help

What error did you get? Did it say inxi was not installed? or that it needed root to run?
I forgot on the other thread to tell you that by enabling the network you could install packages while running the live USB.

Once you open a terminal you can use su to get root access with no password.
Then “dnf install inxi” should make that command available for you.

Hi there thanks for the reply

please see this output file

I also get an error when I try to install Fedora, I am installing it into a drive that is encrypted, could this be the reason for the error?

Please in the future save the screen output to a text file or cut and paste into the post. It is very difficult for me to read the image you posted.

Installing onto an encrypted drive is possible. there are a couple caveats that I am aware of to make it work. Which of those drives shown are encrypted?
I would assume you want to install the OS on the SSD and have data on the HDD.
While you may use whatever you choose as partitions I will give you the layout that works for me.
/boot ext4 500M
/boot/efi vfat,esp 250M (esp is required for UEFI)
/ ext4 30G to 50G (I use 50G) (may be encrypted if you wish)
/home ext4 as large as you wish and may be encrypted.

I would not encrypt anything except /home since all your personal data usually resides there and the system areas seldom hold anything that is non-standard. Your choice though.

The caveats I mentioned:
/boot cannot be encrypted and the efi boot (/boot/efi) partition also cannot be encrypted.
If you only use 1 partition for /boot and not a separate for efi then /boot must be formatted vfat and ~1G in size. It also would need to be flagged as esp for UEFI booting.

Your problems with the nvidia card should be simple to fix once the install is done since the drivers can be installed from rpmfusion. The noveau driver will support most of the features of that card to allow initial usage while getting the nvidia drivers installed…


Hi there,

Okay sorry for that, I wanted to figure out how to attach it as a text file but i didnt think it would let me, i couldnt find that button.

So I am pleased to say I have installed Fedora 33 and its working perfect.

I was so glad to see my favorite app typora worked from the snap store.

Now I just want to install the printers and the drivers for the video card.

How do I get to rpm fusion?

One way is to paste it in and just share a link here.

See and

Hi there,

I tried to install the nvidia drivers and I do not believe it worked. My system keeps freezing.

I have a very old GPU. its called a Geforce 660

I am following the instructions very carefully and its quite confusing here:

I also followed these instructions :

Did you follow the instructions at Configuration - RPM Fusion before you did anything else? That would have set up the rpmfusion repos so you could install the drivers. I checked and although your card (GTX 660) is old it is still supported by the latest drivers according to nvidia.

Once that was done then a simple dnf command would install the rest.

sudo dnf install akmod-nvidia nvidia*455* kernel-devel kernel-headers xorg-x11-drv-nvidia*455*

That is the command I use with a new install to enable and configure the nvidia drivers. It downloads the packages and installs them and after the install is done the akmod-nvidia package builds the kernel modules for the driver. My command differs from that in step 4 of the instructions you posted with the link, but is more comprehensive. If you used the instructions from your post from ( Chapter 4. Installing the NVIDIA Driver) then it is likely there is an error because those are the raw drivers and the ones from rpmfusion are the ones that have already been tweaked for fedora.

If not all that is installed then the drivers may fail. If installed from some other repo they might not be tweaked to work with fedora and require some tweaking by you to work correctly.

If you already have done the install then in order to make certain that everything is clean and coincident I suggest you remove all installed nvidia packages with the below command and reinstall with my command above.

 sudo dnf erase '*nvidia*' 
1 Like

@bennyisaiah Could you please send over the output of the uname -a command?

hi there,

I have been trying to boot into the system for a long time now, I have the feeling the video card is never going to work on fedora as I have tried many ways to get the driver installed, the system wont boot now into the system and just leaves me in the CLI when I boot.

I am wanting to change to AMD video card as I hear the drivers are open source on AMD and simply “just work” for fedora. is that true?

also if AMD cards are better could you tell me if I simply want a decent hard to play 4K DVD’s would a RX570 be okay ?

I wish i could, i cant seem to boot into anything anymore… i’ll keep trying and report back to you.


I have killed my System many times trying to install Nviidia Drivers. The Trick that always worked for me, although descriped by [computersavvy], is to setup a fresh Fedora, at the rpmfusion repos and follow the Instructions:

sudo dnf install$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm

sudo dnf update -y # and reboot if you are not on the latest kernel
sudo dnf install akmod-nvidia # rhel/centos users can use kmod-nvidia instead
sudo dnf install xorg-x11-drv-nvidia-cuda #optional for cuda/nvdec/nvenc support




Especially avoid this monstrosity. Fedora 37/36/35 NVIDIA Drivers Install Guide [525.85.05 / 520.56.06 / 515.86.01 / 510.108.03 / 470.161.03 / 390.157 / 340.108] – If Not True Then False


sorry for the late reply thanks so much

I used the following method to successfully install Nvidia driver on Fedora33

  1. Enable RPM Fusion (Free and Non-Free Repositories)

sudo dnf -y install$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm

sudo dnf -y update

  1. Install Nvidia Driver and Cuda Support

sudo dnf -y install kmod-nvidia
sudo dnf install xorg-x11-drv-nvidia-cuda

  1. Reboot the system

sudo reboot

nvidia-smi output

1 Like

Hi there,

Thanks so much I will give that a try, I appreciate this a lot.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.