My wifi adapter does not show up

Hi All,
I need some advice or help on this.

HP Probook
Dual boot Windows 10 Pro & Fedora 31 server plus LXQT desktop

Since last weekend when I boot up my laptop my internal wifi adapter does not show and I cannot connect to internet.
Wired internet is working. Attaching a USB wireless adapter is working.

If I boot into Win 10 I have the simalar issue. The wifi adapter is not working
In Win 10 you can update de driver in “device manager” but that does not work.
Result : " driver already up to date"
Removing the adapter en reboot Win 10 does not work either…

I believe / think : this is driver / firmware issue.

I found this solution on the internet:

But I’m not happy with the solution because I finally got my speakers working with
an article in Fedora Magazine “PulseEffect”.

I also check the Intel driver website but no luck
I downloaded the driver for Intel(R) Wireless-AC 9560
unzip it
rename the old driver
copy / paste the “new driver” to /lib/firmware
result: no luck

Does anyone have a solution for this ?

I have attached to 2 outputs from my system.

lspci | grep Network
00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)

dmesg | grep iwl
[ 10.729005] iwlwifi 0000:00:14.3: enabling device (0000 → 0002)
[ 10.732272] iwlwifi 0000:00:14.3: WRT: Overriding region id 0
[ 10.732274] iwlwifi 0000:00:14.3: WRT: Overriding region id 1
[ 10.732275] iwlwifi 0000:00:14.3: WRT: Overriding region id 2
[ 10.732276] iwlwifi 0000:00:14.3: WRT: Overriding region id 3
[ 10.732277] iwlwifi 0000:00:14.3: WRT: Overriding region id 4
[ 10.732278] iwlwifi 0000:00:14.3: WRT: Overriding region id 6
[ 10.732279] iwlwifi 0000:00:14.3: WRT: Overriding region id 8
[ 10.732280] iwlwifi 0000:00:14.3: WRT: Overriding region id 9
[ 10.732281] iwlwifi 0000:00:14.3: WRT: Overriding region id 10
[ 10.732282] iwlwifi 0000:00:14.3: WRT: Overriding region id 11
[ 10.732283] iwlwifi 0000:00:14.3: WRT: Overriding region id 15
[ 10.732283] iwlwifi 0000:00:14.3: WRT: Overriding region id 16
[ 10.732284] iwlwifi 0000:00:14.3: WRT: Overriding region id 18
[ 10.732285] iwlwifi 0000:00:14.3: WRT: Overriding region id 19
[ 10.732286] iwlwifi 0000:00:14.3: WRT: Overriding region id 20
[ 10.732287] iwlwifi 0000:00:14.3: WRT: Overriding region id 21
[ 10.732290] iwlwifi 0000:00:14.3: Found debug destination: EXTERNAL_DRAM
[ 10.732291] iwlwifi 0000:00:14.3: Found debug configuration: 0
[ 10.732489] iwlwifi 0000:00:14.3: loaded firmware version 46.8902351f.0 9000-pu-b0-jf-b0-46.ucode op_mode iwlmvm
[ 10.732510] iwlwifi 0000:00:14.3: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
[ 10.821990] iwlwifi 0000:00:14.3: Detected Intel(R) Wireless-AC 9560, REV=0x318
[ 11.870263] iwlwifi 0000:00:14.3: SecBoot CPU1 Status: 0x3, CPU2 Status: 0x226c
[ 12.120802] iwlwifi 0000:00:14.3: Not valid error log pointer 0x00000000 for Init uCode
[ 12.120820] iwlwifi 0000:00:14.3: Fseq Registers:
[ 12.120829] iwlwifi 0000:00:14.3: 0x3B9AAC10 | FSEQ_ERROR_CODE
[ 12.120837] iwlwifi 0000:00:14.3: 0x00000000 | FSEQ_TOP_INIT_VERSION
[ 12.120845] iwlwifi 0000:00:14.3: 0x243A93D0 | FSEQ_CNVIO_INIT_VERSION
[ 12.120854] iwlwifi 0000:00:14.3: 0x0000A384 | FSEQ_OTP_VERSION
[ 12.120862] iwlwifi 0000:00:14.3: 0xF79BFAE9 | FSEQ_TOP_CONTENT_VERSION
[ 12.120870] iwlwifi 0000:00:14.3: 0x7BBED8B6 | FSEQ_ALIVE_TOKEN
[ 12.120879] iwlwifi 0000:00:14.3: 0x06294141 | FSEQ_CNVI_ID
[ 12.120887] iwlwifi 0000:00:14.3: 0x73CBFEC7 | FSEQ_CNVR_ID
[ 12.120895] iwlwifi 0000:00:14.3: 0x01000100 | CNVI_AUX_MISC_CHIP
[ 12.120906] iwlwifi 0000:00:14.3: 0x01300202 | CNVR_AUX_MISC_CHIP
[ 12.120917] iwlwifi 0000:00:14.3: 0x0000485B | CNVR_SCU_SD_REGS_SD_REG_DIG_DCDC_VTRIM
[ 12.120958] iwlwifi 0000:00:14.3: 0xA5A5A5A2 | CNVR_SCU_SD_REGS_SD_REG_ACTIVE_VDIG_MIRROR
[ 12.120972] iwlwifi 0000:00:14.3: Failed to start INIT ucode: -110
[ 12.383320] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -110


If its not working in Win 10, I suspect the internal wifi hardware has failed.

In case it is a driver/firmware issue, whats the output of:

lspci -v

Thanks Tom.

1 Like

I only copy/paste Wireless AC 9560 data or do you need everything ?

00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)
Subsystem: Intel Corporation Device 0030
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at f1230000 (64-bit, non-prefetchable) [size=16K]
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi


Do you see your ssid under Settings, Wi-Fi? If so please try setting a static IP and rebooting.

Have you checked if wifi works with a live iso, fedora 31 or 32?

Thanks Tom.

Hi Tom,
Thanks for your help sofar
karma or not I’m in downloading Fedora 32 WS live iso right now
I want to install it as a kvm guest, play around … I will check it …
Come back to you.

Generally if the same problem occurs and starts at the same time in both linux and windows you can believe it is hardware. Your attempts to use both wired and a USB wireless adapter that work in both systems tell me the same thing.

Please try and see if the wifi works when booted with the F32 live image just in case it is driver/kernel related, although that would not explain the windows failure.

1 Like

Hi Tom,
In my network applet / icon I can only see my ssid under “Known Connection”.
Clicking on it does not anything.
Under “WiFi Connection” the list is blank. Nothing there…

As per your request to create a live USB disk :
I had a usb disk with Ubuntu 20.04, I fired it up and Ubuntu could not recognize my
than :
I downloaded Fedora Writer and created a live USB with Fedora 32 Workstation
and the result was the same as Ubuntu.

I went to the terminal to execute the following command :
nmcli radio wifi result: enabled
nmcli dev status result: only my “wired card” and “lo” show up.

This morning I also ask my windows body to check my card and came to the same conclusion

I will contact my supplier for a new wireless card if possible

Thanks for your help !!!

Hi Computersavvy,

Please see my reply @tjdoyle

Thanks for your help


NP, your testing seems to have confirmed the likely hardware failure.

Hi Thuurio,

as computersavvy has advised, it looks like the wifi chip has failed.

This leaves you with a couple of choices for this laptop. the easiest being get a USB wifi dongle. The 2nd is to replace the wifi chip, a repair shop should be able to this or a googe search will probably produce some results for you probook model.

Thanks Tom.

1 Like

Have you tried doing a clean install of Windows 10? If not, it is worth a try if you have time. Google Windows 10 Download Tool. Click the Download Windows 10 link. Download the tool. Follow the steps to create a live USB. If you need to, go to Disk Manager and get rid of your linux partitions. Then re-install Windows 10. After it is re-installed, hopefully your internal wifi works. Then you can go ahead and create your new partition for Fedora.

Hi All,
My issue is solved now.
In Windows 10 Pro there an option: Network Reset
Here is an windows article :
Network Reset

I only work in Linux, so I used above option and it solves my issue after a windows reboot and starting Fedora.
Credits to my windows techy.

And thanks again for your input

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.