MX Master 3 bluetooth mouse doesn't connect

Hi, i’m trying to connect a bluetooth mouse, Logitech MX Master 3 Mac, without success.
I tried pairing from terminal using bluetoothctl and mouse seems to connect but it disconnects right after

Attempting to pair with D6:B8:A9:25:EE:B2
[CHG] Device D6:B8:A9:25:EE:B2 Connected: yes
Failed to pair: org.bluez.Error.ConnectionAttemptFailed
[CHG] Device D6:B8:A9:25:EE:B2 Connected: no

Other bluetooth devices (JBL Charge 5 speaker and Airpods Pro) are working well.
On Arch Asahi version, mouse worked well.


Maybe the mouse is already paired in some other computer. I have a microsoft mouse and it connects perfectly with asahi

Thanks Ioannis for reponse. Perhaps it’s related to my hardware configuration.

I just migrated from Asahi Arch to Asahi Fedora last night and this morning. My MX Master 3 paired and works fine using KDE Settings after I set it to pairing mode. That being said, I have the regular MX Master 3 (not the Mac version), but I cannot easily determine if there’s a difference between the two from what i see online aside from colour.

Edit: I’m using a Mac Studio (M1 Ultra) hardware-wise

I tried the three different channels but no one works as expected. It connects for a millisec then disconnect :frowning: I’m on Macbook Air M1

I saw some weirdness with a Logitech MX Anywhere 2. I couldn’t get it to pair it using KDE’s Bluetooth wizard. It immediately failed. On the other hand pairing using bluetoothctl worked immediately. This is not on Fedora system. There are two possible causes: It could be a regression in the asahi-6.4 kernel or in my case it could be related to bluez-5.68 release which was on my system installed in the same time frame.

AFAIK on possible difference is that Logitech uses Bluetooth LE for pairing. Let me try on a Fedora install.

edit: no, the MX Anywhere 2 connects without problems on the Fedora system with KDE’s wizard and bluetoothctl

Tried on Steam Deck, it connects without problem

Just to be extra sure, did you put the mouse into pairing mode, by holding the channel switch button until the channel number starts flashing rapidly, before attempting to pair from the Asahi side?

Another thing you could try is to trust the mouse before you pair it. I’ve had the MX3 sometimes reconnect during pairing, and if the reconnection failed (which it would if my machine didn’t trust the mouse) the pairing wouldn’t work.

Yes, i’m in pairing mode. I also tried to trust it with bluetoothctl.

Did you trust it before pairing? The sequence that always works for me is remove device (if I messed up last time and the pairing ended up in a broken state) → put mouse into pairing mode → search for devices → trust mouse → pair mouse. I usually do it with the blueman GUI, but those steps should work in bluetoothctl too.

Yes, i just tried with blueman too. Remove → Trust → Pair. No success.
Can i debug the failure in some way? I’d like to have more messages than a single Failed to pair: org.bluez.Error.ConnectionAttemptFailedline

I’d check dmesg to see if the kernel has anything to say about the pairing process. Other than that though, I’m afraid I’m out of ideas.

1 Like

This thread may also shed light on your issue (if it’s not fixed): Is bluetooth completely fine? - #4 by marcan

I only use 802.11ac (which is 5GHz), so that may explain why my MX Master 3 paired fine, but yours disconnected shortly after the initial pairing.

In my experience the coexistence issues mainly affect real-time audio streaming, not simple pairing tasks, but yeah, it might be worth trying with WiFi off just to rule that out.

Tried with WiFi Off and WiFi on 5Ghz network, no luck

Devices get very confused with multi-boot setups in general (there is a fix for this on Macs by sharing pairing keys but we’re still working on the integration). You could try resetting all the pairings on the mouse, there’s usually some kind of hold-button-down sequence to do that, and then try again. It probably doesn’t like being paired to multiple OSes on the same machine at once (since they all look like the same machine to it, as they have the same address),.

My MX Master 3 works fine on 6.3.asahi13-1. After upgrading to branch asahi-wip(v6.4 kernel), nothing else changed, then I encountered the same pairing problem, but other devices such as keyboard and sound box works normally . so I think it’s related to a regression in the asahi-6.4 kernel.

1 Like

In case it helps, I’m using the 6.4.11-400.asahi.fc38.aarch64+16k kernel from yesterday and my MX Master 3 is still working fine.

I’ve opened this issue for tracking. Please report the affected or unaffected devices/configuration there.

Please report as much information on the bluetooth device (Product name, bt vendor and product ids, if available device firmware version, production date) and the output of asahi-diagnose.

I’ll test and report my config this evening (in ~12 hours) if you want to wait for an report template.

1 Like