Latest bluez update and Apple devices

Last week I receive the update to bluez 5.71.1.fc39 and since that time I’ve had issues connecting my Apple Magic keyboard and Apple AirPods which had been working fine before. I’m using a Logitec Bluetooth mouse and that is still working as before.

It seems there was a Bluetooth security issue with device pairing which was addressed in the 5.70 release of bluez.

It is possible to pair the Apple devices again, but you have to redo this every time Bluetooth restarts, e.g. when rebooting or coming out of suspend. This is not a very workable situation so I have downgraded bluez back to 5.69.1.fc39 and now things are working fine again.

Obviously this is not a good solution. Does anyone know of a better solution?

Hello, I had the same problem and didn’t know how to solve it, thank you very much. In my case, my Bose headset and my Bose speaker, both bluetooth, would pair to the PC but soon after a video or audio stopped playing, the device disconnected by itself, forcing me to reconnect it. Your information about Bluez solved the problem (right after the downgrade). This is complicated, an update comes and there is no audit. This is worrisome because it affects literally every computer running fedora 39 around the world.

Unfortunately it is not the complete work around. The AirPods are now connecting just fine, but the Magic Keyboard still needs to be repaired every time. At least it is easier than before.

Feels like it could be related to this.

(Just a me too comment.)
Not sure if related, but I have a Keychron keyboard (uses Apple driver) that always connects terribly with Linux (Fedora).

  • Almost unable to connect in lock screen
  • Takes several tries to connect
  • Unable to pair with one of my laptops

2 weeks ago the Bluetooth on my old laptop (Realtek 8822CE) stopped working completely (had problem with reset, but I didn’t see useful log when it broke), after it started to work again it is unable to pair with the keyboard (org.bluez.Error.AuthenticationCanceled). Though the laptop connects with other devices just fine.
I thought maybe the Bluetooth module broke and bought a Framework laptop (Intel AX210), same difficulty in connecting, but at least it pairs… By comparison Windows (Surface laptop) connects instantly.

Did you check and see if modifying /etc/bluetooth/input.conf
and setting ClassicBondedOnly=false changed your indications?

Please be sure and read through and understand cve-details if you decide to leave it that way.

You may also want to take a look at, Issues · bluez/bluez · GitHub and see if the issue is already reported or file a new issue.

Just tried that (upgrading to 5.71.1 again and setting ClassicBondedOnly=false), but unfortunately I still need to pair the Apple devices over and over again. Back to downgrading again. :frowning:

This problem appears to be resolved with the 5.71-2 update

1 Like

Unfortunately, even after the update, my devices still disconnect on their own. Forcing me to have to keep reconnecting them right after running any media. Does anyone have any suggestions for the resolution other than the downgrade?