Mutter error when playing full screen video


When I run a video in full screen mode, gnome-shell crashes i.e. all applications close and return to the login screen.
This error appears with all chromium-based browsers, not with firefox (and all video apps like VLC)

each time it happens, i notice thiis error
kernel: gnome-shell[2355]: segfault at ffffffffffffffec ip 00007f9c77970a3b sp 00007ffc59545ff8 error 5 in[7f9c7784e000+159000]

After somes investigations, i notice it happens with gnome-shell.x86_64 43.2-1.fc37
mutter.i686 43.2-1.fc37
EDIT : this is “mutter-43.2-1.fc37.x86_64” (no mutter.i686)

when downgrading theses twoackages to :
gnome-shell.x86_64 43.0-3.fc37
mutter.x86_64 43.0-4.fc37
mutter error doesn’t appear and playing a video in full screen mode is OK

Am i the only one to have this behaviour ? what can i do ? waiting a new update of theses two packages ?

  Kernel: 6.0.15-300.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Desktop: GNOME v: 43.0 tk: GTK v: 3.24.35 wm: gnome-shell
    dm: GDM Distro: Fedora release 37 (Thirty Seven)
  Type: Laptop System: LENOVO product: 82JU v: Legion 5 15ACH6H

  Info: 8-core model: AMD Ryzen 7 5800H with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 2067 high: 4442 min/max: 400/4463 boost: enabled cores:
    1: 2742 2: 400 3: 400 4: 3186 5: 4442 6: 400 7: 2435 8: 2815 9: 2535
    10: 2611 11: 2535 12: 400 13: 2613 14: 400 15: 2535 16: 2636
    bogomips: 102214
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: Lenovo
    driver: nouveau v: kernel arch: Ampere pcie: speed: 8 GT/s lanes: 8 ports:
    active: DP-2,HDMI-A-1 empty: DP-1,eDP-1 bus-ID: 01:00.0 chip-ID: 10de:24dd
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5.1 pcie: speed: 8 GT/s
    lanes: 16 ports: active: none off: eDP-2 empty: none bus-ID: 06:00.0
    chip-ID: 1002:1638 temp: 37.0 C
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-3:3 chip-ID: 04f2:b725
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.6
    compositor: gnome-shell driver: X: loaded: amdgpu,modesetting
    unloaded: fbdev,vesa dri: radeonsi gpu: amdgpu,nouveau display-ID: 0
  Monitor-1: DP-2 model: BenQ EW3270U res: 3840x2160 dpi: 140
    diag: 801mm (31.5")
  Monitor-2: HDMI-A-1 model: BenQ EW3270U res: 3840x2160 dpi: 140
    diag: 801mm (31.5")
  Monitor-3: eDP-2 model: BOE Display 0x0a1c res: 1920x1080 dpi: 142
    diag: 395mm (15.5")
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.6 DRM 3.48 6.0.15-300.fc37.x86_64) direct render: Yes

32-bit packages are increasingly unsupported/untested on Fedora Linux since release 31. Do you really need mutter.i686?

If you have several 32-bit packages installed by accident, you might want to run sudo rpmreaper '\.i686$' ~L1 to prune them (use d to flag packages for deletion and c to commit the transaction). Note, however, that wine/steam does require several 32-bit packages. If you run those sort of applications, you might need some 32-bit packages (but I don’t think you would need mutter.i686).

thanks for your reply.
mistake in my original post : the package is “mutter-43.2-1.fc37.x86_64” and no mutter.i686