After f37 upgrade, video games crash and require hard reboot

I upgraded to f37 yesterday. Seemed like the smoothest fedora upgrade I’ve had in years. Until I tried to play warthunder today. When I try to play, a few minutes into a match the screen goes all crazy and the system stops taking input. I have to hard reboot.

I saw there was an amggpu firmware update in dnf, so I updated. Tried again and still required a hard reboot.
abrt links me to this which has almost 15k of the same backtrace in 24 hours

It looks like neofetch detects my gpu incorrectly as a generic rx 6800 while gnome detects it as a rx 6900 xt correctly.

OS: Fedora release 37 (Thirty Seven) x86_64
Kernel: 6.0.8-300.fc37.x86_64
Uptime: 26 mins
Packages: 2628 (rpm)
Shell: bash 5.2.2
Resolution: 2560x1440
DE: GNOME 43.1
WM: Mutter
WM Theme: Adwaita
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: gnome-terminal
CPU: AMD Ryzen 7 1700 (16) @ 3.000GHz
GPU: AMD ATI Radeon RX 6800/6800 XT / 6900 XT
Memory: 3947MiB / 32017MiB

seems like whatever the problem is it is affecting around 8k people.

so I discovered that if I play windows at medium or lower this doesnt happen. If I play on high it hard locks the computer.

1 Like

I have a similar problem.
Gnome session (with wayland) restarts as soon as I play a video in full screen (with vlc or via web browser).

i have a laptop LENOVO Legion 5 15ACH6H with AMD Ryzen 7 5800H and two praphic cards
Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] driver: new
v: kernel
Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel

In my case, the problem appeared two days after F37 update, when i have done an update including gnome-shell and many firmwares :


1 Like

i have just noticed :
if i play a video in full screen mode with firefox browser, no problem
if i play a video in full scrren mode with vivaldi web browser or with vlc, gnome session restarts.

i have theses messages in logfile :

nov. 21 11:15:02 legion vivaldi-stable.desktop[7222]: [7217:7217:1121/111502.531024:ERROR:CONSOLE(0)] "Uncaught (in promise) Error: A listener indicated an asynchronous response by returning true, but the message channel closed before a response was received", source: chrome-extension://mpognobbkildjkofajifpdfhcokl>
nov. 21 11:15:02 legion audit[6491]: ANOM_ABEND auid=1000 uid=1000 gid=1000 ses=8 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=6491 comm="gnome-shell" exe="/usr/bin/gnome-shell" sig=11 res=1
nov. 21 11:15:02 legion kernel: gnome-shell[6491]: segfault at ffffffffffffffec ip 00007f4193f707bb sp 00007ffe9566d3c8 error 5 in[7f4193e4e000+159000]
nov. 21 11:15:02 legion kernel: Code: 0f 06 00 31 d2 4c 89 e7 89 c6 31 c0 e8 6e 2b ef ff 48 89 df 31 db e8 b4 0b ef ff eb c9 66 90 f3 0f 1e fa 48 63 05 c9 60 0d 00 <8b> 44 38 0c c3 f3 0f 1e fa 48 8b 05 85 61 0d 00 48 85 c0 74 10 48
nov. 21 11:15:02 legion audit: BPF prog-id=133 op=LOAD
nov. 21 11:15:02 legion audit: BPF prog-id=134 op=LOAD
nov. 21 11:15:02 legion audit: BPF prog-id=135 op=LOAD
nov. 21 11:15:02 legion systemd[1]: Started systemd-coredump@1-13382-0.service - Process Core Dump (PID 13382/UID 0).
nov. 21 11:15:02 legion audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@1-13382-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
nov. 21 11:15:04 legion systemd-coredump[13383]: [🡕] Process 6491 (gnome-shell) of user 1000 dumped core.
                                                 Module with build-id 9ff92e165010e0806172add635849ec55533b287
                                                 Module with build-id a66fc3d0ccc24082a2f5e882d09ad117fa9a1822
                                                 Metadata for module owned by FDO found: {

1 Like

I have the same problem on Fedora Workstation 37: On Wayland the machine locks completely, on X11 it some times locks, some times freezes just the game, some times the game and Steam.
I tested a clean install with KDE and on Wayland the same is happening: full system lock, X11 during the tests (2-3 day for hours) it just froze the game once or twice.
Lenovo Legion 5i 15IMH05H
Device-1: Intel CometLake-H GT2 [UHD Graphics] driver: i915 v: kernel
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] driver: nvidia

Nvidia GPUs require the nvidia driver when using graphics intensive apps such as games or videos since the nouveau driver does not support hardware acceleration.

Forcing the cpu into software acceleration is almost certain to cause a system hang on many systems as the cpu becomes overloaded.

Of course using higher resolutions is more demanding on everything.

None have reported details about the hardware or software involved, so there is no way to provide assistance, and having 4 people that say “me too” does not lead to a solution since it is distracting for the OP and any potential solutions suggested.

I suggest the OP provide us the output of inxi -Fzxx inside the </> preformatted text tags so we can see more detail about the hardware and software involved; and that the others wait to see what the outcome may be or start your own threads with the same info provided.

I dont use novideo currently.

  Kernel: 6.0.8-300.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-24.fc37 Desktop: GNOME v: 43.1 tk: GTK v: 3.24.34 wm: gnome-shell
    dm: GDM Distro: Fedora release 37 (Thirty Seven)
  Type: Desktop Mobo: ASRock model: X470 Master SLI/ac
    serial: <superuser required> UEFI: American Megatrends v: P4.40
    date: 03/29/2021
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) status: full
  Device-2: hidpp_battery_1 model: Logitech MX Keys Wireless Keyboard
    serial: <filter> charge: 55% (should be ignored) status: discharging
  Info: 8-core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen rev: 1
    cache: L1: 768 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 1638 high: 3003 min/max: 1550/3000 boost: enabled
    cores: 1: 1282 2: 3003 3: 1280 4: 1574 5: 2099 6: 1282 7: 1328 8: 1278
    9: 1282 10: 2889 11: 1278 12: 1550 13: 1676 14: 1550 15: 1550 16: 1309
    bogomips: 95993
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu
    v: kernel arch: RDNA-2 pcie: speed: 16 GT/s lanes: 16 ports: active: DP-1
    empty: DP-2,DP-3,HDMI-A-1 bus-ID: 0d:00.0 chip-ID: 1002:73bf
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,radeon,vesa dri: radeonsi gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96
  Monitor-1: DP-1 mapped: DisplayPort-0 model: BenQ EX3203R res: 2560x1440
    dpi: 93 diag: 801mm (31.5")
  OpenGL: renderer: AMD Radeon RX 6900 XT (navi21 LLVM 15.0.0 DRM 3.48
    6.0.8-300.fc37.x86_64) v: 4.6 Mesa 22.2.3 direct render: Yes
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    pcie: speed: 16 GT/s lanes: 16 bus-ID: 0d:00.1 chip-ID: 1002:ab28
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 0f:00.3 chip-ID: 1022:1457
  Sound API: ALSA v: k6.0.8-300.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.60 running: yes
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
    v: kernel pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:24fb
  IF: wlp4s0 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0
    chip-ID: 8086:1539
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-9:2 chip-ID: 8087:0aa7
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Device-1: md127 type: mdraid level: raid-5 status: active size: 7.28 TiB
  Info: report: 3/3 UUU blocks: 7813768192 chunk-size: 512k
    super-blocks: 1.2 algorithm: 2
  Components: Online: 0: sda1 1: sdb1 3: sdc1
  Local Storage: total: raw: 11.37 TiB usable: 7.73 TiB used: 382.18 GiB
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 500GB
    size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 36.9 C
  ID-2: /dev/sda vendor: Western Digital model: WD40EZRZ-00GXCB0
    size: 3.64 TiB speed: 6.0 Gb/s serial: <filter>
  ID-3: /dev/sdb vendor: Western Digital model: WD40EZRZ-00GXCB0
    size: 3.64 TiB speed: 6.0 Gb/s serial: <filter>
  ID-4: /dev/sdc vendor: Western Digital model: WD40EZRZ-00GXCB0
    size: 3.64 TiB speed: 6.0 Gb/s serial: <filter>
  ID-1: / size: 464.17 GiB used: 381.8 GiB (82.3%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 378.8 MiB (38.9%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 14 MiB (2.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 464.17 GiB used: 381.8 GiB (82.3%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 46.6 C mobo: N/A gpu: amdgpu temp: 52.0 C
    mem: 52.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 805 Uptime: 5h 39m Memory: 31.27 GiB used: 6.48 GiB (20.7%)
  Init: systemd v: 251 target: graphical (5) default: graphical Compilers:
  gcc: 12.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm Shell: Bash
  v: 5.2.2 running-in: gnome-terminal inxi: 3.3.22

I have solved my problem.
The problem was caused by the latest versions of the “Mutter” and “gnome-shell” packages (43.2-1.fc37)

I downgraded these 2 packages (to version 43.0-3.fc37 for gnome-shell and 43.0-4.fc37 for mutter).

This error message indicates that there was a problem with the communication between the listener and the message channel. The reason is that sendMessage is now promisified internally, so you can ‘await’ it, but the by-product is that when you don’t specify a callback yourselves, it is added internally anyway in order for the call to return a Promise, which means that since you don’t call sendResponse in onMessage, the API will think that it was you who made a mistake of using a callback and not providing a response, and report it as such.

Since the new behaviour is very confusing for almost everyone, a solution might be to stop showing this error when the callback is not specified, however it might cause confusion for those developers who still use callbacks and forgot to call sendResponse inside onMessage by mistake, which should be reported ideally as it always was.

If you see your extension causing this errors - inspect closely all your onMessage listeners. Some of them probably need to start returning promises (marking them as async should be enough).

If still error showing, try disabled all installed extensions in Chrome then you will get a clear console without errors.