System locks up after playing steam games

After playing certain games on Steam, if my monitors go to sleep and awake to the lock screen, I am unable to enter my password as if the box is not allowing me to input any information, along with blinking ‘Authentication Failure’. Not sure what’s going on, but this has been an occurrence from F36 to F37

I think this is a Gnome issue, its wayland compositor lacks support for the idle inhibit protocol.
Just disable “Power off screen” in Power settings

What’s odd is it only happens on my personal system, not my work system, so that’s where the confusion is coming from.

Is each of those systems using Wayland or X11? And Gnome or KDE?
I believe Gnome (like KDE) has a login time choice to switch between Wayland and X11.

My son tested Steam on my Fedora F37 system (out of only curiosity because I don’t want to use Steam and he doesn’t want to use Linux). Maybe we did something wrong, but Steam had enough problems with KDE/Wayland to be basically unusable, but worked fine with KDE/X11.

Both are using stock Fedora 37, I have even reinstalled Fedora, thinking it was something I had done unintentionally, but the issue keeps returning.

Gnome Version: 43.3
Windowing System: Wayland

Have you tried not using Wayland (should be a choice at each GUI login)?

I have not, I can try that later today.

I understand that steam (which is a 32 bit environment) may have problems with wayland. It was developed with xorg and I don’t think it has been upgraded to either 64 bit or to be fully wayland compatible.

So after some more research I think it might be linked to the nvidia-powerd.service, to quote one of the commenters stated.

“With 5 minutes of debugging, I suspect (might be false) that nvidia-powerd is spamming logs through dbus, and hit the limit (hence quotas exceeded). However modern linux desktop relies on dbus for almost everything, including that shutdown button and gdm login. So bad things happen.”

I will test this next time this comes up and confirms.