Monitor burn-in with NVIDIA

I recently installed Fedora 34 and the latest akmod-nvidia package for NVIDIA drivers. However, after leaving my desktop on suspend overnight, I came back to see that there was a bunch of burn in, but seemingly only every other pixel. It gets progressively worse and more and more white the longer I’m using Fedora. Since this is a dual-boot install, I then rebooted into Windows, and found that the effect is still there, but doesn’t get worse. After leaving the monitor off for a while, the effect lessens and goes away after a while, but as soon as I boot into Fedora, it starts again. I’ve disabled GNOME extensions and restarted GNOME multiple times to no avail.

Here’s a picture I took of a part of the screen I know is supposed to be black, but has artifacts of my Fedora wallpaper and Firefox session.

It sounds like it did not blank the screen/did not actually suspend.

There is a package xorg-x11-drv-nvidia-power on rpmfusion that is related to suspend/hibernate issues. Instructions are here for what it is and what to do with it.

I installed this package, but unfortunately it didn’t solve my issue. I have noticed, however, that when clicking suspend, Fedora doesn’t actually suspend, instead my desktop just boots back up into the lock screen. I do suspect that this failed suspend had something to do with the burn-in, because this hasn’t happened ever before, even when I had a previous install of Fedora 35 beta. I’m betting that this package will prevent future suspend issues, but I’m now not sure how to revert this problem.

Another thing to note is that, this is only happening on 1 of my 2 monitors. When disconnected, the other monitor is perfectly fine, and shows no artifacting or “burn-in”.

Alright, after a long while of trying different things, I’ve found a temporary solution. I reinstalled the latest stable version of the drivers as well as the power scripts. This hasn’t solved me not being able to suspend properly, but now the glitches no longer appear in the same manner. Now it seems like the screen will flicker, and occasionally those glitches show up, but are temporary. While reinstalling drivers, I booted into Fedora without them active, and found that there was no problems or glitches whatsoever, so this confirms the belief that it’s not a monitor problem, its either a driver problem or potentially a GNOME problem.

I suspect 2 things are required. I do not suspend my systems so cannot say first hand. I also use only the drivers from rpmfusion so have no other experiences to compare to.

  1. It is possible that all the drivers must be installed from rpmfusion for that package to work properly. The drivers from rpmfusion have been tweaked to work with fedora and it is possible that drivers from other sources do not have the same tweaks.
  2. All three services installed by that package must be activated as the instructions explain for suspend to work properly. Even though not used, I have installed that package and activated those services.

I do know from threads on this forum that there have been several instances of suspend & hibernate not working properly that were solved by the use of that package and the services it installs.

I also know from first hand experience that burn-in from leaving a monitor with a single image for long periods is permanent. While it may not be severely intrusive early on, the damage to those pixels gradually gets worse with normal usage until the user decides the monitor must be replaced.

Therefore, neither GNOME nor the extensions are the issue.

Ok, so for the most part I’ve switched to using i3 full-time and no issues. It seems to be some really weird interaction with GNOME and the NVIDIA 470.74 drivers. There was an issue with those drivers causing all sorts of problems on G-SYNC compatible monitors, like my VG249 monitor, though why I don’t experience those problems on i3, I have no idea. Seemingly, the new 495.44 drivers should fix this problem, but as it’s not in official repos just yet, I have yet to test it. “Monitor burn-in” was probably not the right way to describe what was happening, as it’s not a permanent problem. I just couldn’t find a better term to explain what was happening.

Can you upload the archive created by somewhere. ?