Nvidia graphics drivers not active after rienstall

Screenshot form my info page, I am running a portable version of fedora from a usb:

For a while now when I launched fedora it would say nvidia kernel missing, falling back to noveau, other then that it worked fine. A few weeks ago one of my monitors stopped displaying anything even though it appeared in settings and my mouse and windows would go onto the screen. I decided to uninstall and rienstall the nvidia drivers, so I went to the gnome software gui, uninstalled the nvidia drivers, then followed this guide here to install the latest drivers:

When the display settings were as seen here:

Even though all three monitors are still plugged in.

I have an NVIDIA GTX 1080, and use this portable os on a laptop with a GTX 1660ti in it daily.

Any advice on how to fix this? I everything important backed up but it would be a major pain in the arse to reformat the drive and rienstall the os. When I remove the akmod-nvidia module and try to get the nvidia drivers through the software gui I get this error:

Screenshot from 2023-11-19 17-52-44

When I disable secure boot all three monitors show the asus logo, the fedora logo and a loading circle, all at 1080p, then the resolution falls on them all, the loading circle dissapears and that is it.

Would much appreciate any help, please let me know if there is any more information that could be helpful.

The definitive instructions are these: Howto/NVIDIA - RPM Fusion

After a update from F38 to F39 it is a know issue that the drivers are not alweys rebuilt.

Try this:

sudo depmod
sudo akmods --rebuild --force

Then reboot and see if this fixes it.

Hi Barry thanks for your reply, every time I try to update from 37 I download then restart as prompted and nothing happens I am still in 37.

When I run your command I get this error:
$ sudo akmods --rebuild --force
Error: Unknown option ‘–rebuild’.
Checks the akmod packages and rebuilds them if needed
Usage: akmods [OPTIONS]
–force – try all, even if they failed earlier
–kernels – build and install only for kernel
(formatted the same as ‘uname -r’ would produce)
–akmod – build and install only akmod

Any ideas? Thanks again!

I have just tried $sudo akmods --force and that seems to have worked, will restart in a minute after I have finished backing up files.

Have rebooted and there is no change.

This may provide the fix

Thank you, leaving this post here incase someone else has this issue, but I had work to do last night and this morning so a fresh install was more expedient to fix my problems.