Missing Documents folder

I helped a friend install Fedora on his laptop. He’s been getting on nicely with it (very basic use) but I just did a screenshare with him and found he has no Documents folder, and I mean AT ALL!
No shortcut on sidebar, that’s why i noticed, assumed just the shortcut was missing but no, in Home folder all the usual folders are there except Documents!

I helped him create one in terminal, which was then locked as it was created with Sudo so he had no rights on it. So I did a rm to delete it, and we created it in the GUI instead. That’s all fine, but now he has no Documents shortcut on left sidebar in Files. Tried dragging and dropping but won’t work.

Any idea how to add it to the side bar please?

tee -a ~/.config/user-dirs.dirs << "EOF" > /dev/null
killall nautilus

Thanks, just to confirm I can just paste that into terminal with no adjustments/edits?
Great stuff if so!


1 Like

tee command not found

Also, should I paste that whole chunk into terminal in one go? Or is it several lines/commands?

That seems strange. It should be a standard command that can be seen with ls /usr/bin/tee
If that does not exist it would appear something has altered the default system installation files. The file is provided in almost every fedora system around from the coreutils package.

# dnf provides /usr/bin/tee
Last metadata expiration check: 3:31:53 ago on Thu 21 Mar 2024 05:00:27 PM CDT.
coreutils-9.3-4.fc39.x86_64 : A set of basic GNU tools commonly used in shell scripts
Repo        : fedora
Matched from:
Filename    : /usr/bin/tee
1 Like

Hi Jeff, this seems quite strange.

We ran the command:

ls /usr/bin/tee

But it returned: “No such file or directory”

I can’t imagine why it would not be there as we’ve not altered the standard installation (knowingly anyway!). Any ideas or suggestions welcome! thanks

sudo dnf -y $(rpm -q coreutils &> /dev/null && echo re)install coreutils

Is that two commands, one per line?

Hi everyone ! I know it’s an aside, but I’m actually interested in knowing how you don’t have tee which might make sense since you didn’t have a ~/Documents folder either on a Fresh Install?

Might I ask, where did you get the Fedora image from, to do the fresh install?

I ask, because this could be an issue if the user downloaded a bad image from a site not Fedora or some Google ad link.

Sorry for the interjection.

I’ve changed the above reply to a one-liner.
It was a list and a simple command in Bash terms.

1 Like

Your interjections are always welcome! (My machine has forgotten how to wake up again, seems to do it every time I update, maybe I should not update so quickly!)

Regarding the installation of Fedora, firstly it isnt mine, it’s a friend of mine I am helping start using it (blind leading the blind, oh yeah!), secondly it was installed direct from Fedora official site (I am careful about that for the reasons you’re thinking about!)

1 Like

Alright, thanks. It is still very odd that those things are not in the Image. I’m going to do some testing myself. :+1:t5:

1 Like

He ran that command but doesn’t seem to have worked…

[username@fedora ~]$ sudo dnf -y $(rpm -qcoreutils &> /dev/null && echo re)install coreutils
[sudo] password for username: 
Fedora 39 - x86_64 - Updates                     43 kB/s |  22 kB     00:00    
Package coreutils-9.3-5.fc39.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
[username@fedora ~]$ ls /user/bin/tee
ls: cannot access '/user/bin/tee': No such file or directory

Note the difference between what you posted and the command given by Vladislav. Typos cause errors.
To simplify that you could simply run sudo -y dnf reinstall coreutils

1 Like

xdg-user-dir DOCUMENTS

should tell you the Documents directory defined on your system.

In case of issue you can use


see xdg-user-dirs

Additionally, it should be ls /usr/bin/tee instead.

Thanks everyone, sorry, I’ve passed that on. Will try again with correct command(s)

1 Like

OK. commands entered correctly and now the tee folder exists. Still don’t have a Documents folder shortcut on left sidebar in file manager. Can’t see any way to add it there. tried dragging the Documents folder icon onto sidebar but will only drop inside one of the other shortcuts, can’t actually make it a shortcut in its own right. Any secret trick to this?!

Confirm the target directory actually exists:

ls -l -d ~/Documents

Verify its ownership and permissions.

Then check the contents of the config file:


There should be a line like this:


If necessary, edit the file and remove duplicates.

Be sure to relogin to apply the changes.