Minecraft broken

Minecraft within the Fedora Package Manager does not work. I have tried to run it. It doesn’t seem to have a way to access the installed version of Java 17 on the system for some reason thus the program crashes.
It seems to point to Java 11.

Who do I send this to, to make sure this is looked into and fixed?

If you have Java 17/18 installed already, you can manually point the game to the java executable by going to Installations->…(Visable by hovering over the installation you want to change)->Edit->More Options, in the launcher, and setting the executable you want to use.

You could also manually set the ‘java’ link under /etc/alternatives (Which is where /usr/bin/java pints. It’s link to a link, for some reason.), to point to the correct version. Though, this will likely get overridden once java 11 next updates.
I don’t know if directly changing /usr/bin/java would be better. It may also get overridden.

The issue seems to stem from the fact that Fedora doesn’t update the ‘java’ link to point to the java-latest package. Instead the more stable java-11 package takes precedence.