Microphone doesnt work

Im trying to use microphone in discord and in settings it doesnt work. I have sellected headset and microphone in settings but no sound is detected in settings. I have also disabled microphone in privacy.

So, you have disabled microphone in settings and you pretend to get it working when is actually disabled ? :thinking:

no, in privacy I have turned on the microphone, so that I can you it.

Does it work other places? Can you tell us more about your hardware?

  Host: fedora Kernel: 6.1.15-200.fc37.x86_64 arch: x86_64 bits: 64
    Desktop: GNOME v: 43.3 Distro: Fedora release 37 (Thirty Seven)
  Type: Desktop Mobo: Micro-Star model: MPG B650I EDGE WIFI (MS-7D73) v: 1.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: 1.13
    date: 01/09/2023
  Info: 8-core model: AMD Ryzen 7 7700X bits: 64 type: MT MCP cache: L2: 8 MiB
  Speed (MHz): avg: 3088 min/max: 3000/5572 cores: 1: 3000 2: 3000 3: 3000
    4: 3000 5: 2942 6: 2668 7: 3000 8: 3000 9: 3000 10: 5350 11: 3000 12: 3000
    13: 2791 14: 2672 15: 3000 16: 3000
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
    driver: amdgpu v: kernel
  Device-2: AMD Raphael driver: amdgpu v: kernel
  Display: wayland server: X.Org v: 22.1.8 with: Xwayland v: 22.1.8
    compositor: gnome-shell driver: dri: radeonsi gpu: amdgpu
    resolution: 2560x1440~144Hz
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: AMD Radeon RX 6700 XT (navi22
    LLVM 15.0.7 DRM 3.49 6.1.15-200.fc37.x86_64)
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Device-4: Micro Star USB Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.1.15-200.fc37.x86_64 running: yes
  Sound Server-1: PipeWire v: 0.3.67 running: yes
  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp14s0 state: down mac: 04:7c:16:4f:86:4b
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e
  IF: wlp15s0 state: up mac: f0:a6:54:4e:f5:53
  Device-1: MediaTek Wireless_Device type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 1.14 TiB used: 209.95 GiB (18.0%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 250GB
    size: 232.89 GiB
  ID-2: /dev/nvme1n1 vendor: Corsair model: MP600 PRO NH size: 931.51 GiB
  ID-1: / size: 231.3 GiB used: 37.04 GiB (16.0%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 249.9 MiB (25.7%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 231.3 GiB used: 37.04 GiB (16.0%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 44.2 C mobo: N/A
  Fan Speeds (RPM): N/A
  GPU: device: amdgpu temp: 35.0 C device: amdgpu temp: 37.0 C fan: 0
  Processes: 424 Uptime: 42m Memory: 30.51 GiB used: 3.14 GiB (10.3%)
  Shell: Bash inxi: 3.3.25

my headset is steelseries artis Nova 1 and I have tried the microphone in my cellphone in it works fine

Does it only not work in Discord, or does it also not work otherwise?

it doesnt work in discord and settings. no sound is register in sound settings even thou I’ve sellected my headset in both sound and microphone.

Does the headset feature multiple modes in the sound settings? My Emeet Bluetooth headset is like this and sometimes you have to select the correct mode for it to work with the microphone.

no it just the audio jack, no bluetooth.

The connection shouldn’t matter (unless your device is using a 3.5mm connector). For example, if your headset uses a USB connection, you may still see multiple modes in the system settings:

In the screenshot:

  1. The currently selected device (my Emeet headset). For this headset, it actually shows up as two different devices.
  2. The device mode (labelled ‘Configuration’ in Sound settings). For my headset, there are multiple modes available (using different codecs).

In the mode shown in the screenshot, the microphone doesn’t work. This is because it set to only play audio, as opposed to receiving it. In my case however, the device can automatically switch to “Headset” mode when an application needs the microphone.

Your device may be similar. If it is, you’ll likely see two similar devices under “Output device”. You should also see at least one of these under “Input” in the “Input Device” dropdown. To select your headset, simply choose its coresponding device under “Input Device”.

I did select the right settings in both output and input. however I dont have the ‘Configuation’ setting in Output setting.

Edit: just found the device listed in your device report.

I’ll have to do some digging and see if I can find out if your headset is support in Linux.

any news?

Hi maasi, sorry for the delay in responding.

It seems your headset is reported to work with Linux (albeit with some glitches reported). The only possibility I can think of is that the mic is somehow muted by default (which happens with some devices), although this is unlikely.

I’d suggest installing Pulseaudio Volume Control (pavucontrol) and checking your settings from there (it can give you more granular control than the system settings).

tried them all, still doesnt work.

I’m sorry you haven’t been able to get to the bottom of this one. Hopefully someone with the same headset might see this and be able to offer further insight and assistance.