Inbuilt microphone is not working in other applications except Audacity


apart from Audacity(application) my inbuilt mic does not work anywhere be it Skype, Firefox or google hangouts.

Laptop= LENEVO(81DE) Ideapad 330 15IKB(U)
OS= Fedora 31 Workstation
My kernel version = 5.5.11-200.fc31.x86_64
AlsaMixer v1.2.2
/proc/asound/version= Advanced Linux Sound Architecture Driver Version k5.5.11-200.fc31.x86_64.

Please let me know if any other information is needed.

Any suggestions are welcomed.
Please do help.

![Screenshot from 2020-03-28 18-33-26|690x388]

Are there any other choices for the input device?
If so then you might try the alternatives to see if they work.
Also, it might be hardware/driver related and might require a short wait and another update to see if some as yet uninstalled update fixes the issue.
If all else fails then consider a bug report.

Yes, I have also tried connecting my wired earphones but the situation remains the same. Can you tell what the problem is??

Well, thank you for coming up for help :slight_smile:

What I meant was did you select the other options for input device in the settings panel and test each one individually.

I have a usb connected headset that has a both digital and analog settings, a line-out set of speakers and microphone, and HDMI in/out from my monitor. I can select each one one-at-a-time in the settings panel depending on which input or output I wish to use. Sometimes just trying different options will help identify exactly what is failing.

If the mic is working for audacity then it does not seem to be hardware or driver related, but rather configuration.
You did not state what specific applications are failing so more information is needed to identify the issue.

First, can you post the results of lsmod | grep snd as I do below to show what kernel modules are loaded to support sound? (your list is not likely as large as mine)

Then please post the output of lspci | grep Audio as below.

finally, please show the content of /proc/asound/cards, /proc/asound/devices, /proc/asound/pcm, and /proc/asound/modules
Your kernel and asound Version are exactly the same as mine.

Sure, here are the results:-

snd_seq_dummy          16384  0
snd_hda_codec_hdmi     73728  1
snd_hda_codec_generic    94208  1
snd_soc_skl           180224  0
snd_soc_sst_ipc        20480  1 snd_soc_skl
snd_soc_sst_dsp        40960  1 snd_soc_skl
snd_hda_ext_core       36864  1 snd_soc_skl
ledtrig_audio          16384  1 snd_hda_codec_generic
snd_soc_acpi_intel_match    32768  1 snd_soc_skl
snd_soc_acpi           16384  2 snd_soc_acpi_intel_match,snd_soc_skl
snd_soc_core          294912  1 snd_soc_skl
snd_compress           28672  1 snd_soc_core
ac97_bus               16384  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_hda_intel          53248  5
snd_intel_dspcfg       28672  2 snd_hda_intel,snd_soc_skl
snd_hda_codec         163840  3 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel
snd_hda_core          102400  6 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_soc_skl
snd_hwdep              16384  1 snd_hda_codec
snd_seq                86016  1 snd_seq_dummy
snd_seq_device         16384  1 snd_seq
snd_pcm               126976  7 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
snd_timer              40960  2 snd_seq,snd_pcm
snd                   102400  21 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_compress,snd_soc_core,snd_pcm
soundcore              16384  1 snd

00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)

0 [PCH            ]: HDA-Intel - HDA Intel PCH
                     HDA Intel PCH at 0xb1320000 irq 134


  1:        : sequencer
  2: [ 0- 0]: digital audio playback
  3: [ 0- 0]: digital audio capture
  4: [ 0- 3]: digital audio playback
  5: [ 0- 7]: digital audio playback
  6: [ 0- 8]: digital audio playback
  7: [ 0- 9]: digital audio playback
  8: [ 0-10]: digital audio playback
  9: [ 0- 0]: hardware dependent
 10: [ 0- 2]: hardware dependent
 11: [ 0]   : control
 33:        : timer
00-00: Generic Analog : Generic Analog : playback 1 : capture 1
00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
00-08: HDMI 2 : HDMI 2 : playback 1
00-09: HDMI 3 : HDMI 3 : playback 1
00-10: HDMI 4 : HDMI 4 : playback 1

0 snd_hda_intel

Also here, are few sreenshots from PulseAudio Volume Control, if these might help finding the error:-

I have the same issue, tried downgrading Alsa and pulse audio, updated to latest kernel etc.
Would love to see a solution. My outputs are very much similar to those posted above.

I don’t see anything I can point to as the cause.
However, I do not use anything except the built in system volume controls and no mixers. Thus your pulse audio screenshots don’t help me except for seeing the settings.

The only clue they provide is the second screenshot (input devices) shows the microphone volume at about 30%. I would suggest increasing that setting closer to 100% and see if there is a difference.

Hope that helps because everything else you provided appears perfectly normal and all other volumes are set at 100%.

It appears you probably have an hdmi port since the devices config shows digital audio capture and playback. If so then you could likely use an external monitor with built in speakers and have sound and microphone there as well.

No it didn’t work, even at 80% or 100%.

Any more suggestions on this problem?? Please do help.

Can we change drivers here, like we do in windows??
Will it help??

I want my inbuilt microphone to work in my laptop. Please I want my use microphone like I did in windows. Please help.

I admit I am at a loss. With everything you have shown me there is nothing that jumps out.

If this is pulse related you might try removing “~/.config/pulse/” (the default configuration directory and files that pulse creates when it first starts) then reboot and see if the new config that pulse will create fixes the issue.
Beyond that I can make no further suggestions at this time.

You might look at this link