Mac OS switched to default boot option after Apple Software Update

First off, I wanted to say I’ve had a blast using Fedora on my M1 Pro MBP. The issue I’m running into (probably) isn’t Fedora/Asahi’s fault, as it started after updating my Apple partition.

Since I still use my Mac OS partition in my workflow, I try to keep it up to date. However, with the last software update, my machine no longer boots into the Fedora partition by default. This even affects when I reset to apply updates.

If this has been covered before, I apologize. I checked the Docs and tried to find another post describing this issue.

Is there a workaround for this with my current install? I don’t mind re=installing if I have to, what data I have on here is already backed up.

If it helps: I ran my install on Mac OS Sonoma, and updates before this one didn’t cause the same problem. I also did an upgrade to 39 from 38 about a week before the Mac update messed with my load order.

Hi Rinwolf,

Had the same occurrence. Found the answer on Reddit - Dive into anything

Asahi-bless is your friend

Enjoy Fedora remix!


1 Like

This is a normal occurence.

You can use sudo asahi-bless as mentioned by @klinkers , but there is also an option in the macOS settings application to change the default boot OS. So it does not matter which OS you’re currently using, you can easily change the default.
(Documentation: Change your Mac startup disk – Apple Support (UK) at “Set a default startup disk”)

But even if the computer is not turned on, you can simply long-press the start button until you get to the OS selection screen, and then long-press the Option key. You will see that the labels now change to “Always Use”. Simply keep pressing the Option key and select your default OS here. This is usually the simplest way to change after a macOS upgrade in my opinion.
(Documentation: Use macOS Recovery on a Mac with Apple silicon – Apple Support (UK) at " Set the default startup volume and restart your computer")

1 Like

Thank you @klinkers and @samutpada191 ! That worked for me. It’s also good to know I can do it from the Mac OS side.

edit: apparently I can only have one solution tagged- I’ll tag the additional info on alternate options in case someone needs that. Happy to change if needed