Login in Gnome (GDM) not possible anymore; fallback to login screen

After system-upgrade to F39 I am not able to login into gnome with the User I made the update.

What I did so far:

Tested an other user (inkl. new one) … this works.
Reset the Gnome Desktop to default, with the failing user sudo dconf reset -f /org/gnome/ works not.
Changed from GDM to Lightdm, this works not.

Tried to open a Firefox from terminal, get an error :
Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: Could not connect to wayland socket (t=0.451502) [GFX1-]: glxtest: Could not connect to wayland socket

(firefox:4568): dconf-CRITICAL **: 12:14:23.274: unable to create directory ‘/run/user/1001/dconf’: Permission denied. dconf will not work properly.

But Firefox opens anyway?

  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Display: wayland server: X.Org v: 23.2 with: Xwayland v: 23.2.0
    compositor: gnome-shell v: 45.rc driver: X: loaded: modesetting
    unloaded: fbdev,vesa dri: crocus gpu: i915 resolution: 2560x1080~60Hz
  API: OpenGL v: 4.2 Mesa 23.2.0-rc3 renderer: Mesa Intel HD Graphics 4000
    (IVB GT2)

ligthdm log shows everything ok while logging in. But as mentioned the User 1000 falls back to login.

What else could I test?

I suspect you will do more help in the test mailing list.
Folks there will want to help debug and fix this.

1 Like

I made the update today and the user I made the upgrade from F38 to F39 still falls back to the log in.

It is really strange … are there some more tests’t/tools I could do/use?
Is there a log who registrations the whole login process? As I know the bootlog mainly ends with the gdm login?!

If you login with another user and it works, it looks like there is an issue with your main user. Something in the home directory, config files, GNOME extensions (even if they are supposed to be automatically disabled if something goes wrong).
What about journalctl? Don’t you spot any meaningful logs?

1 Like

I still have to go thru the journal I saved before solving the issue. I saved it now after it works so that i can compare.

Now it works again, after I did reset the gnomw session while opening the therminal with alt + ctrl F2. The first time I made it in the terminal opened with su username.

Thaks for your answer.

Could you elaborate on how you reset the gnome session? I’m seeing this on one of my machines too, but only when I try to use X with Gnome (because Zoom + Anydesk still do not support Wayland AFAIK). Thanks.

1 Like

Ctrl & Alt & F2 login as user who falls back on login,

sudo gsettings reset org.gnome.shell disable-extension-version-validation

You can also check before resetting, if it is possible to just disable the validation of extensions.
This I not tested separately.

1 Like

does not work here !

What does not work? The reset or just disabling the extension-version validation? Or the command as it is there?

I’d file a new question with details—there are a number of reasons why things may not work. Extensions are usually the issue, but if they’re not, there’s something else that needs diagnosing.

All my extensions are disabled too, but X still crashes. So I need to also look into what else may be wrong.

1 Like

the reset command runs in an error (something with dbus and xorg $Display)
disabling the extension works

checking the journal shows a lot of core dumps/stack traces related to gnome shell

+++EDIT +++
running the reset command again to fetch the exact error message turns out: no error message this time …Aaaarrrggghhh

fetched the journal and ask where to put it

for my taste: best in an RH bugzilla

is there already one open ?
pointer ?
otherwise I would fill one

+++EDIT 2 +++

it seems a BZ is already there (?)

1 Like

with today updates this bug is fixed

My problem I had was also with Wayland. The bugzilla link is restricted to xorg.

I do not have any problems with wayland.
it’s also a pure Intel box, RKL though