How can I re-enable the Xorg option in GDM?

Hello! I recently upgraded my buddy’s PC to Fedora 39. The new version disabled signing in with the Xorg session (only available for Classic). Of course, as he is an Nvidia user, his desktop was completely glitching out on Wayland, with windows flickering and being totally unstable. He also really didn’t like Classic. So, I downgraded him back to Fedora 38. Unfortunately, the hidden Xorg option stuck, meaning he has no way of logging in to his desktop to play games. How can I re-show the “GNOME on Xorg” option for him on Fedora 38? Please send help!

Bugzilla Report

If you see both ‘GNOME’ and ‘GNOME on Xorg’, the ‘GNOME’ session is using Wayland. If you only see ‘GNOME’, then GDM itself is running under X, and that is an X11 session.

GDM has a complicated algorithm to merge the contents of /usr/share/wayland-sessions and /usr/share/xsessions that results in this behavior.

P.S. To my knowledge, ‘GNOME on Xorg’ has not been removed from F39. I don’t think it has even been formally proposed for a future release yet.

I’m sure you’re right, but in this case, something else is going on. The options in GDM are as follows:

  • GNOME Classic
  • GNOME Classic on Xorg

Logging in to “GNOME” brings me into a Wayland session, confirmed by bugs, as well as the “About” page in Settings. I found this Fedora doc and followed it. It only boots me into “GNOME Classic on Xorg”. I can’t just use the normal desktop on Xorg for some reason, even when forcing it.

I’m going to try using the knowledge from this post to add the desktop entry back to /usr/share/xsessions/. Hopefully, I can just copy from a working system and paste into here since GNOME is pretty standard. I’ll let you guys know if it works. Wish me luck!

PS: Please fix this upgrade bug, Fedora devs!!! He seriously had no display output until I chrooted in and ran dnf reinstall kernel-core, plus this!! Love you guys, Fedora’s still the best!

The entries in /usr/share/xsessions/ are provided by the packages gnome-classic-session and gnome-session-xsession. If they are missing, try to install or re-install those packages.