Login and screen brightness issue with Fedora 37

Hello everyone!

I just bought a new laptop for work(msi modern 14) that runs on a ryzen 5825u with a integrated gpu. Because this laptop came without an OS I wanted to try out Linux but I’ve been running into some weird problems.

  1. when the laptop goes into sleep mode(close lid or inactive), or if I use the systemctl suspend command in the terminal, I am unable to log back in, eventually the screen goes black and the only option for me, is to do a hard reboot by holding down the power button.

this does not happen when i lock screen using shortcut windows button + l

  1. when I change the screen brightness, it will keep adjusting the screen brightness periodically. For example: I turn the screen brightness from 100% to 95% using the fn button, 1 min later, without me touching anything it will go from 95% to 90%

if I do not touch the screen brightness this does not happen.

I have tried
Linux mint
and now Fedora

all have the same problem.
with the first 3 distro’s, the screen did not go black after trying to log back in, but all images(user image, power image, etc) would show blank and the login would be unresposive.

Hi! I’m not sure if my situation was the exact same as yours (a lot of different variables, but maybe the same root cause?), but my wife bought a computer for her work (a Lenovo IdeaPad), and had a similar experience on Windows 11. Apparently somehow the combination of CPU, firmware, motherboard, etc. “advertised” to the operating system that it was capable of one type of sleep mode, but actually couldn’t successfully wake back up from it.

In her case, I had to do the Windows version of this same process, but one way to find out what your computer thinks “sleep mode” means is to try cat /sys/power/mem_sleep from the terminal, and see if there are multiple options listed, and if s2idle is the one currently defaulted (in brackets). There could be different avenues to go from there, if that is in fact the issue, but at the very least knowing how your computer is treating “sleep” may help figure out what the exact problem is to diagnose.

On the screen brightness…could you run inxi -Fzxx (install the inxi package if needed) and post the results (in the “Preformatted text” mode from the editor toolbar here) to see what sort of graphics setup is specifically in there and how Fedora Linux is seeing it?


There appears to have been a switch on some of the newer systems to no longer support the S3 (suspend) power mode. A search on this forum for the problems reported, particularly for failure to suspend, should give you some ideas of how prevalent the issue is and what may be done as a workaround. I do not have an affected laptop so cannot assist other than to point you in the proper direction to get assistance.

Thank you for the suggestion! when I type cat /syspower/mem_sleep into the terminal I get one option which is s2idle

here is my inxi - Fzxx

  Kernel: 6.1.18-200.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-25.fc37 Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_x11
    dm: SDDM Distro: Fedora release 37 (Thirty Seven)
  Type: Laptop System: Micro-Star product: Modern 14 C5M v: REV:1.0
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-14JK v: REV:1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: E14JKAMS.103 date: 08/16/2022
  ID-1: BAT1 charge: 16.8 Wh (44.8%) condition: 37.5/37.8 Wh (99.2%)
    volts: 11.3 min: 11.4 model: MSI BIF0_9 serial: N/A status: discharging
  Info: 8-core model: AMD Ryzen 7 5825U with Radeon Graphics bits: 64
    type: MT MCP arch: Zen 3 rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 16 MiB
  Speed (MHz): avg: 1637 high: 2000 min/max: 1600/4547 boost: enabled cores:
    1: 1600 2: 1600 3: 1600 4: 1600 5: 1600 6: 1600 7: 1600 8: 1600 9: 1600
    10: 2000 11: 2000 12: 1600 13: 1600 14: 1397 15: 1600 16: 1600
    bogomips: 63883
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Barcelo vendor: Micro-Star MSI driver: amdgpu v: kernel
    arch: GCN-5 pcie: speed: 8 GT/s lanes: 16 ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 03:00.0 chip-ID: 1002:15e7 temp: 34.0 C
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.8
    compositor: kwin_x11 driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x142b res: 1920x1080
    dpi: 158 diag: 354mm (13.9")
  API: OpenGL v: 4.6 Mesa 22.3.7 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.1.18-200.fc37.x86_64) direct-render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 03:00.1 chip-ID: 1002:1637
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Micro-Star MSI
    driver: snd_rn_pci_acp3x v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 03:00.5 chip-ID: 1022:15e2
  Device-3: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 03:00.6 chip-ID: 1022:15e3
  Sound API: ALSA v: k6.1.18-200.fc37.x86_64 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes
  Device-1: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel pcie:
    speed: 5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 14c3:0608
  IF: wlp1s0 state: up mac: <filter>
  Device-1: MediaTek Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 3-3:2 chip-ID: 0e8d:0608
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 7.13 GiB (1.5%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVL4512HBLU-00BTW
    size: 476.94 GiB speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 25.9 C
  ID-1: / size: 475.35 GiB used: 6.87 GiB (1.4%) fs: btrfs dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 251.9 MiB (25.9%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 17.4 MiB (2.9%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 475.35 GiB used: 6.87 GiB (1.4%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 7.13 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 39.8 C mobo: N/A gpu: amdgpu temp: 34.0 C
  Fan Speeds (RPM): N/A
  Processes: 400 Uptime: 3m Memory: 7.13 GiB used: 2.65 GiB (37.2%)
  Init: systemd v: 251 target: graphical (5) default: graphical Compilers:
  gcc: 12.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm Shell: Bash
  v: 5.2.15 running-in: konsole inxi: 3.3.25

Interesting - as Jeff V said, there may be some suspend-specific troubleshooting required based on your machine seeing “Suspend to Idle” as the only possible mode. It might be worth looking at your system’s BIOS to see if it’s possible to switch to or enable other Suspend modes.

On the screen brightness - maybe a silly question, but does that behavior that you’re seeing show up when you’re changing the brightness using the slider in the system quick settings as well? And does it also happen when you increase the brightness? (Essentially, is it always going to the nearest 10% increment?)

I looked trough the BIOS and I am unable to find different Suspend modes.
The problem has also seemed to change somewhat after the last update. After suspend the screen returns to the normal functional login screen, I am able to log back in, but when I do , the screen goes black again.
If I do not log in, the screen goes black regardless after about 30-60 sec.
I did see SVM mode was enabled in the BIOS, after turning that off and trying to reproduce the suspend issue with systemctl suspend it showed me this screen

then after pressing Ctrl+Alt+F1, it went back to a black screen and had to hard reboot.

Screen brightness issue:
there’s no consistent variable other than the 5% incremental increase/decrease.

  • this happens both with Fn+F9(B down) and Fn+F10(B Up)
  • the problem also happens with the slider
  • if I decrease the screen brightness, its also possible for the screen brightness to increase by 5% increments. This also works the other way around but it will never go → up, down, down or down, up, down etc.
  • the times it will increase/decrease seems random but the problem does become worse the more I increase/decrease screen brightness.

Found a solution to the random Screen brightness on askubuntu:

I added these lines in /usr/share/X11/xorg.conf.d/10-quirks.conf and it solved the problem

Section "InputClass"
 Identifier "Spooky Ghosts"
 MatchProduct "Video Bus"
 Option "Ignore" "on"

Now just the suspend issue… I managed to login before the screen turned black but then it just freezes on the desktop.

Edit* Updated my Bios to see if it would resolve anything,
now I get the “screen locker is broken” message consistently.
Ctrl+Alt+f1 gives me a black screen.

when I use Ctr+Alt+F1 when my system is running normally it will also go into the black screen, Ctrl+alt+F2 brings me back to my desktop