Live usb Stick does not start on Microsoft Surface Pro 6

I wanted to install Fedora on my Microsoft Surface Pro 6. Unfortunately I am having problems installing it.

After the booting on the usb stick I get to a grub like screen where I can choose if I want to install Fedora or test the medium and install fedora. No matter what I choose the screen turns black afterwards (but a little - in the top left) and nothing happens.

Tried steps so far to fix the problem:

  • Tried a different USB Stick
  • Tried a different USB Port
  • Flahsing with Fedora Media Writer
  • Flashing with Rufus
  • Verified correct download of ISO
  • Disabled Secure Boot

During my online research I have found out it may be a UEFI problem. Can that be?

Can someone help me?

Or at least help me on how can rephrase my question so you can help me?

Not sure if it would make a difference but try Ventoy with Partition Style set to GPT and Partition Configuration to NTFS

Hello @saaabo ,
Was this install done with a USB created using Fedora Media Writer? If not please try that approach first. Also, I do remember some discussion around here regarding issues with installing to the Surface devices but you would need to search the forum.

It looks more like a graphics hardware issue. Try at the grub menu Troubleshooting and the select basic graphics or something similar.

According to the first post it was – among other things that was tried.

Sorry missed that.

I will try this, and report back once I have done it. Thank you.