Leaving hibernation automatically

Hi all,

I’m currently running Fedora 34 LXDE on an ASUS EeeBook X205TA.
Ever since installation, I have been having problems with hibernation. The computer is supposed to be able to be running over a week when hibernating but I never get over a day…

The problem I have, is that when I suspend, the computer does go to hibernation. But any change in the state of the lid (open → close / close → open) makes the computer leave hibernation.
While the opening of the lid should trigger a computer awakening, I think it shouldn’t be the case when it gets closed (heck it should even be possible to go to hibernation then), but I didn’t find any way of parameterizating it.

I have not been able to find any troubleshooting regarding this be it in english or in french…

Thanks for your help!



I believe Fedora 34 by default doesn’t have hibernation enabled. Except if we customize it by creating physical swap partition and not using zram as swap.

Maybe this is why your computer can’t running over a week because it’s not in hibernate state but on suspend only.

Hi @oprizal and @thibault.hiron Some docs about hibernation, How to enable hibernation on Fedora It is the swap!

1 Like